LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2003, 04:17 PM   #1
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
Installing Swat from Samba


In trying to install samba and I want to be able to use Swat.
When i run 'rpm -iv swat-2.2.7-1.i386.rpm'
It gave me a list of failed dependencies.

So i installed the apt-get program, and synaptic, and through it, I installed everyting, so now for samba-swat is says package is installed.
But if ti is installed, how do i run it?
And i tried to redo the rpm install, and it have meth elist of 5 failed dependencies again.
Shouldn't apt-get have installed all those packages?

Thanks
 
Old 10-12-2003, 01:22 AM   #2
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
sorry to bump, but anyone?
 
Old 10-12-2003, 03:36 AM   #3
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
to run swat, open up a browser and type in the address bar:

http://localhost:901

type in root for username and the root password.

also make sure swat is set to run. for redhat 7.3 swat isn't configured to run by default. to make it run on my version, i had to go into the service configuration gui and check the box marked SWAT. that starts swat. to kill swat, uncheck the box marked SWAT. but it maybe different in redhat 9.0. also bear in mind, i don't use redhat's samba packages either. i always use the packages from samba.org. they're usually more recent than redhat's versions and in one nice rpm package as opposed to downloading the serveral packages the way redhat does.

edit: this is the command for the service conf gui tool:

/usr/bin/serviceconf

Last edited by megaspaz; 10-12-2003 at 03:37 AM.
 
Old 10-12-2003, 11:13 AM   #4
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Hi, thanks, you are right, it was unchecked in the service configuration tool.

Sorry to ask this really newb question, but when you say local host, you dont actually mean 'localhost'right, you mean ip adress?

But anyway, it doesnt work for either...also the files that I think are supposed to be there aren't...But i the apt-get program it says swat is installed?
 
Old 10-12-2003, 12:57 PM   #5
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
i really do mean localhost. no ip address because swat is being run from your computer. not on the web. as far as getting swat to work for you, i don't know. i remember one person using apt-get to update samba and it not working. i always get the samba packages from samba.org and it always works for me after making sure to check if swat and smb are enabled (smb you can restart).
 
Old 10-12-2003, 02:33 PM   #6
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Well orignally i tried to install swat from rpm...but there was a whole bunch of dependencies, and when i tried to install those, there was another list of dependedncies for each.

Eventallu, I coulnd't install them, and i did some reading, and someone said that one could use apt-get to do it all easily. But after using it, it doesnt seem like swat really is installed, even though it says it is.

Im getting very frustrated, because I can't fgure out what to do

On the samba.org website, it is VERY not newbi-friendly, i don't really understand lost of the documentation, and there is very little doucmentation that I could find on SWAT, which i understand is a program to use samba, right?

I guess I could not sue swat, and just edit the ocnfig file fo samba, but it seems very hard to do.
 
Old 10-12-2003, 03:57 PM   #7
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
when i do http://localhost:901

i get to this garbage profitleads.com website...
 
Old 10-12-2003, 05:28 PM   #8
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
In your /etc/xinetd.d directory there needs to be a file named "swat", whose contents should be very similar to:
Code:
# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
#              to configure your Samba server. To use SWAT, \
#              connect to port 901 with your favorite web browser.
service swat
{
        disable = yes
        port            = 901
        socket_type     = stream
        wait            = no
#       only_from       = 127.0.0.1
        user            = root
        server          = /usr/sbin/swat
        log_on_failure  += USERID
}
If you have a static IP address, try connecting (on port 901) to that instead of localhost. For example:

http://192.168.0.3:901
 
Old 10-13-2003, 01:02 AM   #9
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Yes, that file is there, except
disabled = no

i have a static ip, but it says connection was reufesed when I put in my ip:901
 
Old 10-13-2003, 06:04 AM   #10
ReefShark
Member
 
Registered: Oct 2003
Location: the Netherlands
Distribution: Arch Linux, Ubuntu server
Posts: 145

Rep: Reputation: 15
Just asking the obvious; is xinetd running at all?
# ps -ef | grep inetd

If you change anything in the config-file, you have to make the daemon reread its config-file:
# kill -HUP PID
(where PID is the proces-id-number you found with the 'ps' command)
 
Old 10-13-2003, 11:24 AM   #11
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Yes...the xinetd is running......

[robert@localhost robert]$ ps -ef |grep inetd
root 1803 1 0 Oct12 ? 00:00:00 xinetd -stayalive -pidfile /var/
run/xinetd.pid
robert 23935 23892 0 12:20 pts/0 00:00:00 grep inetd



so I should
kill -HUP 1803?
 
Old 10-13-2003, 11:32 AM   #12
ReefShark
Member
 
Registered: Oct 2003
Location: the Netherlands
Distribution: Arch Linux, Ubuntu server
Posts: 145

Rep: Reputation: 15
If you force xinetd to reread its config-files, that would be the way to do it.
In the near future, if ever having to make xinetd reread its config, enter
# kill -SIGHUP `/var/run/xinetd.pid`

Take a few minutes to read the kill manual too ('man kill').

I posted 'kill -HUP' but that was not the correct command. Changed it to 'kill -SIGHUP'.

Last edited by ReefShark; 10-15-2003 at 06:16 AM.
 
Old 10-13-2003, 12:18 PM   #13
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
When i did kill -HUP 1803 it didnt' seem to do anything...
i did kill 1803...which got rid of the process

But both putting in my ip and locahost still doesnt work......
 
Old 10-13-2003, 03:36 PM   #14
ReefShark
Member
 
Registered: Oct 2003
Location: the Netherlands
Distribution: Arch Linux, Ubuntu server
Posts: 145

Rep: Reputation: 15
Okay... killing the process entirely makes sure it won't work. You need to (re) start xinetd. It's probably something like /etc/init.d/xinetd start or something like that. Are you running a firewall that is blocking port 901 or something? It's really a weird problem; I've installed Samba several times, but SWAT was never an issue. In all fairness; that was a while back, SuSE 7.2 and still using inetd (not xinetd).

Hope someone can help you, because I am running out of stupid ideas...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing Samba-SWAT Dolphin2005 Linux - Newbie 1 11-18-2005 05:43 PM
Help with Samba/SWAT driesel Linux - Newbie 3 02-13-2005 09:33 AM
Samba and swat james.farrow Linux - Networking 7 04-04-2003 11:27 AM
Samba Help with Swat? Alinuxnoob Linux - Newbie 9 06-27-2002 06:38 PM
Samba Help? Installing Swat? Alinuxnoob Linux - Software 11 04-19-2002 08:49 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration