LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-16-2002, 06:33 PM   #1
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Rep: Reputation: 30
Samba Help? Installing Swat?


I been reading the book that comes with Samba. Using Samba and having problems trying to find /etc/inetd.conf Or it not there? Any Ideads Im trying to do this part listed below Thx in advance.....

2.3.1 Final Installation Steps

There are a couple of final steps to perform. Specifically, add the Samba Web Administration Tool (SWAT) to the /etc/services and /etc/inetd.conf configuration files. SWAT runs as a daemon under inetd and provides a forms-based editor in your web browser for creating and modifying SMB configuration files.



To add SWAT, add the following line to the end of the /etc/services file:

swat 901/tcp



Add these lines to /etc/inetd.conf. (Check your inetd.conf manual page to see the exact format of the inetd.conf file if it differs from the following example.) Don't forget to change the path to the SWAT binary if you installed it in a different location from the default /usr/local/samba.

swat stream tcp nowait.400 root /usr/local/samba/bin/swat swat

And that's pretty much it for the installation. Before you can start up Samba, however, you need to create a configuration file for it. Using Samba
 
Old 04-16-2002, 08:02 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
I believe in RH7+ it's xinetd.conf you want.
 
Old 04-16-2002, 08:31 PM   #3
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30
OK is there a way to confirm this file xinetd.conf to be inetd.conf?
 
Old 04-16-2002, 08:39 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
i think beginning in 7.0 or 7.1, redhat changed the inetd.conf to the xinetd.conf....so yes, the xinetd.conf is the inetd.conf that book is referring to. if you check the date on the book, its probably dated and published in 2000 or earlier, before RH 7.0 or later came out..

Last edited by trickykid; 04-16-2002 at 08:40 PM.
 
Old 04-17-2002, 04:10 AM   #5
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
It isn't just Redhat that made the change to xinetd, I think it's a general evolution regardless of distro (my Mandrake 8.0 box also uses xinetd). The two files are quite different; here's a link which talks about enabling SWAT if you're using xinetd: http://samba.linuxbe.org/en/samba/learn/swat.html.

<edit>
fsck! I just tried to verify that link and found that they've rearranged their site. It'll probably take a little more digging on the site to uncover the article..snort!
</edit>

Last edited by DMR; 04-18-2002 at 07:03 PM.
 
Old 04-17-2002, 11:52 AM   #6
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30
I have edit those two files
added swat 901 /tcp in /etc/services
[B]added swat stream tcp nowait400 root /usr/local/samba/bin/swat swat in xinetd.conf

and then I try to use the web browser to connect to
http://localhost:901

and I get this error An error occured while loading http://localhost:901:
Could not connect to host localhost (port 901)

What am I doing wrong?
 
Old 04-17-2002, 01:44 PM   #7
PostDeals
Member
 
Registered: Mar 2002
Location: New Jersey, USA
Distribution: Suse 8.0
Posts: 39

Rep: Reputation: 15
i have samba working fine would it help if you got my configurations? i am not sure how to help you exactly. I can ask a friend who runs a linux site and maybe he can help you out. would you mind if he emailed or pm you?
 
Old 04-17-2002, 05:51 PM   #8
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30
Sure any kind of help would be nice. I mean IM a noob and proably a dumbass. I just wondering after I edit thoose two files I should at least be able to get to that site...????? But changing the two files I should at least be able to connect to
or get the SWAT LOGIN? right? SO what am I doing wrong?

Last edited by Alinuxnoob; 04-17-2002 at 06:10 PM.
 
Old 04-18-2002, 01:13 PM   #9
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30
*BUMP

So any Ideas why Swat is not working? after I edit the two files?
 
Old 04-18-2002, 07:11 PM   #10
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
xinetd is modified differently than inetd:
Quote:
If working with xinetd instead of inetd:

Some last Linux distributions have introduced a new version of the inetd daemon. This daemon, called xinetd, must be configured using a different way. The main configuration file of xinetd is typically /etc/xinetd.conf. On RedHat 7.0, this file holds some default parameters and a reference to a directory :

includedir /etc/xinetd.d

After having edited the /etc/services file as explained above for inetd, you will create into the /etc/xinetd.d directory (or your own distribution equivalent) one file called swat. This file will contain the following information :

service swat
{
port = 901
socket_type = stream
wait = no
user = root
server = /usr/local/samba/bin/swat
log_on_failure += USERID
disable = no
}

To pass a switch to the command you will add a line called server_args = <list of switch> after the server line above.

If you are using Linux to run SWAT, you must also add the following information to be able to use SWAT in authentication mode. Because SWAT is using the PAM (Pluggable Authentication Module) system, you need to configure the PAM sub-system to be used by SWAT. So you will create a file called samba in the /etc/pam.d directory. This file will contain the following two lines :

auth required /lib/security/pam_pwdb.so nullok shadow
account required /lib/security/pam_pwdb.so
If you still have trouble accessing swat from your browser, you can try:
http://127.0.0.1:901 or
http://xxx.xxx.xxx.xxx:901 (replace the "x"es with your NIC's IP)
 
Old 04-19-2002, 11:35 AM   #11
Alinuxnoob
Member
 
Registered: Feb 2002
Location: Van city
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30
OK I got it to come up I guess I had to restart
swat with the command service xinetd restart?
But I dont know if this is what I was sopose to do
or if following your instructions made it work?
thx U
 
Old 04-19-2002, 09:49 PM   #12
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
I don't recall having to restart xinetd when I configured swat, but it was a long time ago so I can't say for sure. Whatever you did, you did it right though, and that's a Good Thing.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing Samba-SWAT Dolphin2005 Linux - Newbie 1 11-18-2005 06:43 PM
Help with Samba/SWAT driesel Linux - Newbie 3 02-13-2005 10:33 AM
Installing Swat from Samba Tyir Linux - Newbie 13 10-13-2003 04:36 PM
Samba and swat james.farrow Linux - Networking 7 04-04-2003 12:27 PM
Samba Help with Swat? Alinuxnoob Linux - Newbie 9 06-27-2002 07:38 PM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration