LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2003, 10:44 AM   #1
GDuru
LQ Newbie
 
Registered: Oct 2003
Location: Germany
Distribution: Mandrake
Posts: 2

Rep: Reputation: 0
GTK 1.xx-2.4 incompatibility


Hi,

How can I compile a program that needs GTK 1.xx when I have allready GTK 2.4 installed?
I hope it is possible without removing GTK 2.4 and installing an older version.

Thank you

GDuru

Last edited by GDuru; 10-17-2003 at 10:46 AM.
 
Old 10-17-2003, 11:16 AM   #2
jkobrien
Member
 
Registered: Jun 2003
Location: Dublin, Ireland
Distribution: Slackware, LFS, Ubuntu, RedHat, Slamd64
Posts: 507

Rep: Reputation: 30
In priniciple there's nothing stopping you having several versions of a program at the same time. Have a look at the rpm manpages, I've had several different versions of the kernel installed at the same time, so it should be fine for gtk too.

Have the rpm for gtk-2.4 handy, just in case it all goes wrong. You should be able to get rpms for earlier versions from any of the mandrake mirror sites. You'll have to figure out how to get the program that requires it to look at the 1.xx version rather than the 2.4.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Router incompatibility? PenguinPride Linux - Networking 1 11-19-2005 03:32 PM
how to compile programm for suse 9.3? moog Linux - Newbie 6 10-16-2005 08:42 PM
GTK 1.xx-2.4 incompatibility GDuru Linux - Newbie 1 10-18-2003 06:21 PM
incompatibility with Windows2000 j_topen Linux - Software 1 04-30-2003 04:59 PM
RH 8 and multimedia = incompatibility? morbius Linux - Distributions 2 11-27-2002 03:07 AM


All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration