LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2003, 04:55 AM   #61
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64

OMFG... *MasterC Slaps himself in the forehead...

Just read over the Release Notes (which I SOOOO should have waaaayyyyy back...) and here's what we are gonna do:

As root, download this file:
http://download.nvidia.com/XFree86/n...0-0261.src.rpm

Make sure you are in the directory where you just downloaded it to and type this (as root):
rpm --rebuild NVIDIA_nforce-1.0-0261.src.rpm

When it's complete you'll see something similar to this (the location of the file might be different):
Wrote: /usr/src//RPMS/i386/NVIDIA_nforce-1.0-0261.rpm
So then you just need to change to the directory it writes that file to:
cd /usr/src/RPMS/i386

In the example above, and then type:
rpm -i NVIDIA_nforce-1.0-0261.rpm

And you are done....



Can you believe that? This does assume all those things work out without warnings...

Anyway, give that a go, I'll clarify anything I know I went a little fast here, just wanted to get it out to you soon.

Cool
 
Old 07-27-2003, 04:56 AM   #62
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by strider_D_3000
where do i find the file modules.conf to post it up
If the above doesn't work, modules.conf is located in /etc, so to read it you would type:
less /etc/modules.conf

And it will open it up for reading.

Cool
 
Old 07-27-2003, 04:56 AM   #63
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by MasterC
/sbin/lspci is the command, you just type it exactly like I have shown above. First be in your root's home directory, to get there type this exactly:
cd ~
And press return.

Then type:
/sbin/lspci > lspci.output

Cool
after i type that what do i do?
 
Old 07-27-2003, 04:58 AM   #64
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by MasterC
If the above doesn't work, modules.conf is located in /etc, so to read it you would type:
less /etc/modules.conf

And it will open it up for reading.

Cool
dude is there a way to copy the msg and pase ie ctrl+c like in windows or do i have to type all that?
 
Old 07-27-2003, 05:00 AM   #65
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yeah, you just highlight and then click with the middle button on the mouse. Highlighting something is the equivilent to pressing CTRL C Then pasting is done with the mouse, both buttons if there is no middle button (the scroll counts as a middle button).

Cool
 
Old 07-27-2003, 05:01 AM   #66
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by strider_D_3000
after i type that what do i do?
Quote:
Originally posted by MasterC
What do you have (I'm surprised we haven't established that yet )?

As root, type this, exactly like this:
cd ~ (the press return)
lspci -vv > lspci.output
And post up everything that now lives in a text file in your root's home directory, do that by typing the following:
less /root/lspci.output
And post up what you've got.

And tell me anything you can about your hardware setup, what you want to do and what seems to be the problem (I am really really amazed we haven't established any of this yet ).

Cool
 
Old 07-27-2003, 05:03 AM   #67
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by MasterC
OMFG... *MasterC Slaps himself in the forehead...

Just read over the Release Notes (which I SOOOO should have waaaayyyyy back...) and here's what we are gonna do:

As root, download this file:
http://download.nvidia.com/XFree86/n...0-0261.src.rpm

Make sure you are in the directory where you just downloaded it to and type this (as root):
rpm --rebuild NVIDIA_nforce-1.0-0261.src.rpm

When it's complete you'll see something similar to this (the location of the file might be different):
Wrote: /usr/src//RPMS/i386/NVIDIA_nforce-1.0-0261.rpm
So then you just need to change to the directory it writes that file to:
cd /usr/src/RPMS/i386
In the example above, and then type:
rpm -i NVIDIA_nforce-1.0-0261.rpm

And you are done....



Can you believe that? This does assume all those things work out without warnings...

Anyway, give that a go, I'll clarify anything I know I went a little fast here, just wanted to get it out to you soon.

Cool
unknown option --rebuild now what?
 
Old 07-27-2003, 05:06 AM   #68
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.co#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
aliasound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 |
| :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) eth0 nvnet
eth0 nvnet
eth0 nvnetnf (END) alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
aliasound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 |
| :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) eth0 nvnet
eth0 nvnet
eth0 nvnet
 
Old 07-27-2003, 05:09 AM   #69
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
That's crazy. I just checked the man page, it's listed there for sure....

rpm --version

Post up what version you are using.

Cool
 
Old 07-27-2003, 05:09 AM   #70
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
there isnt anything writen in lspci.output
 
Old 07-27-2003, 05:11 AM   #71
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by MasterC
That's crazy. I just checked the man page, it's listed there for sure....

rpm --version

Post up what version you are using.

Cool
RPM version 4.2
rpm --rebuild NVIDIA_nforce-1.0-0261.src.rpm
--rebuild: unknown option
gonna reboot and try again

Last edited by strider_D_3000; 07-27-2003 at 05:22 AM.
 
Old 07-27-2003, 05:22 AM   #72
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by strider_D_3000
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.co#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
aliasound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 |
| :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) eth0 nvnet
eth0 nvnet
eth0 nvnetnf (END) alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
aliasound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 |
| :
#alias sound-slot-1 nvaudio
#alias usb-interface usb-ohci
alias eth0 8139too
alias eth0 nvnet
/etc/modules.conf (END) eth0 nvnet
eth0 nvnet
eth0 nvnet
Wow! That is sure, uh, different?

Let's edit a few things ok?

I'm gonna chop that up:
Code:
alias usb-interface usb-ohci
#alias eth0 8139too
alias eth0 nvnet
alias sound-slot-1 nvaudio
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
use all that instead

The comments (the # signs) mean to NOT use those.

So if you do decide to use that old device again, for whatever reason, all you have to do is comment (add the # sign) this line:
alias eth0 nvnet
And uncomment (remove the # sign) this line:
#alias eth0 8139too



Cool
 
Old 07-27-2003, 05:32 AM   #73
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Just checked RedHat's documenation, even found a book on RPM's, and here it is:
http://www.redhat.com/docs/books/max...uild-mode.html

I wish I could figure out why yours isn't responding to that function???

....
 
Old 07-27-2003, 05:46 AM   #74
strider_D_3000
Member
 
Registered: Jul 2003
Posts: 51

Original Poster
Rep: Reputation: 15
maybe i have to do in in the black one ie ctrl alt f2 instead of run ->xterm nope same thing unknow option
look its almost 3am im gonna call it a night lol hope u can think of something later

Last edited by strider_D_3000; 07-27-2003 at 05:48 AM.
 
Old 07-27-2003, 05:47 AM   #75
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Maybe... It's definitely worth a shot as if we can get that to work it will by far be easier than anything we've started otherwise

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine question?? plez help?? :cry: gammak7 Linux - Newbie 11 02-19-2004 10:38 PM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration