LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2005, 07:23 PM   #1
nanoprobe
LQ Newbie
 
Registered: Jan 2005
Location: Netherlands
Distribution: Suse 9.1/10
Posts: 29

Rep: Reputation: 15
glib


before

"*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files"


when i try to install xchat i get the above error after running ./configure


i have 2 glibs installed version 2.0 and 2.4.0, pkg-config is alredy updated, but after reading some pots i executed ( without thinking ) some commands like: xport LD_LIBRARY_PATH=/usr/local/lib, ldconfig etc... and i got this...

checking for GLIB - version >= 2.0.3... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: "Cannot find glib"

i'm now totally lost and i would be happy if someone helped me out on this...

thanx
 
Old 01-15-2005, 08:01 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
First, distribution "Linux" doesn't really help at all. You should change that in your profile.

If you wan't two glibs installed thats okay, but beware if you want to link against certain ones you are going to have to manipulate everything to force the compiler to ignore one or the other. The other problem this creates is at runtime you have to manipulate the linker to force it to find the right library to links against (this is where LD_LIBRARY_PATH comes in).

In short, the way I personally prefer is if you want an updated lib that is part of the base system, upgrade that lib instead of installing a new one in /usr/local

If you really want to use both glibs though, go with this:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:$PKG_CONFIG_PATH


that will force pkg-config to find 2.4 before 2.0
 
Old 01-15-2005, 09:01 PM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
glib is usually installed in /usr on most distros (most that I have used or tried out anyway), so to completeley replace the old glib, you would need to do
$./configure --prefix =/usr
$make
#make install
Then also do as root
#ldconfig
before trying to compile anything that checks for glib.
 
Old 01-16-2005, 08:26 AM   #4
nanoprobe
LQ Newbie
 
Registered: Jan 2005
Location: Netherlands
Distribution: Suse 9.1/10
Posts: 29

Original Poster
Rep: Reputation: 15
tanx to both of you!
It all seems to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM


All times are GMT -5. The time now is 03:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration