LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-25-2012, 02:06 PM   #1
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Rep: Reputation: 1
Findind logical volumes after formatted


Hello,

I had a crash over my CentOS 6 system.
I formatted for a mistake.

I had 3 disks,

/dev/sda
/dev/sdb
/dev/sdc

/dev/sda is a flash disk of 60 Gb, it was the one contained CentOS 6 system.
/dev/sdb and /dev/sdc are data storage. I used LVM to manage them.

I tried to install Windows on the flash unit (/dev/sda) but it says that cannot being installed.
I tried Rhel5 but it give this output

Code:
Reading all physical volumes. This may take a while...
Couldn't find device with uuid '[...uuid...]'
Couldn't find all physical volumes for volume group vg_vitanero
[...]
I didn't copied everything because the log is very long.

I would like to make a system read again data from /dev/sdb and /dev/sdc , save it and reinstall again everything.

Any suggestion?
 
Old 12-25-2012, 02:47 PM   #2
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
Quote:
I formatted for a mistake.
What did you format?


Quote:
/dev/sda is a flash disk of 60 Gb, it was the one contained CentOS 6 system. I tried to install Windows on the flash unit (/dev/sda) but it says that cannot being installed.
What was the exact error from your attempt at installing windows? Were you trying to install it over CentOS or on another partition?

Quote:
Couldn't find device with uuid '[...uuid...]'
It's looking for a uuid which doesn't seem to exist. Run blkid command to see if the uuid exists.
 
Old 12-25-2012, 03:30 PM   #3
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Original Poster
Rep: Reputation: 1
- I formatted /dev/sda (the flash disk 60 GB)

- If you wish I can copy the full error but it will need some time. Do you want the Windows error or the Linux error?
I tried to install Windows over an ex-ext.4 partition. I did not erase data from /dev/sdb and /dev/sdc . But I took off CentOs 6 with uuid and data information from /dev/sda , so, the logical volumes informations.

I have to write on a cd a centOS 6 becase I have now only centOs 5 and I don't know if is the same to look into drives.
 
Old 12-25-2012, 04:47 PM   #4
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Original Poster
Rep: Reputation: 1
Last update :

- system didn't boot. It stucked in "GRUB" monitor. I installed

- I installed Rhel6 I had on that machine. The system booted in "rescue mode"

- At the beginning of this post the boot partition was /dev/sda , now, it became /dev/sdb . I am talking about the flash disk of 60 GB.

- /dev/sda (500 GB) and /dev/sdc (1.000 GB) are now type=LVM2_MEMBER , when I try to mount them the error is "unknown filesystem type 'LVM2_member'
 
Old 01-02-2013, 12:23 PM   #5
adol83
Member
 
Registered: Jul 2012
Location: Rome
Distribution: RHEL6, CentOs
Posts: 92

Original Poster
Rep: Reputation: 1
I hope it will be useful for others.

First, I plugged a new hard disk.
Code:
cat /proc/partitions
then looking on internet i did

Code:
vgchange -ay /vg_vitanero
Vitanero is my logical volume. I tried to restore that. It isn't restored but I can do the following now and without this i command i couldn't :

1. I mounted the new device under
Code:
 /backup
2. I mounted the logical volume part of volume group vg_vitanero under /temporarydata
3. I copied what I needed from /temporarydata to /backup

unmounted devices

Restored files

Finished.

At disposal.

Davide
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Encrypting logical volumes Ezys Fedora - Installation 1 11-02-2010 03:10 PM
Are logical volumes images ? vzxen Linux - Newbie 2 07-05-2010 07:43 AM
creating logical volumes... mtsm Linux - Newbie 1 01-31-2009 07:38 AM
Can't delete logical volumes gnoop Linux - Enterprise 6 01-23-2009 12:54 PM
I did not know about logical volumes gezi Linux - Newbie 5 04-27-2005 10:26 AM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration