LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-14-2001, 04:00 PM   #1
lancesykes
LQ Newbie
 
Registered: Jun 2001
Location: Indianapolis
Distribution: RedHAt 7.0
Posts: 18

Rep: Reputation: 0
Question fatal server error


Having recently got everything working under Linux- i was feeling rather good about things and was installing a 3D graphics program (called 3cD- i think). Then the big fatal error brings me back down to earth again!!

Basically i installed the program but could not "Make" the Install as i needed the Blue Moon Rendering tool. So i then downloaded BMRT and tried to instal this. However after failing with the command below i then halted the machine and went to sleep\.

gzip -d 3cD.tar.gz.

Anyway today when i started Linux i was issued a fatal server error ( see details below) when i preceeded with the startx command.

Fatal server error
could not open default font 'fixed'

Personally i think the half installation of 3cD wiped out the default font and hence i can not use the GUI.

I have a nvidia card running on the new drivers. Should i reinstall the drivers. I hope not as that process really sucks.

Lance
 
Old 07-15-2001, 11:19 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,541
Blog Entries: 54

Rep: Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924Reputation: 2924
Open up ure XF86Config and verify the FontPaths are valid.
 
Old 07-15-2001, 11:34 AM   #3
lancesykes
LQ Newbie
 
Registered: Jun 2001
Location: Indianapolis
Distribution: RedHAt 7.0
Posts: 18

Original Poster
Rep: Reputation: 0
no joy!

I have opened up

/etc/rc.d/init.d/xfs

And the Font port is set to 7100.

Under XF86config in etc/X11 , it states

fontpath unix:\7100

Which i do believe is all correct.
I have checked Usr/lib/X11/fonts and i have the following fonts

75dpi
misc
CID
speedo

Which seems fine.
The log file for the x server error indicated that it coulod not find the Unix:\7100 font and hence crashes the server!!!

I thought this was indicating that it could not find the font port, but according to what i said above all seems fine.

Any ideas would be great as i never seem to have Linux running for more than a week at a time ( yes i am currently on my windows 2000/98 part of my machine)




 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Move 9.2 error, fatal server error:( silentwhispers Mandriva 1 12-17-2004 12:36 AM
Fatal X server error..... chunlee Linux - Software 0 10-19-2004 07:51 PM
Fatal server error sneakerpimp Red Hat 4 12-30-2003 07:25 PM
Fatal server error. Rocket_Magnet Linux - General 5 08-24-2003 02:42 PM
Fatal Server Error ludwig W Linux - General 1 05-17-2003 11:28 PM


All times are GMT -5. The time now is 11:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration