LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-23-2003, 04:58 AM   #1
Rocket_Magnet
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9.0
Posts: 9

Rep: Reputation: 0
Fatal server error.


Hey Guys/Girls,

I'm having problems apparently with my font server. I searched the forums and noone really had a definite fix for this. So I figured I'd give it a shot and see what some of you guys/girls know about it.

When loading X I get the following:

Could not init font path element unix/:7100, removing from list!
Fatal server error:
could not open default font 'fixed'

Here is a copy of my XF86Config:


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
Load "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/psaux"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell D1025TM"
DisplaySize 330 240
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



I've checked the free space available on the partition and it still has plenty of room. I had read in several places where that might be the cause, but unfortunately it wasn't. Furthermore, incase you don't know what distro it is, I'm running Redhat 9.0. If you need more information please let me know and I'll be happy to devulge any information you might need.
 
Old 08-24-2003, 03:28 AM   #2
Rocket_Magnet
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9.0
Posts: 9

Original Poster
Rep: Reputation: 0
No ideas anyone? I'm starting to formulate my hypothesis that something has happened to the path after FontPath "unix/:7100", am I correct in thinking so?

Last edited by Rocket_Magnet; 08-24-2003 at 03:34 AM.
 
Old 08-24-2003, 03:32 AM   #3
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Try adding

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

To your config.
Make sure your paths match, and the folder /usr/lib/X11/fonts exists.

Or read up on the font server, though most people have it switched off.
 
Old 08-24-2003, 03:53 AM   #4
liquidfx
LQ Newbie
 
Registered: Aug 2002
Location: California, USA
Distribution: Mandrake 8.1, Slackware 8.1
Posts: 14

Rep: Reputation: 0
rocket.....here's my xf86config

################################################################################
# XFree86 configuration for version XFree86 4.x
#
# Configuration created by Libranet Adminmenu
################################################################################

Section "Files"
FontPath "unix/:7100"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/TrueType"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/75dpi"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/openoffice"
EndSection

Section "ServerFlags"
EndSection

Section "Module"
Load "ddc"
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "pex5"
Load "record"
Load "xie"
Load "bitmap"
Load "freetype"
Load "speedo"
Load "type1"
Load "vbe"
Load "int10"
EndSection

Section "InputDevice"
Identifier "Default Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Default Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Selected Driver"
Driver "nv"
#VideoRam 8192
EndSection

Section "Monitor"
Identifier "Selected Monitor"
HorizSync 31.5-57.0
VertRefresh 50-70
Option "DPMS"
EndSection


Section "Screen"
Identifier "Default Screen"
Device "Selected Driver"
Monitor "Selected Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Default Keyboard"
InputDevice "Default Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



HOPE THAT HELPS
 
Old 08-24-2003, 04:10 AM   #5
Rocket_Magnet
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9.0
Posts: 9

Original Poster
Rep: Reputation: 0
Re: rocket.....here's my xf86config

Quote:
Originally posted by leonscape
Try adding

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

To your config.
Make sure your paths match, and the folder /usr/lib/X11/fonts exists.

Or read up on the font server, though most people have it switched off.
Quote:
Originally posted by liquidfx
################################################################################
# XFree86 configuration for version XFree86 4.x
#
# Configuration created by Libranet Adminmenu
################################################################################




HOPE THAT HELPS
Thanks guys it worked, I owe you one.
 
Old 08-24-2003, 01:42 PM   #6
brianabroad
LQ Newbie
 
Registered: Aug 2003
Location: Taiwan, US
Posts: 17

Rep: Reputation: 0
You may also want to make sure your font server is actually running:
"/etc/init.d/xfs stop"
-note: if it said "failed" then it wasn't running.
To start it, type:
"/etc/init.d/xfs start"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Move 9.2 error, fatal server error:( silentwhispers Mandriva 1 12-16-2004 11:36 PM
Fatal X server error..... chunlee Linux - Software 0 10-19-2004 06:51 PM
Fatal server error sneakerpimp Red Hat 4 12-30-2003 06:25 PM
Fatal Server Error ludwig W Linux - General 1 05-17-2003 10:28 PM
fatal server error lancesykes Linux - Newbie 2 07-15-2001 10:34 AM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration