Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-30-2009, 02:21 PM   #1
LQ Newbie
Registered: Jan 2009
Posts: 5

Rep: Reputation: 0
Edit the GRUB to make LILO-using distro to boot????

Got a pretty basic question the solution of whitch I can t find anywhere...what do I add in the grub of ubuntu(or anything Grub-y) in order to get a lilo-using distro to work...

for the time being I ve edited my grub with that:

title Zenwalk
root (hd0,5)
kernel /boot/vmlinuz- root=/dev/hda6 ro
initrd /boot/initrd.splash

When trying to boot zenwalk I get:Error 11:cannot recognize device string.

Any ideas??
Old 01-30-2009, 03:14 PM   #2
LQ Guru
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
If you install lilo to the root partition of Zenwalk (instead of the MBR), you can just use
title Zenwalk
root (hd0,5)
chainloader +1
See Saikee's grub booting tips in my signature for more info.
Old 01-30-2009, 06:31 PM   #3
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,836

Rep: Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242Reputation: 1242
I expect you are getting that error because of this entry in your menu.lst

initrd /boot/initrd.splash
The line should look something like below, not a splash file.

I'd recommend pljvaldez' method, simplest and should work.
Old 01-30-2009, 07:46 PM   #4
Senior Member
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
also it is /dev/sda6 not hda6
Old 01-31-2009, 10:00 AM   #5
LQ Newbie
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
First of all,THanks for your quick responses.Secondly...Amani and yancek,i did the changes you effect.Yancek you suggest "-16" after the kernel.I don't have that...what does it mean?my ubuntu have an "-8"

pljvaldez,i read the guide and if I got it right ,you re sayng i should have lilo working.if i do i can treat zenware like a windows partition.Thing is,I haven't installed LILO for the fear of conflicts with grub....
Old 01-31-2009, 02:42 PM   #6
LQ Newbie
Registered: Jan 2009
Posts: 5

Original Poster
Rep: Reputation: 0
i installed lilo,by reinstallin zenwalk.i put it in the superblock.(the command lilo -b etc wasn t working...)My only problem now is that on the chainloading i must add noapic....


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mult distro boot help (lilo and grub) cygnus-x1 Linux - General 1 11-08-2007 09:57 PM
how do u edit/make your own distro? darthyoda3 Linux - General 1 03-11-2007 10:15 PM
Kind souls: help getting Mandriva install 2 boot? edit boot.ini/grub /boot device or NoMoreReinstallMS Linux - Newbie 1 08-09-2006 04:34 AM
GRUB or LILO won't boot linux!!! for ANY distro stelmate Linux - Hardware 12 05-27-2005 06:42 PM
edit windows boot ini to allow booting to lilo V_LESTAT Linux - Newbie 2 01-15-2004 06:58 PM

All times are GMT -5. The time now is 11:22 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration