LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Edit the GRUB to make LILO-using distro to boot???? (http://www.linuxquestions.org/questions/linux-newbie-8/edit-the-grub-to-make-lilo-using-distro-to-boot-701090/)

Karaxarias 01-30-2009 03:21 PM

Edit the GRUB to make LILO-using distro to boot????
 
Got a pretty basic question the solution of whitch I can t find anywhere...what do I add in the grub of ubuntu(or anything Grub-y) in order to get a lilo-using distro to work...

for the time being I ve edited my grub with that:

title Zenwalk
root (hd0,5)
kernel /boot/vmlinuz-2.6.25.4 root=/dev/hda6 ro
initrd /boot/initrd.splash

When trying to boot zenwalk I get:Error 11:cannot recognize device string.

Any ideas??

pljvaldez 01-30-2009 04:14 PM

If you install lilo to the root partition of Zenwalk (instead of the MBR), you can just use
Code:

title Zenwalk
root (hd0,5)
chainloader +1
boot

See Saikee's grub booting tips in my signature for more info.

yancek 01-30-2009 07:31 PM

I expect you are getting that error because of this entry in your menu.lst

Quote:

initrd /boot/initrd.splash
The line should look something like below, not a splash file.

Quote:

initrd.img-2.6.24-16-generic
I'd recommend pljvaldez' method, simplest and should work.

amani 01-30-2009 08:46 PM

also it is /dev/sda6 not hda6

Karaxarias 01-31-2009 11:00 AM

First of all,THanks for your quick responses.Secondly...Amani and yancek,i did the changes you recommend...no effect.Yancek you suggest "-16" after the kernel.I don't have that...what does it mean?my ubuntu have an "-8"

pljvaldez,i read the guide and if I got it right ,you re sayng i should have lilo working.if i do i can treat zenware like a windows partition.Thing is,I haven't installed LILO for the fear of conflicts with grub....

Karaxarias 01-31-2009 03:42 PM

i installed lilo,by reinstallin zenwalk.i put it in the superblock.(the command lilo -b etc wasn t working...)My only problem now is that on the chainloading i must add noapic....


All times are GMT -5. The time now is 02:00 AM.