LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-08-2003, 06:14 PM   #1
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Rep: Reputation: 30
Connect script failed on ppp-go


I am using Slackware 9.1.

I read all the documentation I found about pppsetup, but still I get "connect script failed" when i type ppp-go. No dialing sound ever comes from the modem, as if it were not interrogated at all.

I read some forum on similar topics, and counsels were more or less "run netconfig". But why do I have to worry about the settings of the network when my PC is not linked to one? I don't have a network card, I only want to connect to the internet with my cable modem!
However, I ran it and I choose "loopback device", which was the indicated alternative to DHCP to be used in case of no network or cable modem.

I am pretty sure that the device I indicate for the modem (ttyS2, = DOS COM3) is correct, and so also for its INIT string (ATZ), because I have a live installation in which the connection works in a much more "plug and play" mode, and from there I got these informations.

I typed "ifconfig -a" and the answer is that the loopback device is up and running.

I checked the file /etc/rc.d/rc.modules and I noted that the modules for ppp support were commented. I uncommented them and ran the file, but I got the message that the modules were already up to date.

I checked the file /etc/protocols, and the tcp and ip protocols were uncommented, so, I think, working.

CAN SOMEBODY GIVE ME SOME NEW HINT?

Thanks

-----------
 
Old 12-08-2003, 08:26 PM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
i'm not sure i understand what your problem is exactly...

you speak of a dial-up modem, but you also mention you want to connect with your cable modem... they are two different things...

if you are using a cable modem then you won't need any ppp, you'll simply need to properly configure your network card...

if you're going to connect via dial-up, then you'll first need to make sure your modem is supported on linux (to make sure all the troubleshooting won't be totally useless)...

you should let us know the brand and model of your dial-up modem in that case...

it'll be easier to help you once you have clarified these details...
 
Old 12-08-2003, 08:36 PM   #3
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
you don't need to be messing with that network stuff.

you just need a modem that works under linux, and knowledge about
where that modems port is.

try to figure out if you have a winmodem. you most likely do.
 
Old 12-08-2003, 11:23 PM   #4
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
http://www.linmodems.org/
 
Old 12-09-2003, 01:21 PM   #5
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
Thank you for answering. My modem is definitely on device ttyS2, corresponding to the port that under DOS is called COM3. I am sure of this because I see it in the control panel of my old Windows98 and because I have a live linux installation (Knoppix) that works smoothly and finds my modem on that device.

Since Knoppix had no problem in connecting to the internet with my modem (with tool KPPP), I assumed it was supported. However, it is
V1433VQH-U Internal FAXModem.

Thank you for your patience...
 
Old 12-09-2003, 02:15 PM   #6
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
i have 2 of that modem. not a winmodem.
plain old 56k isa hardware modem. i miss using them. i couldn't find
a motherboard with an isa slot that had the features i needed on the last
upgrade. i miss it when i have to compile kernel modules for my lucent
modem everytime i start playing with the kernel.

having a modem at a specific port under win98 doesn't mean it's not a
winmodem that will not work under linux, because a winmodem would
just be put at that port by windows. the knoppix is a different matter
alltogether. it may be at com3(ttyS2), but not under the standard interrupt
of 4 for that port.

perhaps you could look at the modem jumpers and see what irq the
modem is set at? you may have to use a setserial command.
 
Old 12-09-2003, 04:23 PM   #7
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
Again from Win98 control panel, I see that the I/O interval is 03E8 - 03EF, and that the interrupt level is 05 (and not 04 as I think should be the standard). What shell I do?

Thanks
 
Old 12-09-2003, 06:21 PM   #8
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
you should skim this page

http://www.faqs.org/docs/linux_netwo...iguration.html

see if there is a file /etc/rc.serial first. you may be able to change it there.

This command should work setserial /dev/ttyS2 irq 5

man setserial explains many other options.
 
Old 12-10-2003, 07:11 PM   #9
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
There is not a file /etc/rc.serial

I tryed with the command you indicated, but with no result: I still get the message "connect script failed" with no trace o f life by the modem.

I am getting crazy. The final lines of pppsetup give a warning saying "I didn't find ppp in your kernel or modules", but I checked with
dmesg | grep -i ppp
and it finds driver ppp.
Is there some other check I can make to make sure I have all the necessary processes running?
Thanks
 
Old 12-10-2003, 08:16 PM   #10
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
the setserial command will also list the settings for a serial port
setserial /dev/ttyS2
will show the current settings.

maybe you can find somewhere or someone who will show you how to check
if a modem is working with minicom. it's been way too long since i have.

you didn't compile your own kernel did you?

perhaps you could start up your knoppix cdrom and
look at the settings that work.
run the setserial /dev/ttyS2
to see what the settings are, and
lsmod
to see what modules are loaded.

Last edited by whansard; 12-10-2003 at 08:17 PM.
 
Old 12-14-2003, 04:58 PM   #11
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
the setserial command run on Knoppix gives an answer like
UART: 16550a Port: 0x03e8 IRQ 4
There are two serial ports on IRQ 4, but knoppix works fine all the same.
Command lsmod gives a great list of modules, in knoppix, including ppp-deflate, ppp-async, and ppp-generic. If I give the same command on Slackware, I obtain only the following modules:

uhci
usbcore
pcmcia-core
ide-scsi
agpgart

Is there something missing?

I think the problem is not with pppsetup but with the communication between the kernel and the modem. I tryied to run Seyon, and it gives an error on the communication with the modem. Have you got any other hint?

However, I paste in the following the file pppsetup.txt containing the information regarding my settings, could you tell me wether there's something wrong with that too?

=========================================================================
PPPSETUP 1.98

Written by Robert S. Liesenfeld <xunil@bitstream.net> <IRC:Xunil>
Changes for 1.98 by Kent Robotti <robotti@erols.com>
Patched for Slackware by Patrick Volkerding <volkerdi@slackware.com>

You should get these docs if you don't already have them:

ftp://metalab.unc.edu/pub/Linux/docs/howto/PPP-HOWTO
ftp://metalab.unc.edu/pub/Linux/docs/faqs/PPP-FAQ

Press [Enter] to continue with pppsetup...
=========================================================================
These are your PPP configuration files and instructions...
=========================================================================

# This is your /etc/ppp/pppscript.

TIMEOUT 60
ABORT ERROR
ABORT BUSY
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
"" ATZ OK
"atdt7020221022"
TIMEOUT 75
CONNECT

# This is your /etc/ppp/options file.

# General configuration options for PPPD:
lock
defaultroute
noipdefault
modem
/dev/ttyS2
115200
crtscts
# Uncomment the line below for more verbose error reporting:
#debug
# If you have a default route already, pppd may require the other side
# to authenticate itself, which most ISPs will not do. To work around this,
# uncomment the line below. Note that this may have negative side effects
# on system security if you allow PPP dialins. See the docs in /usr/doc/ppp*
# for more information.
#noauth
passive
asyncmap 0
name "iqbala"

I created the symbolic link: /dev/modem -> /dev/ttyS2

# This is your /etc/ppp/options.demand dialing file.

# General configuration options for PPPD:
lock
defaultroute
noipdefault
modem
/dev/ttyS2
115200
crtscts
# Uncomment the line below for more verbose error reporting:
#debug
# If you have a default route already, pppd may require the other side
# to authenticate itself, which most ISPs will not do. To work around this,
# uncomment the line below. Note that this may have negative side effects
# on system security if you allow PPP dialins. See the docs in /usr/doc/ppp*
# for more information.
#noauth
passive
asyncmap 0
name "iqbala"
ipcp-accept-local
ipcp-accept-remote
0.0.0.0:10.10.10.10
demand
connect "/usr/sbin/chat -v -f /etc/ppp/pppscript"

If you have a ethernet connection you should change the local:remote
IP addresses in the options.demand file, to your actual local and
remote address. Example: 215.346.117.89:312.217.187.96

# This in your /etc/resolv.conf file.

search everyday.com
nameserver 212.151.128.66

212.151.128.66 <-IMPORTANT: This should be the IP address of
your service providers nameserver.

# This is your /etc/ppp/pap-secrets file.

Look at /etc/ppp/pap-secrets.

ATENTION: I couldn't find 'PPP' in the kernel or as a module.
You'll need 'PPP' in the kernel or as a module to make a PPP connection.

Does everything look correct? if not, run 'pppsetup' again...

=========================================================================
To connect to your service provider.
=========================================================================

~# ppp-go <-Make PPP connection.)

You'll hear and see the modem dialing then once connected,
logging you in Username: or Login: and Password: etc.

You won't see a Username or Login: and Password: prompt
if they're using PAP or CHAP to authenticate you.

If they use PAP or CHAP you'll just see CONNECT -- got it.

If the connection was successful you'll see the Local IP and
Remote IP address printed to the screen, you can press [Enter].

If you run ppp-go in X windows you probably won't see a Local
and Remote IP address printed to the screen, you'll just see
the connection process come to a end, wait a few seconds and
press [Enter] at that point.

If you don't connect for whatever reason e.g. Failed No
Dialtone, Busy, No Carrier, Whatever, Exit, just press
[Enter] at that point.

if you have syslogd running, you can see the output messages
from pppd and chat in the /var/log/messages and or debug file.

Sample /var/log/messages file.

zzeus pppd[562]: Serial connection established.
zzeus pppd[562]: Using interface ppp0
zzeus pppd[562]: Connect: ppp0 <--> /dev/modem
zzeus pppd[562]: local IP address 215.87.78.18
zzeus pppd[562]: remote IP address 205.94.97.35

You don't have a successful PPP connection until you
receive a local & remote IP address like above.

If you have the X window system, you could connect in a Xterm.

zzeus # startx
zzeus # ppp-go
zzeus # netscape mosaic etc.

~# ppp-off <-To end the ppp connection.)

~# ppp-go -h <-For help.)

There is no support in linux for "WinModems", if you have a
WinModem you will not be able to use it in linux.

There is support for plug n play modems, if you have a pnp
modem you may need "isapnptools" to get it recognized.

=========================================================================
#### Look at the /usr/doc/pppsetup/pppsetup-1.98.README. ####
#### A copy of this text can be found in: /etc/ppp/pppsetup.txt ####
=========================================================================

Done... You can exit now...

End...
=========================================================================
PPP-2.3.0 and later has a demand dialing option, you can use it this way,
the options file for demand dialing will be /etc/ppp/options.demand.

Start ppp-go -d, pppd will just stay in the background until you try to
connect to some site, then pppd will dial your service provider and make
the ppp connection.

~# ppp-go -d <-Start pppd this way for demand dialing.)
# <-It should drop you back to #.)

~# ftp ftp.funet.fi <-Pppd will start dialing.)
# lynx http://www.foo.com <-Pppd will start dialing etc.)
# ppp-off -d <-To end and restart pppd in demand dialing mode.)
# ppp-off <-To end the ppp connection.)

End...
=========================================================================
These are some other ways to make a PPP connection.

The best way to make a PPP connection is to create a chat script, if
you're having trouble with the chat script you can use these methods
below to make the PPP connection.

You can also use these methods below to see what's going on when you
connect to your service provider, i.e. what do they require, do they
present you with a Login: or Username: and Password: prompt etc.

What steps do you have to go through before they start PPP at there
end?

First make sure the IP address of your service providers nameserver
is in the /etc/resolv.conf file.

nameserver 205.117.312.56 <-For example.)

=========================================================================
Using 'dip' to make the PPP connection.
=========================================================================

~# dip -tv
Host name lookup failure

If you get the above messgae when you start 'dip', it's because you
don't have your hostname in the /etc/hosts file.

~# hostname
foobar

If your hostname were 'foobar' you should put it in the /etc/hosts file.

127.0.0.1 localhost
0.0.0.0 foobar.localnet foobar

~# dip -tv
dip> port /dev/ttyS1
can't open - problems with locking ttyS1

If you get the above message after "port /dev/modem", it means you have a
lock file in /var/lock/LCK..ttyS1, remove the lock file and kill dip.

~# rm /var/lock/LCK*
# killall -9 dip

~# dip -tv

dip> port /dev/ttyS1 <-Where's the modem? ttyS0 = com1 ttyS1 = com2 etc.)
dip> speed 115200 <-Modem speed: 19200 38400 57600
dip> term

at&fw2 <-Modem init string.)
atdt1234567 <-Replace 1234567 with the phone number.)

Usally you give your username and password then ppp is started, if
they use PAP or CHAP you probably won't be asked for a username and
password, they will just say that PPP has been started or nothing.

Press Ctrl ] to exit dip term mode when PPP is started at their end.

dip> default <-Use default route.)
dip> mode ppp <-Start PPP at your end.)

~# ping metalab.unc.edu <-To see if you're connected.)

~# dip -k <-To kill dip and the PPP connection.)

=========================================================================
Using 'minicom' to make the PPP connection.
=========================================================================

Keep the /etc/ppp/options file that was created by pppsetup, it should
have at least these options in it.

lock
defaultroute
noipdefault
/dev/ttyS1 <- ttyS0 = com1 ttyS1 = com2 ttyS2 = com3 ttyS3 = com4
57600
modem
crtscts
debug
asyncmap 0

~# minicom -m -s

at&fw2
atdt1234567

Press Alt Q to exit minicom without reset after PPP is started at
the other end.

~# pppd <-Start PPP at your end.)

~# ppp-off <-To end the PPP connection.)
# killall -INT pppd <-If you don't have 'ppp-off' end it this way.)

End...
=========================================================================


I thank you for your kind assistance
 
Old 12-14-2003, 11:02 PM   #12
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
that modem has jumpers that can be set for a specific irq or pnp.
it might be set to pnp, which could make it have different settings under
different circumstances.
you should check your jumpers to make sure they are set to that irq
and not to pnp.
knoppix could be running tools that setup pnp devices while slackware
isn't. the pnptools.
the modem can dial without the ppp modules. i think the modem is set
to pnp, which slackware wouldn't set up by default, or the serial device
isn't set right for the modem.

there's another nice modem setup tool called wvdial, or wvdialer.
it's much more automated, and you might have good results with that.
 
Old 12-15-2003, 04:55 PM   #13
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
I think I will keep the possibility of changing the jumpers as a last resort. Meanwhile, I read somewhere that problems with ISA PNP cards are not so uncommon, and that there is an appropriate tool (pnpdump) to make the proper configuration file. But I also read that it may cause conflict in the system.
I tried it, and it produced a file with many possibilities between which I should choose, and I haven't got the least idea about which one I should choose. What will it happen if I chose the wrong alternative? Will I damage something permanently in my system?

However, here is the portion of the file regarding the modem, could you guide me in its use?

Thanks.

# $Id: pnpdump_main.c,v 1.27 2001/04/30 21:54:53 fox Exp $
# Release isapnptools-1.26
#
# This is free software, see the sources for details.
# This software has NO WARRANTY, use at your OWN RISK
#
# For details of the output file format, see isapnp.conf(5)
#
# For latest information and FAQ on isapnp and pnpdump see:
# http://www.roestock.demon.co.uk/isapnptools/
#
# Compiler flags: -DREALTIME -DHAVE_PROC -DENABLE_PCI -DHAVE_SCHED_SETSCHEDULER -DHAVE_NANOSLEEP -DWANT_TO_VALIDATE
#
# Trying port address 0273
# Board 1 has serial identifier ce 03 10 01 5d 03 10 79 05
# Board 2 has serial identifier a9 ff ff ff ff 36 42 63 0e

# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

# Card 1: (serial identifier ce 03 10 01 5d 03 10 79 05)
# Vendor Id AKY1003, Serial Number 51380573, checksum 0xCE.
# Version 1.0, Vendor version 1.0
# ANSI string -->V1433VQH-U 336 PNP MODEM<--
#
# Logical device id DAV0336
# Device supports I/O range check register
# Device supports vendor reserved register @ 0x39
# Device supports vendor reserved register @ 0x3b
# Device supports vendor reserved register @ 0x3c
# Device supports vendor reserved register @ 0x3e
#
# Edit the entries below to uncomment out the configuration required.
# Note that only the first value of any range is given, this may be changed if required
# Don't forget to uncomment the activate (ACT Y) when happy

(CONFIGURE AKY1003/51380573 (LD 0

# Multiple choice time, choose one only !

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x02f8
# Maximum IO base address 0x02f8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x02f8) (CHECK))
# IRQ 3.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03f8
# Maximum IO base address 0x03f8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03f8) (CHECK))
# IRQ 4.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 4 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03e8
# Maximum IO base address 0x03e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03e8) (CHECK))
# IRQ 4.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 4 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x02e8
# Maximum IO base address 0x02e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x02e8) (CHECK))
# IRQ 3.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03e8
# Maximum IO base address 0x03e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03e8) (CHECK))
# IRQ 5.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 5 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x02e8
# Maximum IO base address 0x02e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x02e8) (CHECK))
# IRQ 5.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 5 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03e8
# Maximum IO base address 0x03e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03e8) (CHECK))
# IRQ 3, 4, 5, 7, 10, 11, 12 or 15.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x02e8
# Maximum IO base address 0x02e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x02e8) (CHECK))
# IRQ 3, 4, 5, 7, 10, 11, 12 or 15.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03f8
# Maximum IO base address 0x03f8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03f8) (CHECK))
# IRQ 3, 4, 5, 7, 10, 11, 12 or 15.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x02f8
# Maximum IO base address 0x02f8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x02f8) (CHECK))
# IRQ 3, 4, 5, 7, 10, 11, 12 or 15.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x0200
# Maximum IO base address 0x03f8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x0200) (CHECK))
# IRQ 3, 4, 5, 7, 10, 11, 12 or 15.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))

# End dependent functions
(NAME "AKY1003/51380573[0]{V1433VQH-U 336 PNP MODEM}")
# (ACT Y)
))
# End tag... Checksum 0x00 (OK)

# Card 2: (serial identifier a9 ff ff ff ff 36 42 63 0e)
# Vendor Id CSC4236, No Serial Number (-1), checksum 0xA9.
# Version 1.0, Vendor version 0.1
# ANSI string -->AW32 Pro (Res.Ver2.00)<--
#
# Logical device id .....
.....
.....
 
Old 12-15-2003, 10:52 PM   #14
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
i can't remember if you're supposed to uncomment the whole section or just a few
of the lines.

the way those settings work is: the pnpdump shows the possible settings for the
device, of which you can choose whichever you want. i would suggest setting
it the same as knoppix or setting it to the standard setting that setserial shows
you for ttyS2.

isn't this the set that matches with the knoppix settings?
i think you already set ttyS2 to irq5, so your modem might start working
after you uncomment that set and run the isapnptool tool. i can't remember
that stuff very well. i can't remember the name of the program that sets up
the pnp devices.


# Start dependent functions: priority acceptable
# Logical device decodes 16 bit IO address lines
# Minimum IO base address 0x03e8
# Maximum IO base address 0x03e8
# IO base alignment 8 bytes
# Number of IO addresses required: 8
# (IO 0 (SIZE 8) (BASE 0x03e8) (CHECK))
# IRQ 5.
# High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 5 (MODE +E)))


take the # out from in front of the above lines, then run pnpsetup i think.

if the modem gets setup right, you may have to put pppsetup in your startup
script. also for pppsetup and ppp-go, you may have to uncomment the ppp
modules that you need started for a ppp connection. if you get the modem
going, and ppp-go connects, and then complains about the kernel not having
ppp support, that's what you will have to do next.

Last edited by whansard; 12-15-2003 at 10:57 PM.
 
Old 12-20-2003, 07:19 AM   #15
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
I tried and I got a message warning me that there is a conflict on the I/O address:
bash-2.05b# isapnp /etc/isapnp.conf
Board 1 has Identity ce 03 10 01 5d 03 10 79 05: AKY1003 Serial No 51380573 [checksum ce]
Board 2 has Identity a9 ff ff ff ff 36 42 63 0e: CSC4236 Serial No -1 [checksum a9]
/etc/isapnp.conf:73 -- Fatal - resource conflict allocating 8 bytes of IO at 3E8 (see /proc/ioports)
/etc/isapnp.conf:73 -- Fatal - Error occurred executing request '<IORESCHECK> ' -
On file /proc/ioports there is just the indication that the mentioned I/O is used by the serial port.

How can I discover which resource is really using that I/O?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind9: NDC command failed : rndc: connect failed: connection refused Boudewijn Linux - Networking 19 01-02-2014 08:19 AM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover SUSE / openSUSE 8 02-22-2005 08:57 AM
error: stat of /var/log/ppp/connect-errors failed: No such file or directory Niceman2005 Linux - Newbie 0 01-20-2005 01:29 AM
ppp failed to start? tradewind Linux - Newbie 1 06-28-2004 03:04 AM
PPP service failed to start tradewind Linux - Networking 0 06-28-2004 02:13 AM


All times are GMT -5. The time now is 04:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration