LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-20-2003, 10:49 AM   #16
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52

your onboard serial port might be using that.. you can probably disable
that port in the bios if you're not using it, or try a different setting in the
isapnp configuration file.

Last edited by whansard; 12-20-2003 at 07:29 PM.
 
Old 12-20-2003, 03:40 PM   #17
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
Well, it is true that that two cards that conflict are recognized by BIOS before the booting process, so maybe there something to be set at BIOS level, but if WIN98 and Knoppix manage to turn around whichever problem there may be, Slackware should be able, too, somehow.

I have three teoretical questions:

1) In the isapnp.conf file, the first instructions are

# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING

What do they mean? They are instructions to abort the program in case of conflict, or they are in themselves a signal that there is a conflict? And why does it look only in that particular address (0x0273)?

2) The modem is identified as follows:
# Card 1: (serial identifier ce 03 10 01 5d 03 10 79 05)
# Vendor Id AKY1003, Serial Number 51380573, checksum 0xCE.
# Version 1.0, Vendor version 1.0
# ANSI string -->V1433VQH-U 336 PNP MODEM<--
#
# Logical device id DAV0336

What is the meaning of this "logical device"? Couldn't the problem be that this tool is somehow trying to assign the serial port to a logical device named some DAV0336 while that port is already assigned to /dev/ttyS2? I expected to find some place in this file where I could indicate that the modem/port I am trying to set is assigned to /dev/ttyS2, but I don't find any such instruction.

3) What is the meaning, anyway, of the I/O address? Are they the identifiers of the fisical ISA slot on the motherboard, or I can assign them as I wish to the port where I have my modem?

Thanks, I never happened to go in such low-level settings, and without much experience It's quite difficult. Really thanks, without your help I would have been force to give up.
 
Old 12-20-2003, 07:25 PM   #18
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
the i/o port is the address in memory where the device will communicate
with the computer. the computer puts data there it wants the modem to
see, and the modem puts data there it wants the computer to see.

a plug n play device is called so because it doesn't grab all the resources
it needs when it is turned on, and relies on something else to give it what
it needs. the bios can do it, if set to do so. most versions of windows will
do so automatically if needed. linux will not, unless told to, in general.
pci slots have irq's assigned to them by the bios, i think, but isa ports do
not. that's what the isapnp tools do. they assign a free(hopefully) irq to
an isa device that needs one. some devices can share an irq.
if an onboard serial port is assigned the same irq as an isa device,
usually that can work, as long as you only use one of them. a sound card
and an lpt port can often share an irq.
the irq is sort of like a bell on a rope that the devices and the computer
use to communicate to each other. when the irq is asserted, the
computer goes, hey, i need to look at that irq's i/o ports for data from the
device that has that irq. i think thats sort of how it works anyway.


# (DEBUG)
(READPORT 0x0273)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO FATAL)(IRQ FATAL)(DMA FATAL)(MEM FATAL)) # or WARNING


i don't think that set of settings will work. that's sort of a lpt port set.
i think the (IO FATAL) can be changed to (IO WARNING), and it will go
ahead and use the settings, instead of aborting.
don't try any ports except 3E8, 2E8, 3F8, and 2F8. those are for com
1,2,3,4 or TTYS 0,1,2,3, in windows and linux language respectfully.

Last edited by whansard; 12-20-2003 at 07:27 PM.
 
Old 12-21-2003, 06:14 PM   #19
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
OK. I begin to see the light at the end of the tunnel, or so I hope. I changed (IO FATAL) to (IO WARNING) and it still gave me that warning but enabled the MODEM. I the typed ppp-go, and my MODEM SPRANG TO LIFE, DIALLED AND CONNECTED. :-))
I received the communications of the local and remote IP address, so I was happy. BUT: I started GNOME desktop, run MOZILLA and I still could not see anything. I am online (the ifconfig shows device ppp0 and some K-byte sent and received), but either the browser doesn't realize it, or it doesn't understand what the modem is saying. I tryied other browsers with the same result. The symptoms are that the browser either loads a blank page and states "Done" or gives a message "couldn't locate site".

Is there something to set in the X-configuration, or in the net configuration?

How can I be sure thet I have in my system all the drivers/protocols I need?

I am not sure to have chosen the right authentication method (PAP, CHAP, or what else?) but I assume that since I got a local IP, the connection was established correcly. Am I wrong? In WIN98 I see messages like "verifying password and username... Now you have access to the net". Should I see something of the sort in LINUX also?

However, thanks
 
Old 12-21-2003, 09:23 PM   #20
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
it's probably your name server not setup right. pppsetup can do it,
or you can add it to /etc/resolv.conf
if your name server sets up automatically, you should use 0.0.0.0
you can try 128.95.1.4 if you want to just try one.


you wouldn't have gotten the local and remote ip if the username and
password were not getting sent right.

the reason for those specific windows messeges is that's what
windows wants to tell you. ppp-go is just a few scripts that use
chat to dial and pppd for the ppp connection. most of the info
gets written to log files in your /var/log directory. it depends on
what system logger you use.

Last edited by whansard; 12-22-2003 at 01:25 PM.
 
Old 12-22-2003, 05:48 PM   #21
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
I tried to change /etc/resolv.conf both by hand and by pppsetup. I tryied to use the server name with ip 0.0.0.0, I tried even to skip inserting the server name, and to change the modem baud rate. The connection reacts always in the same way: I get local and remote IP address, but thennothing else.

Ifconfig tells me that:

bash-2.05b# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:146 errors:0 dropped:0 overruns:0 frame:0
TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12156 (11.8 Kb) TX bytes:12156 (11.8 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:81.211.138.20 P-t-P:212.151.128.66 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:362 (362.0 b) TX bytes:153 (153.0 b)

See? The modem IS sending/receiveing something, and the amount of packets sent/received increases every time I insert a new URL in the browsers. So? What am I missing?

By the way: why the loopback device received/transmitted more packats than ppp0 device?

About the name server, I am sure that it is correct, anyway.
 
Old 12-22-2003, 07:13 PM   #22
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
how are you sure that 0.0.0.0 is correct?

it's a nameserver problem. don't mess with other stuff.
see if you can ping a site just to make sure.
ping 128.95.1.4

if that works, it's definately the name server

/etc/resolv.conf should be

nameserver 128.95.1.4
or whatever your isp uses.
 
Old 12-23-2003, 02:49 PM   #23
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
Well, I tried that besides the appropriate IP address of the server (the IP I saw as remote on a successful connection by means of knoppix), and both gave me the same result. I thought that, having I received my local dynamic IP, the connection was successful. It is possible that I am missing some point.

I think I'll not be posting this next week, but don't think I've given up. It's Christmas time, you know, and I will be involved in infinite dinner with parents and relatives. I'll be back at least to give you the results of my latest tries. Hope I'll still find you there.

Meantime, thank you again and have a Merry Christmas.

Truly
Andrea
 
Old 12-23-2003, 09:59 PM   #24
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
Quote:
Originally posted by iqbala
Well, I tried that besides the appropriate IP address of the server (the IP I saw as remote on a successful connection by means of knoppix), and both gave me the same result. I thought that, having I received my local dynamic IP, the connection was successful. It is possible that I am missing some point.

I think I'll not be posting this next week, but don't think I've given up. It's Christmas time, you know, and I will be involved in infinite dinner with parents and relatives. I'll be back at least to give you the results of my latest tries. Hope I'll still find you there.

Meantime, thank you again and have a Merry Christmas.

Truly
Andrea

do you mean you tried to ping those ip's, or you tried them as a nameserver?

the nameserver address is where the application will try to get the
ip's of names. like when you put in http:/www.linuxquestions.org,
your app asks the nameserver what ip that is at. you can check if you have
it set right with ping. such as.
ping -c 1 www.linuxquestions.org
PING www.linuxquestions.org (64.179.4.146) from x.x.x.x
(number changed by me to protect the innocent)
: 56 data bytes
64 bytes from 64.179.4.146: icmp_seq=0 ttl=51 time=175.3 ms
--- www.linuxquestions.org ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 175.3/175.3/175.3 ms


or

ping -c 1 128.95.1.4
PING 128.95.1.4 (128.95.1.4) from x.x.x.x (same explanation as before)
: 56 data bytes
64 bytes from 128.95.1.4: icmp_seq=0 ttl=49 time=204.7 ms
--- 128.95.1.4 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 204.7/204.7/204.7 ms

if you can't ping a name, but you can ping a number, you are connected,
but don't have the name server setup right.
 
Old 12-24-2003, 10:15 AM   #25
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
I'M ON THE INTERNET, UP AND RUNNING!!!!

I am writing this post using Epiphany, and I'm happy.

You were right, it was the nameserver not setup correctly. I just changed my ISP, since my old one kept on saying "you don't need to know the DNS, I do it all automatically".

Now my only problem is just to manage my many different ISPs. Shall I run pppsetup every time I want to change?

However, I'm on the internet, so I'll do somehow, and besides, the topic of the thred is solved.

My deepest thanks, and see you on an other forum.

My deepest than
 
Old 12-24-2003, 08:04 PM   #26
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
Goodly. Contratulations.
you can actually make different copies of the dialing scripts under
different names for the different isp's, and change the references
in the scripts. like make a ppp-otherisp file that's a copy of ppp-go,
and have it reference a ppp.script.otherisp instead of ppp.script,
and make an options.otherisp, and change all the references of
options to options.otherisp. there's about 5 files.

it would be easier to make a seperate options file and pppscript for
the other isp, and have a script that copies those files into the right
place.

kppp and other dialers are much easier for this sort of thing.
 
Old 12-26-2003, 02:22 PM   #27
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
Are this other dialers part of the basic Slackware release, or I have to install them?
 
Old 12-26-2003, 10:47 PM   #28
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
i don't know. look at www.freshmeat.net
wvdial is one text based one.
xppp, gnome-ppp, and kppp are X based.
 
Old 01-02-2004, 04:33 PM   #29
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
OK, I mastered ppp scripts, so I don't need to look for other dialers. My principal aim right now is to get more and more accustomed with the low-level workings of this operative system which is still largely unknown to me, so I will resist the temptation to look for more user-friendly interfaces.

Now just a small question: how can I tell the system to run the isapnp tool automatically at start?

Thanks
 
Old 01-02-2004, 10:18 PM   #30
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
is the tool isapnpconf? and the name of a script?

add it to one of the startup scripts, like /etc/rc.d/rc.local
i think for slackware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind9: NDC command failed : rndc: connect failed: connection refused Boudewijn Linux - Networking 19 01-02-2014 08:19 AM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover SUSE / openSUSE 8 02-22-2005 08:57 AM
error: stat of /var/log/ppp/connect-errors failed: No such file or directory Niceman2005 Linux - Newbie 0 01-20-2005 01:29 AM
ppp failed to start? tradewind Linux - Newbie 1 06-28-2004 03:04 AM
PPP service failed to start tradewind Linux - Networking 0 06-28-2004 02:13 AM


All times are GMT -5. The time now is 07:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration