LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-17-2006, 04:44 PM   #1
cottonfever
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met;


Hi,

I managed to get Fedora core 4 up and running and thought I might like to install PAN as a newsreader, howver after untarrign and unzipping it, I got the subject libne error message. More precisely:
-------------------------------------------------------
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.2.0 gthread-2.0 >= 2.2.0 gobject-2.0 >= 2.2.0... yes
checking GLIB_CFLAGS... -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking GLIB_LIBS... -pthread -lgthread-2.0 -lgobject-2.0 -lglib-2.0
checking for gtk+-2.0 >= 2.0.5... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
-------------------------------------------------------

I did a google on gtk+-2.0 and also on phg-config, but I'm a total newbie with Linux (had it installed for two days) and it's all over my head so far. I thought I was doing pretty good to figure out how to doewnload, unzip and then to try and load programs.

Also I nuzipped PAn on my desktop. Will this present a problem.

Maybe this isn't a typical newbie question, but I certainly am.

Thanks
 
Old 08-17-2006, 08:08 PM   #2
Baix
Member
 
Registered: Jun 2004
Distribution: Gentoo, LFS, Slackware
Posts: 203

Rep: Reputation: 30
Hiya,

First find where gtk+-2.0.pc is with either:

Code:
locate gtk+-2.0.pc
or
Code:
find / -name gtk+-2.0.pc 2> /dev/null
If neither give you a path than you need to install gtk+. If gtk+ is installed then continue on.

Depending on where you installed gtk the .pc file will most likely be in /usr/lib/pkgconfig or /lib/pkgconfig. For example, if gtk+-2.0.pc was found in /usr/lib/pkgconfig export this path to the PKG_CONFIG_PATH variable:
Code:
export PKG_CONFIG_PATH=/usr/lib/pkgconfig/
Finally, either try running through the install again and cross your fingers or double check that you set it correctly first with:
Code:
pkg-config --modversion gtk+-2.0
Which should output the version number.

Good luck

Last edited by Baix; 08-17-2006 at 08:19 PM.
 
Old 08-18-2006, 04:18 PM   #3
cottonfever
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

Thanks for your help, I had to download gtk+-2.0 from an ftp site, when I ran it I found I had to also download and install the Pango, and Atk libraries as well and use the infor you gave me to ;locate their .pc files as well. I found it easier jsut o move these to/usr/lib/pkgconfig.

I ran ./configure for gtk=-2.0.5 and got no errors, however whn I tried to run 'make' as it says to do below in the documentation for this I get:

[root@localhost gtk+-2.0.5]# make
make: *** No targets specified and no makefile found. Stop.

So I have gone as far as my limited knowledge will take me.

If someone could help my thanks will be many.

<from the doco>
Simple install procedure
========================

% gzip -cd gtk+-2.0.5.tar.gz | tar xvf - # unpack the sources
% cd gtk+-2.0.5 # change to the toplevel directory
% ./configure # run the `configure' script
% make # build GTK
[ Become root if necessary ]
% make install # install GTK

</from the doco>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found jaygee02 Linux - Software 2 04-30-2006 11:59 PM
I met an error when I wrote a gtk program icoming Programming 1 03-16-2005 03:19 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
knoda configure error re: qt-mt library not found tr6boy Linux - Software 0 07-12-2004 10:21 PM
configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found Mugatu Linux - Software 14 12-15-2003 04:11 AM


All times are GMT -5. The time now is 05:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration