LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met; (http://www.linuxquestions.org/questions/linux-newbie-8/configure-error-library-requirements-gtk-2-0-%3D-2-0-5-not-met%3B-474903/)

cottonfever 08-17-2006 04:44 PM

configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met;
 
Hi,

I managed to get Fedora core 4 up and running and thought I might like to install PAN as a newsreader, howver after untarrign and unzipping it, I got the subject libne error message. More precisely:
-------------------------------------------------------
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.2.0 gthread-2.0 >= 2.2.0 gobject-2.0 >= 2.2.0... yes
checking GLIB_CFLAGS... -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking GLIB_LIBS... -pthread -lgthread-2.0 -lgobject-2.0 -lglib-2.0
checking for gtk+-2.0 >= 2.0.5... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
-------------------------------------------------------

I did a google on gtk+-2.0 and also on phg-config, but I'm a total newbie with Linux (had it installed for two days) and it's all over my head so far. I thought I was doing pretty good to figure out how to doewnload, unzip and then to try and load programs.

Also I nuzipped PAn on my desktop. Will this present a problem.

Maybe this isn't a typical newbie question, but I certainly am.

Thanks

Baix 08-17-2006 08:08 PM

Hiya,

First find where gtk+-2.0.pc is with either:

Code:

locate gtk+-2.0.pc
or
Code:

find / -name gtk+-2.0.pc 2> /dev/null
If neither give you a path than you need to install gtk+. If gtk+ is installed then continue on.

Depending on where you installed gtk the .pc file will most likely be in /usr/lib/pkgconfig or /lib/pkgconfig. For example, if gtk+-2.0.pc was found in /usr/lib/pkgconfig export this path to the PKG_CONFIG_PATH variable:
Code:

export PKG_CONFIG_PATH=/usr/lib/pkgconfig/
Finally, either try running through the install again and cross your fingers or double check that you set it correctly first with:
Code:

pkg-config --modversion gtk+-2.0
Which should output the version number.

Good luck :)

cottonfever 08-18-2006 04:18 PM

Hi,

Thanks for your help, I had to download gtk+-2.0 from an ftp site, when I ran it I found I had to also download and install the Pango, and Atk libraries as well and use the infor you gave me to ;locate their .pc files as well. I found it easier jsut o move these to/usr/lib/pkgconfig.

I ran ./configure for gtk=-2.0.5 and got no errors, however whn I tried to run 'make' as it says to do below in the documentation for this I get:

[root@localhost gtk+-2.0.5]# make
make: *** No targets specified and no makefile found. Stop.

So I have gone as far as my limited knowledge will take me.

If someone could help my thanks will be many.

<from the doco>
Simple install procedure
========================

% gzip -cd gtk+-2.0.5.tar.gz | tar xvf - # unpack the sources
% cd gtk+-2.0.5 # change to the toplevel directory
% ./configure # run the `configure' script
% make # build GTK
[ Become root if necessary ]
% make install # install GTK

</from the doco>


All times are GMT -5. The time now is 05:56 AM.