LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-11-2003, 10:22 PM   #1
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Rep: Reputation: 30
Question configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found


Still attempting to install apollon 0.9.1. I'm using Manrake 9.2

[root@pionex apollon-0.9.1]# ./configure
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
[root@pionex apollon-0.9.1]# grep qt config.log
configure: 26526: /usr/lib/qt3/include/qstyle.h
configure:26641: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -fno-exceptions -fno-check-new -fno-common -I/usr/lib/qt3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib -L/usr/X11R6/lib conftest.cc -lqt-mt -lpng -lz -lm -ljpeg -ldl -lXext -lX11 -lSM -lICE -lpthread 1>&5
configure:26684: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
ac_cv_have_qt=have_qt=no
kde_qtver='3'
qt_includes=''
qt_libraries=''
[root@pionex apollon-0.9.1]# ldconfig -v | grep qt
libqtc.so.1 -> libqtc.so.1.0.0
libqthreads.so.12 -> libqthreads.so.12.3.0
libqtmcop.so.1 -> libqtmcop.so.1.0.0
/usr/lib/qt3/lib:
libqt-mt.so.3 -> libqt-mt.so.3.1.2
[root@pionex apollon-0.9.1]# rpm -qa | grep qt
libqtc1-devel-3.1.3-1mdk
libqt3-3.1.2-14.1.92mdk
qt3-common-3.1.2-14.1.92mdk
libqt3-devel-3.1.2-14.1.92mdk
libqtc1-3.1.3-1mdk
[root@pionex apollon-0.9.1]# $PATH
bash: /usr/lib/qt3/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin: No such file or directory
[root@pionex apollon-0.9.1]# $QTDIR
bash: /usr/lib/qt3: is a directory
[root@pionex apollon-0.9.1]# $LD_LIBRARY_PATH
bash: /usr/lib/qt3/lib:: No such file or directory
[root@pionex apollon-0.9.1]# ls $QTDIR/lib
libdesigner.a libqassistantclient.a libqt-mt.so.3@ libqui.so@
libdesigner.prl libqassistantclient.prl libqt-mt.so.3.1@ libqui.so.1@
libeditor.a libqt-mt.prl libqt-mt.so.3.1.2* libqui.so.1.0@
libeditor.prl libqt-mt.so@ libqui.prl libqui.so.1.0.0*
[root@pionex apollon-0.9.1]#

Not really sure what else to say. I've tried to check the matter out on Google as much as possible, but I haven't found anything that works yet.

Last edited by Mugatu; 12-11-2003 at 10:27 PM.
 
Old 12-12-2003, 05:38 AM   #2
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Hmm, I saw your post and I thought "easy, he probably hasn't set $QTDIR". How wrong I was. One thing though: did you install qt from source? If not, you may need to get the qt-devel package (or something like this) that matches your qt version, so you have the required headers and so on. Do "ls $QTDIR/include" and if there's nothing there, then that might be the problem.
Also, I was puzzled to notice the lines
Quote:
[root@pionex apollon-0.9.1]# $LD_LIBRARY_PATH
bash: /usr/lib/qt3/lib:: No such file or directory
When you do "ls $QTDIR/lib" and get sensible results, and $QTDIR is clearly set correctly. I would have expected:

[root@pionex apollon-0.9.1]# $LD_LIBRARY_PATH
bash: /usr/lib/qt3/lib: is a directory

Do "echo $LD_LIBRARY_PATH" and post the results. I expect that you have done "LD_LIBRARY_PATH=/usr/lib/qt3/lib:$LD_LIBRARY_PATH", when it isn't defined, meaning that you have added "/usr/lib/qt3/lib:" as a directory, rather than "/usr/lib/qt3/lib" (no colon at the end)
I would suspect that one of these two factors is your problem
Hope this helps
Guy
 
Old 12-12-2003, 08:48 AM   #3
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
ls $QTDIR/include gives me a ton of header files

you were right--i had an extra colon at the end of the LD_LIBRARY_PATH, so i fixed it:

[root@CCSTAFF2 apollon-0.9.1]# $LD_LIBRARY_PATH
bash: /usr/lib/qt3/lib: is a directory

...but still no success. Any other suggestions?
 
Old 12-12-2003, 09:35 AM   #4
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
OK, try this:
grep QT_VERSION /usr/lib/qt3/include/qglobal.h
and check that you have at least version 3.1. Also, post the output because I am curious about something else (how the release date is found. Mine has 0x030102 which I'm guessing is 02/01/2003, but I'd be interested to see yours)

However, I think I have now found the problem. When I unset my QTDIR and attempt to configure apollon, I get the same message as you, execpt that I get "(headers and libraries) not found" instead of "(library qt-mt) not found". Which implies that qt-mt is the only thing it can't find. A quick google tells me that qt-mt is qt with threaded mode enabled - something I compiled into qt in the first place. If you installed from a binary, then it might not have threading enabled, and apollon won't be able to compile. I had another quick google and it seems that there is no qt-mt package for mandrake (but check for yourself, I only spent 30 seconds looking). You may be able to get around this but I suggest these things, in this order.
First of all, do "ls $QTDIR/lib" and see if there are any files beginning with "libqt-mt"
If there are then try:
./configure --with-qt-dir=$QTDIR --with-qt-includes=$QTDIR/include --with-qt-libraries=$QTDIR/lib

That will probably still not work as it looks like you don't have these files. If you have them and it doesn't work then let me know.

Otherwise, there is a workaround, although apparantly it's deprecated and so shouldn't really be used (but hey if it works then do it). This is:
./configure --disable-mt
which will link to a non-threaded Qt and should almost certainly work.

Hope this helps
Guy
 
Old 12-12-2003, 10:07 AM   #5
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
[root@CCSTAFF2 apollon-0.9.1]# grep QT_VERSION /usr/lib/qt3/include/qglobal.h
#define QT_VERSION_STR "3.1.2"
QT_VERSION is (major << 16) + (minor << 8) + patch.
#define QT_VERSION 0x030102
[root@CCSTAFF2 apollon-0.9.1]# ls $QTDIR/lib
libdesigner.a libqassistantclient.a libqt-mt.so.3@ libqui.so@
libdesigner.prl libqassistantclient.prl libqt-mt.so.3.1@ libqui.so.1@
libeditor.a libqt-mt.prl libqt-mt.so.3.1.2* libqui.so.1.0@
libeditor.prl libqt-mt.so@ libqui.prl libqui.so.1.0.0*

it looks like the threaded version is installed (libqt-mt.so.3.1.2), so i tried

./configure --with-qt-dir=$QTDIR --with-qt-includes=$QTDIR/include --with-qt-libraries=$QTDIR/lib

with no success. i actually think i had tried that before cause i have been searching Google myself continuously.

i tried ./configure --disable-mt, and it gave me this error:

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

whereas before i had been getting this error:

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

by the way, i did not compile Qt at all--i guess it came with Mandrake 9.2. should i perhaps try to download the source and compile it? i've never done that before, but i guess i could try...

if this helps, here is a more complete dump of my config.log file:

configure:26458: checking for Qt
configure: 26526: /usr/lib/qt3/include/qstyle.h
taking that
tried NO
configure:26641: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic
-W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-s
ubscripts -O2 -fno-exceptions -fno-check-new -fno-common -I/usr/lib/qt3/include -I/usr/X11R6/include -DQT_THR
EAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib -L/usr/X11R6/lib conftest.cc -lqt-mt -lpng -lz -lm -ljpeg -ld
l -lXext -lX11 -lSM -lICE -lpthread 1>&5
/root/tmp/cc8DNfI6.o(.text+0x8): In function `main':
: undefined reference to `QString::null'
/root/tmp/cc8DNfI6.o(.text+0xd): In function `main':
: undefined reference to `QStyleFactory::create(QString const &)'
/root/tmp/cc8DNfI6.o(.text+0x1a): In function `main':
: undefined reference to `QCursor::QCursor(int)'
/root/tmp/cc8DNfI6.o(.text+0x24): In function `main':
: undefined reference to `QCursor::~QCursor(void)'
collect2: ld returned 1 exit status
configure:26644: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 0x030100)
#error 1
#endif

int main() {
(void)QStyleFactory::create(QString::null);
QCursor c(Qt::WhatsThisCursor);
return 0;
}
configure:26684: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
 
Old 12-12-2003, 10:27 AM   #6
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Hm. Well I have the same files in my qt library directory and the exact same version of qt. I'm afraid I have one last ditch idea, which really shouldn't make a difference, but try it anyway. Instead of using LD_LIBRARY_PATH, add the line "/usr/lib/qt3" to /etc/ld.so.conf and run "ldconfig". This is probably good practice anyway. Just to check, when you set LD_LIBRARY_PATH, did you run "export LD_LIBRARY_PATH"? That could make a difference I suppose. Best just add it it /etc/ld.so.conf and see what happens
 
Old 12-12-2003, 01:39 PM   #7
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
when i went to edit /etc/ld.so.conf, it already had /usr/lib/qt3/lib listed, but i went ahead and added /usr/lib/qt3 anyway. then i typed ldconfig. now i get:

[root@CCSTAFF2 rpms]# ldconfig -v | grep qt
libqtc.so.1 -> libqtc.so.1.0.0
libqthreads.so.12 -> libqthreads.so.12.3.0
libqtmcop.so.1 -> libqtmcop.so.1.0.0
/usr/lib/qt3/lib:
libqt-mt.so.3 -> libqt-mt.so.3.1.2
/usr/lib/qt3:

so it doesn't look like there's really anything in the qt3 folder itself it really needs. and yes, i made sure i exported LD_LIBRARY_PATH. Would it help if i uninstalled qt3 and compiled it from source? even though it seems like i already have the threaded version of qt installed, that's the only other thing i can think of. thanks for all your help btw. has anyone else successfully installed apollon under mandrake 9.2 or even tried??
 
Old 12-12-2003, 03:22 PM   #8
Velvet Elvis
Member
 
Registered: Dec 2003
Distribution: debian (when I can) RHEL (when I must)
Posts: 98

Rep: Reputation: 15
It's been a few used since I used mandrake, but I seem to remember qt-mt being in a seperate package, apart from the main qt libs. Double check and make sure that's not the case.
 
Old 12-13-2003, 06:49 PM   #9
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
but doesn't this mean that qt-mt is already installed?:

[root@pionex apollon-0.9.1]# ldconfig -v | grep qt
libqtc.so.1 -> libqtc.so.1.0.0
libqthreads.so.12 -> libqthreads.so.12.3.0
libqtmcop.so.1 -> libqtmcop.so.1.0.0
/usr/lib/qt3/lib:
libqt-mt.so.3 -> libqt-mt.so.3.1.2

these are the qt packages i have installed:

[root@pionex temp]# rpm -qa | grep qt
libqtc1-devel-3.1.3-1mdk
libqt3-3.1.2-14.1.92mdk
qt3-common-3.1.2-14.1.92mdk
libqt3-devel-3.1.2-14.1.92mdk
libqtc1-3.1.3-1mdk

Apparently libqt3-3.1 is the one that contains libqt-mt. Does anyone else have any suggestions? If not, an anyone give me some instructions/tips/advice on compiling and installing qt from source? All i know is i need to install it with threading support, and this site:

http://lists.debian.org/debian-kde/2.../msg00260.html

says install it with no xkb, whatever the heck that is. Also, what is the best version to install? The version on the Trolltech site is 3.3.0b1, and i have 3.1.2-14.1.92 installed apparently. Any help at all would be appreciated--i'm still learning. One other quick question--how do i change the $PATH for root? it seems when i change the PATH in /etc/profile it only changes for the other users.
 
Old 12-13-2003, 10:17 PM   #10
Velvet Elvis
Member
 
Registered: Dec 2003
Distribution: debian (when I can) RHEL (when I must)
Posts: 98

Rep: Reputation: 15
Have you tried contracting the apollon developer? From what I gather, compiling Qt is not for the faint of heart.
 
Old 12-14-2003, 01:36 PM   #11
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
thanks for everyone's help. i found some rpms for apollon and gift:

http://mirrors.zoreil.com/www.plf.or...rake/9.2/i586/

and got apollon working. it's pretty awesome. i went ahead and compiled the plugins (gift-gnutella, fasttrack, openft, and opennap) seperately to make sure i had the latest versions, and all is working quite well. next time i'm gonna do a more thorough search for rpms be4 i compile something. i know rpms are evil, but at least they work most of the time.
 
Old 12-14-2003, 03:59 PM   #12
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Glad you got it working, still not sure why it wouldn't work though. Anyway, to change the root path, edit /root/.bash_profile (or something similar if you're not using bash) and put it in there. It should say something like: "PATH=$PATH:/sbin:/usr/sbin"
 
Old 12-14-2003, 04:55 PM   #13
Velvet Elvis
Member
 
Registered: Dec 2003
Distribution: debian (when I can) RHEL (when I must)
Posts: 98

Rep: Reputation: 15
FWIW, if you (rightly, IMHO) think rpm's are evil, you should check out a distro that doesn't use them. I personaly swear by slackware, though to can be a pain to get running at first. Debian and Gentoo are the other too big ones that don't force rpm torment upon you.
 
Old 12-14-2003, 05:16 PM   #14
Mugatu
Member
 
Registered: Dec 2003
Location: VA
Distribution: Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 30
although i think rpms might be evil, to me they are a necessary evil as i don't know enough about linux yet to compile every little piece of software. i think i'll stick with mandrake for a while until i'm more comfortable with linux, although i'm definitely gonna try out other distros on my other computers.
 
Old 12-15-2003, 04:11 AM   #15
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Debian uses .deb files which are similar to rpms, in that they're precompiled, and although the system is better (apt), you can still run into problems. I hear that Gentoo is very good, but if you really want to escape from rpms, I highly recommend you set up a couple of free partitions and go to http://www.linuxfromscratch.org where it will tell you how to compile a new distribution from scratch. It's fairly straightforward as long as you follow the instructions, and it teaches you loads about Linux. It sounds really daunting, but I did it a bit at a time, a couple of programs a day, and soon I had a really fast distribution. Not one program on my Linux was ever a binary - it's all from source and it's great.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make-Error: Vorbis Tools 1.0.1 - Library not found froedi Linux - Software 7 11-02-2009 02:04 AM
error: Qt (>= Qt 3.0.2) (library qt-mt) not found bogdanf25 Linux - Newbie 16 04-03-2005 01:53 AM
Webalizer: configure: error: png library not found... please install png. mikeshn Linux - Software 5 01-10-2005 02:28 PM
knoda configure error re: qt-mt library not found tr6boy Linux - Software 0 07-12-2004 10:21 PM
Configure error: QT not found marsonist Linux - Software 3 04-26-2004 12:48 AM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration