LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-15-2009, 05:27 AM   #1
nedzer
Member
 
Registered: Dec 2008
Posts: 44

Rep: Reputation: 15
configure: error: bad value No for --enable-gui


Hi,

configure: error: bad value No for --enable-gui

I get this error when I try and run the command

./configure --prefix=/tmp/unixODBC --enable-gui=No

Previously I got through the rest of the install
1. by changing the option to 'Yes' - that didn't work
2. removed '--enable-gui=No' completely, it runs to completion, no apparent errors

However since my unixODBC seems to not be set up correctly I want to do things by the book.

Anyone know of any downsides to altering this option. How could I force it to run with 'enable-gui=No'.

All suggestions tried and thanks for any feedback.

Cheers,

Last edited by nedzer; 01-15-2009 at 05:31 AM. Reason: Set enable-gui = Yes and that didn't work neither
 
Old 01-15-2009, 05:33 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,755
Blog Entries: 1

Rep: Reputation: 238Reputation: 238Reputation: 238
Try using --disable-gui.
 
Old 01-15-2009, 11:15 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,273

Rep: Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663Reputation: 2663
.
# 4
http://www.linuxquestions.org/questi...light=unixODBC

'./configure --without-gui'

This is tested by # 4. It works !
....

Last edited by knudfl; 01-15-2009 at 02:21 PM.
 
Old 01-15-2009, 11:51 AM   #4
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
There is a typo in the documentation. It should be lowercase:
Code:
./configure --enable-gui=no
or eventually, as already suggested
Code:
./configure --disable-gui
 
  


Reply

Tags
unixodbc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure error: configure: error: cannot execute: /usr/local/bin/arm-apple-darwin-ld GunNam Linux - General 0 10-24-2008 09:26 PM
configure script sends bad switches to daughter configure scripts Wells Linux - Software 7 10-10-2008 04:38 PM
I need to enable the GUI newbiesforever MEPIS 7 05-19-2006 05:07 PM
ppp- bad configure nak/rej error s_araj Linux - Networking 7 02-24-2005 07:42 AM
[pkgconfig] Error in ./configure; bad directory (where I'm Installing from) sitmex Linux - Software 1 05-20-2004 06:56 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration