LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   configure: error: bad value No for --enable-gui (http://www.linuxquestions.org/questions/linux-newbie-8/configure-error-bad-value-no-for-enable-gui-697448/)

nedzer 01-15-2009 05:27 AM

configure: error: bad value No for --enable-gui
 
Hi,

configure: error: bad value No for --enable-gui

I get this error when I try and run the command

./configure --prefix=/tmp/unixODBC --enable-gui=No

Previously I got through the rest of the install
1. by changing the option to 'Yes' - that didn't work
2. removed '--enable-gui=No' completely, it runs to completion, no apparent errors

However since my unixODBC seems to not be set up correctly I want to do things by the book.

Anyone know of any downsides to altering this option. How could I force it to run with 'enable-gui=No'.

All suggestions tried and thanks for any feedback.

Cheers,

weibullguy 01-15-2009 05:33 AM

Try using --disable-gui.

knudfl 01-15-2009 11:15 AM

.
# 4
http://www.linuxquestions.org/questi...light=unixODBC

'./configure --without-gui'

This is tested by # 4. It works !
....

colucix 01-15-2009 11:51 AM

There is a typo in the documentation. It should be lowercase:
Code:

./configure --enable-gui=no
or eventually, as already suggested
Code:

./configure --disable-gui


All times are GMT -5. The time now is 01:26 PM.