LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-21-2005, 03:10 PM   #1
s_araj
Member
 
Registered: Feb 2005
Location: Mumbai, India
Distribution: FC 2 | Ubuntu 5.04 | SuSE 9.3
Posts: 46

Rep: Reputation: 15
ppp- bad configure nak/rej error


I am using a dial up connection. I am getting the following error when I try to connect to internet from FC2 m/c and am not able to correct it. I have tried kppp, wvdial and pppd.

Feb 22 00:31:28 localhost pppd[2870]: PAP authentication succeeded
......
Feb 22 00:31:29 localhost kernel: PPP Deflate Compression module registered
.......
Feb 22 00:31:30 localhost pppd[2870]: Received bad configure-nak/rej: 12 06 00 00 00 01

I am shown connected to internet, even ping to any site works well, but am not able to surf.
 
Old 02-23-2005, 08:09 AM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Add the "debug" option to /etc/ppp/options to get some extra logging details..
 
Old 02-23-2005, 10:45 AM   #3
s_araj
Member
 
Registered: Feb 2005
Location: Mumbai, India
Distribution: FC 2 | Ubuntu 5.04 | SuSE 9.3
Posts: 46

Original Poster
Rep: Reputation: 15
On suggestion from other forums, I got it working by adding the ISP's primary and secondary IP addresses in /etc/resolv.conf.

But the internet speed is still slow, as against the normal speeds of 30Kbps in windows. Anyways, its working now.
 
Old 02-23-2005, 10:54 AM   #4
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Do ifconfig and post the MTU values..
They should be between 1500-1450..
 
Old 02-23-2005, 11:55 AM   #5
s_araj
Member
 
Registered: Feb 2005
Location: Mumbai, India
Distribution: FC 2 | Ubuntu 5.04 | SuSE 9.3
Posts: 46

Original Poster
Rep: Reputation: 15
Output of ifconfig is as shown below....

Link encap:Point-to-Point Protocol
inet addr:220.224.x.x P-t-P:97.235.x.x Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:264 Metric:1
RX packets:9874 errors:0 dropped:0 overruns:0 frame:0
TX packets:8697 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:2411760 (2.3 Mb) TX bytes:601730 (587.6 Kb)

Last edited by peter_robb; 02-23-2005 at 03:46 PM.
 
Old 02-23-2005, 03:59 PM   #6
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Because the MTU in ifconfig is so small, packets will be chopped into pieces to get them across the link, which makes for a really slow link.

You can force a higher MTU by placing a value in /etc/ppp/options
eg
mtu 1500
mru 1500

See man pppd for more options
 
Old 02-24-2005, 02:32 AM   #7
s_araj
Member
 
Registered: Feb 2005
Location: Mumbai, India
Distribution: FC 2 | Ubuntu 5.04 | SuSE 9.3
Posts: 46

Original Poster
Rep: Reputation: 15
I tried wrote mtu 1500 in /etc/ppp/options. But the moment I connect to internet, the line "mtu 1500" just goes off. I think (dunno know if this is possible) the dialer erases the value or the ISP is negotiating at such a low value. Is there some other thing that can do? I would hate to go windoz only for faster downloads.
 
Old 02-24-2005, 07:42 AM   #8
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
It's time to run with the debug option in /etc/ppp/options to see why it is negotiated so low..
Usually because of low signal to noise ratio on the phone line and/or echoes..

Which programme are you using to start the dialler?
If it's kppp you can add options to the setup menu..

I'm not too sure which file the debug level gets logged to, prob /var/log/syslog
To read it, do tail -f /var/log/syslog and then start kppp (or whatever)..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 01:07 AM
can't configure ppp dosnlinux Linux - Networking 5 09-30-2005 05:33 PM
[pkgconfig] Error in ./configure; bad directory (where I'm Installing from) sitmex Linux - Software 1 05-20-2004 06:56 PM
Configure as PPP dialin server pawan Linux - Networking 0 09-17-2003 02:24 PM
How do I set ppp max bad session? mimi Linux - Networking 0 12-02-2002 01:00 AM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration