LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2004, 06:07 AM   #1
jg167
Member
 
Registered: Jun 2004
Posts: 40

Rep: Reputation: 15
can't find ide.agent & block.agent for hotplug for 2.6


I'm trying to get the PCMCIA slot working with RH 9 and a 2.6.6 kernel.

First cardmgr 3.1.31 complaied that there was a release mismatch so I upgraded to 3.2.7 with the pcmcia-cs set, that seems ok, cardmgr runs. But now when I insert a CF adapter (easy first test) I get errors about
no /etc/hotplug/ide.agent
and
no /etc/hotplug/block.agent
and indeed there are none. So that should be easy... but looking at various hotplug packages releated in 2004 (jan mar may) none of them have those either. What gives? Should I not need these (and thus have something else wrong that these are being looked for in the first place?)

Last edited by jg167; 06-15-2004 at 06:08 AM.
 
Old 06-23-2004, 06:20 PM   #2
jg167
Member
 
Registered: Jun 2004
Posts: 40

Original Poster
Rep: Reputation: 15
I was able to download the rpm-utils package from
javascriptpenExternal(%22http://www.kaybee.org/~kirk/html/linux.html%22)

which enabled me to extract just the block.agent, generic_empty.agent, and ide.agent (the last is a symlink to generic_empty.agent) and the needed hotplug.subfs.functions files from
ftp://chuck.ucs.indiana.edu/pub/arra...2.5.noarch.rpm

whcih allowed pcmcia CF adapters and the CF slot itself to work. Once again answering my own questions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotplug problems: RH 9, 2.6.6, PCMCIA-CS 3.2.7 (missing ide.agent & block.agent) jg167 Red Hat 1 06-23-2004 06:18 PM
Hotplug usb agent "Cannot get config descriptor 0"? imk Linux - Networking 0 10-26-2003 01:48 PM
Error on boot /etc/hotplug/pci.agent: line 169: 156 Aborted Anibal Slackware 0 08-26-2003 01:45 PM
Can't find package Red Hat Update Agent installed poison5151 Linux - Software 4 04-12-2003 12:40 PM
ssh-agent problem (using GDM & KDE) ocularbob Linux - Software 1 04-11-2003 05:15 PM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration