LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2006, 01:30 AM   #1
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Rep: Reputation: 0
Can't boot to Windows on Mepis 3.4


Well, things have been going fine, not had too much trouble. Untill I decided to move my 2nd hard drive.
I've got Mepis and Windows XP on different partitions of my SATA hard drive and I sued to have a backup IDE drive for my things I wanted to make sure I didn't loose. Whenever I used to boot into Windows, the grub menu would show 3 entries, Linux, HDA1, and SDA1, Windows is on the sata drive but for some reason if I selected that it wouldn't work, I'd go into some kind of prompt screen. Nothing from a normal command prompt would work. However, if I chose to boot from the backup drive, SDA1, I would then boot to Windows, no problem. Since then I no longer have that drive, I've given it to a mate who needs a spare drive, so now I can't boot into Windows. I have no idea how I could fix this, I mean I can't find anything about boot up in the control center and know next to nothing of what I could do in the command line, which I'm guessing is where I'll have to fix it from
If anyone can save me from loosing all my "My Documents" things and another HUGE install I'd be oh so gratefull.

Regards,

~evo
 
Old 05-01-2006, 09:57 AM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
First, you can mount your Windows partition(s) under Linux and access your files.
Second, we cannot help you without knowing your disks layout, please post output of fdisk -l. Furthermore, we need to see the contents of your /boot/grub/grub.conf and /boot/grub/device.map.
 
Old 05-01-2006, 03:31 PM   #3
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
It's not so much accessing my files I need, more actually being able to use Windows too. Here's the things you asked for:

fdisk -l:
Code:
Disk /dev/hda: 6488 MB, 6488294400 bytes
255 heads, 63 sectors/track, 788 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         788     6329578+   b  W95 FAT32

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        7295    58597056    7  HPFS/NTFS
/dev/sda2   *        7296        8573    10265535   83  Linux
/dev/sda3            9668        9729      498015   82  Linux swap / Solaris
/dev/sda4            8574        9667     8787555   83  Linux

Partition table entries are not in disk order
/boot/grub/device.map:
Code:
(hd0)	/dev/hda
(hd1)	/dev/sda
But there was no /boot/grub/grub.conf in there. I hope this is of some help, thanks.

~evo
 
Old 05-01-2006, 04:01 PM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Well, you really need to find your grub.conf.
You have quite a mess there. GRUB is obviously installed to the MBR of hda, everything else is on sda.

One way to get your Windows to boot is by mapping drives in grub.conf, Windows won't boot if it finds itself on the second drive.

This is how Windows section in your grub.conf should look like:
Code:
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1
Second, much cleaner way, is to make your system independent of that IDE disk. This involves installing GRUB to the MBR of sda, editing devices.map and grub.conf. Let us know if you want to go this way.

Edit: Mepis may have menu.lst file instead of grub.conf.

Last edited by Emerson; 05-01-2006 at 04:06 PM.
 
Old 05-01-2006, 05:56 PM   #5
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Ok thanks for your intrest, your correct, there is a menu.lst file, here is it's contents:
Code:
timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1

gfxmenu /boot/grub/message

title MEPIS at sda2, kernel 2.6.15-1-586tsc
kernel /boot/vmlinuz-2.6.15-1-586tsc root=/dev/sda2 nomce quiet vga=791 

title Windows at sda1
rootnoverify (hd1,0)
chainloader +1

title MEMTEST
kernel /boot/memtest86.bin
I didn't exectyly understand what you meant about the mbr, but I know last time I tried to install Ubuntu, which would only let me install to the mbr of my sata drive Windows wouldn't load then either. So with Mepis I had the option of putting GRUB on the root partition(I think) which did work fine at first.
 
Old 05-01-2006, 06:11 PM   #6
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Well, am I correct assuming BIOS is set to boot from IDE? If yes, then add those map lines to the Windows section. Probably this makeactive line is not needed, it won't hurt either.

title Windows at sda1
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
makeactive
chainloader +1
 
Old 05-01-2006, 06:20 PM   #7
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
no, sorry, it's set to boot from my sata drive. I don't know why there is a boot flag for my IDE drive. As far as I can tell it boots from my second partition(Mepis root) of my sata drive.
 
Old 05-01-2006, 06:32 PM   #8
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
If BIOS is set to boot from SATA, then you need to swap entries in device.map.

(hd0) /dev/sda
(hd1) /dev/hda

Your menu.lst should look like this:

title MEPIS at sda2, kernel 2.6.15-1-586tsc
root (hd0,1)
kernel /boot/vmlinuz-2.6.15-1-586tsc root=/dev/sda2 nomce quiet vga=791

title Windows at sda1
rootnoverify (hd0,0)
makeactive
chainloader +1

Edit: Also make sure GRUB is installed to the MBR of sda or it wont work.

Last edited by Emerson; 05-01-2006 at 06:35 PM.
 
Old 05-01-2006, 06:48 PM   #9
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
ok I just changed my menu.lst, so it looks like this:
Code:
timeout 15
color cyan/blue white/blue
foreground ffffff
background 0639a1

gfxmenu /boot/grub/message

title MEPIS at sda2, kernel 2.6.15-1-586tsc
kernel /boot/vmlinuz-2.6.15-1-586tsc root=/dev/sda2 nomce quiet vga=791 

title Windows at sda1
rootnoverify (hd1,0)
chainloader +1

title MEMTEST
kernel /boot/memtest86.bin
and it didn't work still, just goes to a GRUB prompt when I select Windows. I tried this before you mentioned about installing it on the MBR so maybe thta was why. If I've already got GRUB installed on my root partition how do I go about putting it on my MBR? Sorry for dragging this out but I really have no idea what I'm doing, though I'm learnin quick I think

Thanks,

~evo
 
Old 05-01-2006, 06:52 PM   #10
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Did you also correct your device.map? And you should add makeactive to Windows section because sda1 is not bootable for Windows if partition is not active.
If you get GRUB prompt then it is already installed to the MBR.

Edit: just saw you still have (hd1,0) under Windows, fix it.

Last edited by Emerson; 05-01-2006 at 06:53 PM.
 
Old 05-01-2006, 07:20 PM   #11
Evok3
LQ Newbie
 
Registered: Feb 2006
Posts: 18

Original Poster
Rep: Reputation: 0
I'm typing this from Windows You fixed my problem, thank you so much. I learnt a little along the way too Again, thanks, it's really appreciated.

Regards,
~evo
 
Old 05-01-2006, 07:29 PM   #12
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Glad to hear it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis destroys network for Windows johnnyjumpup MEPIS 5 10-09-2005 03:29 AM
mepis/windows partition ToofDogger MEPIS 1 09-04-2005 06:49 PM
MEPIS with other windows managers? how do I... lefty.crupps MEPIS 3 08-11-2005 10:39 PM
Opps! Mepis 3.3 took over my windows partion!? murfman89 Linux - Newbie 3 06-11-2005 11:31 AM
Triple-Boot Windows, Fedora and MEPIS cerebro89 Fedora - Installation 4 05-16-2005 03:06 AM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration