LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2011, 11:04 AM   #1
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Rep: Reputation: 48
boot problem


my computer has 2 hard disks 80GB & 1TB
I installed xp on first primary partition in 1TB hard drive.
Then debian on second (mount point : /root) & third partition (mount point : swap) which are logical type.

I asked debian to install grub & it seems it installed on MBR of 80GB hard disk .
This 80GB hard disk does not show up in BIOS so
[coolor=red]How can I install grub to MBR of 1TB partition ?[/color]
BTW , my version is debian-6.0.2.1-i386.

Thank You.
 
Old 11-22-2011, 12:42 PM   #2
SuperMechaCow
LQ Newbie
 
Registered: Nov 2011
Posts: 28

Rep: Reputation: Disabled
I'm not sure about Debian, but I know the install process in Ubuntu/Mint has a drop-down menu asking you where to install the bootloader. If you have a GUI installation, make sure you look at each screen carefully before continuing.

Do you mean that Windows is installed on the first partition and the second partition of your 1TB is Debian? If that's the case, I think a simple and obvious solution is to disconnect the 80gb during the installation so that there is no wrong disk to write to.
 
1 members found this post helpful.
Old 11-22-2011, 01:31 PM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Fdisk -l will tell you which drive is listed as sda if sda is the 80 Gig drive then grub will try to install there, but you can install it to sdb but you have to change the line at grub install.
Another option would be to change the boot order of hard drives under boot options.
 
Old 11-22-2011, 03:23 PM   #4
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: Stuttgart, Germany
Distribution: Debian like
Posts: 710
Blog Entries: 2

Rep: Reputation: 68
I suppose XP is booting?
So, I would install Grub4Dos on the 1TB: I think you can start debian.
See example how to start tinycorelinux via XP + Grub4Dos in http://forum.tinycorelinux.net/index....html#msg59705
 
Old 11-22-2011, 09:36 PM   #5
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,398

Rep: Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207
A bit odd that the 80G doesn't show in bios. That is not a real issue. The issue is you told or didn't actually tell where to put grub.
 
Old 11-23-2011, 07:16 AM   #6
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 260

Rep: Reputation: 42
Download very small super grub2 disk and burn it to CD, boot the CD and select the pre-selected option to detect any OS, shortly after it will show your two Debian booting options, normal and recovery, and the Windows XP option. Select the Debian normal boot option and hit enter and it will boot you into Debian. Open a terminal and run the fdisk command as root or sudo to find which disk your installations are on. If indeed they are on /dev/sda, run command as root or sudo: update-grub then command: grub-install /dev/sda to install to the MBR. Reboot and there should be a menu to select either Debian normal, recovery or Windows XP.
 
1 members found this post helpful.
Old 11-26-2011, 02:32 AM   #7
sumeet inani
Member
 
Registered: Oct 2008
Posts: 895
Blog Entries: 26

Original Poster
Rep: Reputation: 48
Thank You , brains

initially I had super grub disk 1 which could be installed to usb without formatting it .
In case of installing super grub disk2 (on my uSB stick) I had to do
'dd if=path-to-iso-image of=/dev/sdd' (on my puppy)
Thus my USB stick is empty except iso files on it.
I selected 'detect any OS'
It gave me list of debian-normal,debian-recovery & xp boot
I booted normally into debian then
ran
'df' which told root as /dev/sdb6
so I did as root
'update-grub;grub-install /dev/sdb'

VOILA !
My system's bootloader is concise & clear.

Last edited by sumeet inani; 11-26-2011 at 08:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't select XP OS in a dual boot with Isadora at boot screen (grub problem) faby1321 Linux Mint 10 08-10-2010 07:07 PM
Fedora 9x64 AHCI problem - no boot (only CD Rom boot) after install sandaili Fedora 1 06-06-2008 03:33 PM
boot to GUI problem want grub boot to single user mode. hocheetiong Linux - Newbie 1 09-26-2007 07:41 PM
solaris boot problem boot error loading interpreter(misc/krtld) Johncy_j Solaris / OpenSolaris 5 08-18-2005 02:47 AM
problem with Installing red hat linux dual boot(/boot < for 1024 cylinders ) praveenb Linux - Newbie 2 02-13-2004 09:49 PM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration