LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices



Reply
 
Search this Thread
Old 08-03-2010, 01:00 AM   #1
faby1321
LQ Newbie
 
Registered: May 2007
Posts: 17

Rep: Reputation: 0
Question Can't select XP OS in a dual boot with Isadora at boot screen (grub problem)


Hey guys , I had a dual boot
Mint9 and Xp, everything works
perfect before, but now after the last mint
update, my keyboard doesn't work, i can't select
xp, arrows or any key doesn't work until it boots
in linux, key board works perfect after login in mint, but
I need to boot in xp to retrieve some files.

any help!!
 
Old 08-03-2010, 04:52 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
you need to put an entry in grub.cfg (I think) for XP. Something like

title your pet name for XP - feel free to be abusive
rootnoverify (your xp drive in grub speak, hd0.0 or that sort of thing in round brackets)
chainloader +1
 
Old 08-03-2010, 04:38 PM   #3
faby1321
LQ Newbie
 
Registered: May 2007
Posts: 17

Original Poster
Rep: Reputation: 0
To Business kid
What are your talking about? ,
computer works perfect since i installed
Xp and LM9, no need to config grub.cfg,
or put a name o label to xp!
beside that XP is installed in a partition not on
a drive, and you don't have a chainloader+1 in
Grub2
Please if you don't know, don't guess

I have a 160GB HD, partitioned like this:
15gb-ext4-mounted at / installed Linux mint- /dev/sda1
2gb -swap space
86gb-extended partition- ext4-(2gb for swap & 84gb for separated home partition), /dev/sda2
31gb-NTFS-bootable-I installed Window$ XP Pro in this partition= /dev/sda3
27gb-NTFS- I use this partition for data and storage-(I can mount this partition from linux or from XP)- /dev/sda4

When I installed Xp, the entry that you talk about
is already done automatically by the installer itself
so there isn't a need to mess around with grub.cfg, (that's the installer job).
 
Old 08-04-2010, 02:57 AM   #4
markmurf
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
I assume your keyboard is a USB keyboard? Do you have the option of trying a PS2 keyboard to see if the same behaviour is exhibited?
Check your BIOS and make sure USB input devices is enabled, or whatever option your particular BIOS has.
If none of these options help, you might need to update grub, and that may help with your issue.
 
Old 08-05-2010, 04:04 PM   #5
faby1321
LQ Newbie
 
Registered: May 2007
Posts: 17

Original Poster
Rep: Reputation: 0
NO, my keyboards are(have 2) PS2,
and of course I can't go to bios
because the keyboard doesn't respond
when booting up!!

none of the key works when booting up,
so i can't select any of my 2 OS, but it
works after the computer
boots in linux, (after the 10 seconds count)

and yes, i already updated grub
thanks for your answer, and your time spent
i appreciated.
 
Old 08-06-2010, 02:45 AM   #6
markmurf
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
Well, that has me completely stumped. I don't see how or why updating Mint would cause a PS2 type keyboard to stop responding at boot time. It may be a worthwhile exercise looking through your history log file in /var/log/apt to see what packages you last updated and that will at least give you a starting point as to what may be causing the problems. Post your results here if you wish.
 
Old 08-07-2010, 12:23 AM   #7
faby1321
LQ Newbie
 
Registered: May 2007
Posts: 17

Original Poster
Rep: Reputation: 0
After looking to /var/log/apt,
i found this:



Start-Date: 2010-07-24 21:43:37
Upgrade: xulrunner-1.9.2 (1.9.2.6+nobinonly-0ubuntu0.10.04.1, 1.9.2.7+build2+nobinonly-0ubuntu0.10.04.1), apt-transport-https (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), mintsystem (7.6.8, 7.6.9), apt-utils (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), apt (0.7.25.3ubuntu9, 0.7.25.3ubuntu9.1), firefox (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), mintupdate (4.0.5, 4.0.6), firefox-gnome-support (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), firefox-branding (3.6.6+nobinonly-0ubuntu0.10.04.1, 3.6.7+build2+nobinonly-0ubuntu0.10.04.1), ureadahead (0.100.0-4.1, 0.100.0-4.1.2)
End-Date: 2010-07-24 21:44:14

Start-Date: 2010-07-27 17:03:53
Upgrade: xulrunner-1.9.2 (1.9.2.7+build2+nobinonly-0ubuntu0.10.04.1, 1.9.2.8+build1+nobinonly-0ubuntu0.10.04.1), thunderbird (3.0.5+build2+nobinonly-0ubuntu0.10.04.1, 3.0.6+build2+nobinonly-0ubuntu0.10.04.1), firefox (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1), gdm (2.30.2.is.2.30.0-0ubuntu2, 2.30.2.is.2.30.0-0ubuntu3), firefox-gnome-support (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1), firefox-branding (3.6.7+build2+nobinonly-0ubuntu0.10.04.1, 3.6.8+build1+nobinonly-0ubuntu0.10.04.1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2010-07-27 17:04:20

Start-Date: 2010-07-28 09:47:11
Upgrade: ubuntu-system-service (0.1.20, 0.1.20.1)
End-Date: 2010-07-28 09:47:22


My problem started
between july 24 and july 28,
so I don't know what to do or where to
look up I think the las one screwed up my computer
the ubuntu system service update,
thank for checking
 
Old 08-07-2010, 12:56 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
here is the problem you did what your system asked you to do up date the O/S. updated.
Quote:
Hey guys , I had a dual boot
Mint9 and Xp, everything works
perfect before, but now after the last mint
update, my keyboard doesn't work, i can't select
xp, arrows or any key doesn't work until it boots
in linux, key board works perfect after login in mint, but
I need to boot in xp to retrieve some files.
now please be kind look at this
Quote:
, i can't select
xp, arrows or any key doesn't work until it boots
Befor O/s boots it is bios. Not a operating system.
this is a grub hard ware bios problem ???????? not sure.
usb key board? how about a little info.

let me guess ps2 mouse that was pulled out and put back in and a keyboard that has ps 2 connection also.
since nothing is running
Because you said
Quote:
key doesn't work until it boots
trust me I do hardware for a living. Intel board will not boot with out keyboard. Look back. this is the first thing you learn. Dirty keys? etc.
Quote:
works after the computer
boots in linux, (after the 10 seconds count)
switch the ps2 mouse with the ps2 keyboard yes this is a bios read old
old problem. Xp has the ability to play with bios not Linux.
get rid of xp and put bios in none windows none os environment
Yes you did up grade doze xp.

Last edited by Drakeo; 08-07-2010 at 01:07 AM.
 
Old 08-08-2010, 09:16 AM   #9
pierre2
Member
 
Registered: May 2009
Location: Perth, AU
Distribution: LinuxMint
Posts: 339
Blog Entries: 8

Rep: Reputation: 74
Quote:
switch the ps2 mouse with the ps2 keyboard yes this is a bios read old
old problem. Xp has the ability to play with bios not Linux.
get rid of xp and put bios in none windows none os environment
Yes you did up grade doze xp.
Don't follow that bit ..

I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.

& anyway, a kernel upgrade is not going to cause the OPs problems.

Last edited by pierre2; 08-08-2010 at 09:18 AM.
 
Old 08-09-2010, 08:51 AM   #10
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Don't follow that bit ..

I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.
That is the same thing I said no pnp. ok if you go back 25 years the pnp was not there it was OS select when we had OS2 from IBM and a IBM spin off company M$ from Bill Gates. and Unix.
sorry if I did not make sense to you. to day plug N play has gone different directions in bios
Quote:
pierre2 you actually know his version of bios and see the no plug n play settings
proprietary bios by mother board manufactures vary so much I have to give a generic answer in order for them to find select os. and that option is not on all proprietary boards.
Quote:
I generally set the bios to "no plugNplay" aware O/S.
that way,, only the O/S can set, how the hardware operates.
when set to NONE plug N Play this allows the bios to set the IRQ's
then The kernel will read them and set up to them.
That said Linux is not designed to run bios never will. PNP was experimental for 10 years. UDEV hotplug just reads the bios and sets up the hardware hal runs them.
Since this problem.
Quote:
Since this problem is before the O/S is started what is this going to do
this is why we set to No O/S Select or NO plug N play No windows or no OS/2 they all mean the same thing let bios run the board and do not let the O/S change IRQ addresses.

Last edited by Drakeo; 08-09-2010 at 09:07 AM.
 
Old 08-10-2010, 07:07 PM   #11
faby1321
LQ Newbie
 
Registered: May 2007
Posts: 17

Original Poster
Rep: Reputation: 0
after more than 2 weeks, i got a little frustrated
so i decided to reinstall LinuxMint 9 (again), and that
did the trick or solution, unfortunately i didn't find
out what was the problem that caused the keyboard stop
working, so in the future I can't help someone with the
same problem.

Anyway my problem is solved
I just wanna say thanks to everyone that tried to help me

Now I'm so happy with my 2 worlds (Linux & Window$)

Thanks and bye.
 
  


Reply

Tags
boot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 06:45 PM
How to select boot OS before restart in a Dual Boot Environment? stulluk Linux - Newbie 3 05-18-2009 03:43 PM
I am getting a frozen screen once i try to load linux mint through grub in dual boot putush Linux - Newbie 2 10-25-2007 01:08 AM
GRUB dual boot problem: Boot "other" (windows) just restarts GRUB! stevod333 Linux - Software 13 04-06-2006 06:26 AM
How to change default OS in Grub dual boot screen vipin_mittal Red Hat 1 05-29-2004 09:26 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration