LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-16-2008, 03:06 AM   #1
crazyivan
Member
 
Registered: Mar 2007
Distribution: Debian, Ubuntu server
Posts: 40

Rep: Reputation: 15
Question Authenticating Samba and Win2K NT_STATUS_IO_TIMEOUT


Hello crew,

I'm having troubles with authenticating a linux samba client to a win2k domain. Without creating local users I want to be able to log on using a user and pass valid only in the windows domain.

Somehow I seem to be stuck on the last part:

When I log in with correct user and correct pass:

/var/log/pam.log
Jan 14 16:29:03 sandbox pam_winbind[2632]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 16:29:07 sandbox pam_winbind[2632]: Verify user `testuser'
Jan 14 16:29:17 sandbox pam_winbind[2632]: request failed: NT_STATUS_IO_TIMEOUT, PAM error was System error (4), NT error was NT_STATUS_IO_TIMEOUT
Jan 14 16:29:17 sandbox pam_winbind[2632]: internal module error (retval = 4, user = `testuser')

When I login using a WRONG password:

/var/log/pam.log
Jan 14 16:31:33 sandbox pam_winbind[2675]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 16:31:35 sandbox pam_winbind[2675]: Verify user `testuser'
Jan 14 16:31:35 sandbox pam_winbind[2675]: request failed: Wrong Password, PAM error was Authentication failure (7), NT error was NT_STATUS_WRONG_PASSWORD
Jan 14 16:31:35 sandbox pam_winbind[2675]: user `testuser' denied access (incorrect password or invalid membership)

When I login using `wronguser`:

/var/log/pam.log
Jan 14 17:38:43 sandbox pam_winbind[2928]: pam_winbind: pam_sm_authenticate (flags: 0x0000)
Jan 14 17:38:45 sandbox pam_winbind[2928]: Verify user `wronguser'
Jan 14 17:38:45 sandbox pam_winbind[2928]: request failed: No such user, PAM error was User not known to the underlying authentication module (10), NT error was NT_STATUS_NO_SUCH_USER
Jan 14 17:38:45 sandbox pam_winbind[2928]: user `wronguser' not found


Testing the authentication using `kinit` works perfectly. `wbinfo -u` and `wbinfo -g` produce all users and groups in domain. `getent passwd` gives me only the local machines listings. I'm working with a fresh debian install. All packages are installed `out of the box`. I'm very willing to supply more info but I thought posting the entire config upfront is a little too much. I'm using Linux sandbox 2.6.18-5-686 #1 SMP Mon Dec 24 16:41:07 UTC 2007 i686 GNU/Linux
and Samba Version 3.0.24

Cheers

[edit]Typo[/edit]
 
  


Reply

Tags
kerberos, nt, pam, samba windows, status, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba member server as fileserver authenticating samba PDC activeq Linux - Networking 0 11-17-2006 10:44 AM
Authenticating with Samba from XP domain rw@garibaldi Linux - Networking 4 12-19-2005 02:51 AM
Authenticating on a win2k PDC with Active Directory and disk quotas morfeo Linux - Networking 1 10-07-2004 01:32 PM
Authenticating Win2K on Samba 3.0.2a jacquedp Linux - Networking 7 03-23-2004 03:46 PM
RH9 authenticating to Win2K domain BruceC Linux - Networking 0 08-05-2003 09:53 AM


All times are GMT -5. The time now is 04:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration