LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-19-2004, 08:34 AM   #1
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Rep: Reputation: 21
NFS server - client cannot mount remote file system


Hi. I'm pretty new to this linux stuff and am having problems sharing files between 2 systems. I have configured NFS Server on one PC and each time I try to mount the exported directory from the client, I get the message:

mount: RPC: Remote system error - No route to host

The 2 systems can ping each other quite happily, but that's about as far as I have got!

My configuration is as follows:

The server is running Red Hat Fedora and has the host name fedora and the IP address 192.168.1.1
The client is running Red Hat 9 and has the IP address 192.168.1.2

From the graphical NFS Server utility on the server, I have exported the following:

/root, to host 192.168.1.2/24, permissions Read/Write

The /etc/exports file has the following entry: /root 192.168.1.2/24(rw,sync,no_root_squash)
There is nothing concerning the new exported dir in /etc/fstab or /etc/mtab

On the client, I have created /mnt/fedora

The commands I have issued at the client to try to mount the remote filesystem are:

mount fedora:/root /mnt/fedora
mount 192.168.1.1:/root /mnt/fedora
mount -t nfs 192.168.1.1:/root /mnt/fedora

The error message is the same:
mount: RPC: Remote system error - No route to host

Accoding to the NFS server help file, the required services should start automatically,but I have tried stopping and re-starting them manually anyway, using the commands:

/etc/init.d/nfs start
/etc/init.d/nfslock start

ps ax gives processes for:

portmap
rpc.statd
rpc.rquotad
[nfsd] (8 of these)
lockd
rpciod
rpc.mountd

Please help!!!

Mike.
 
Old 01-19-2004, 05:33 PM   #2
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Change the .2 to .0 in
192.168.1.2/24
and check that you are not filewalling
iptables -L -n;
 
Old 01-20-2004, 01:17 PM   #3
mikemrh9
Member
 
Registered: Nov 2003
Distribution: Arch
Posts: 136

Original Poster
Rep: Reputation: 21
Yep! Disabled the firewalls and it worked straight away.

Thanks very much - I'd forgotten all about the firewall......
 
Old 02-04-2006, 10:31 AM   #4
nukeu666
Member
 
Registered: Mar 2004
Location: India
Distribution: MDK, Fedora, Debian Unstable (current)
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by g-rod
Change the .2 to .0 in
192.168.1.2/24
and check that you are not filewalling
iptables -L -n;
im having the same problem
i dunno anyhtign about iptables...so what should i be trying to find or fix?
 
Old 02-05-2006, 10:06 AM   #5
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
First, you need to configure mountd and rquotad to use static ports; they don't by default. I bind them to ports 922 and 923, but you can use any unused ports you wish. In Red Hat distros, the relevant file is /etc/sysconfig/nfs.

Code:
[root@petrel ~]# cat /etc/sysconfig/nfs
export MOUNTD_PORT=922
export RQUOTAD_PORT=923
Next, restart your nfs server. (Again, using Red Hat techniques.)
Code:
/sbin/service nfs restart
Finally, modify your software firewall to allow clients to connect to your nfs server. By using the "-s 192.168.1.0/24" option, I allow only internal clients to connect. Modify or leave it out altogether if you wish.
Code:
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 922 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 922 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 923 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 923 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 111 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 111 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 2049 -j ACCEPT
 
Old 10-12-2006, 11:05 PM   #6
jola
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
SUSE 10.1 NFS problems

i use command "service nfs start " but if promote :
Net File System UNUSED
why ???

my development board can not mount NFS server .help !
 
Old 10-12-2006, 11:05 PM   #7
jola
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
help to check how to use nfs service on suse10.1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 8 09-22-2006 03:34 AM
mount the filesystem from the remote NFS server. UltraSoul Solaris / OpenSolaris 8 08-12-2005 07:51 AM
want to mount a remote unix-based file system to fc2, nfs the answer? how? parv Fedora 3 09-23-2004 12:28 PM
How can I nfs mount an NTFS file system on my linux server jj4broder Linux - Networking 4 09-30-2003 02:03 PM
A mounted file system inside an NFS mount paradoxlight Linux - Networking 1 04-24-2002 08:34 PM


All times are GMT -5. The time now is 05:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration