LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices


Reply
  Search this Thread
Old 08-06-2005, 05:16 PM   #1
dennyqian
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Rep: Reputation: 0
how to mount a nfs mount from linux client to AIX nfs server


Hi Everyone,
I've export a directory from the AIX NFS server. It don't have any problem being NFS mounted by other AIX system. While I tried to use one linux doing the same NFS mount, it returned the " permittion denied" error.

Is there anything special I should do on this linux client before I do the "NFS mount" ?


Appreciate for any suggestion
Regards
Denny
 
Old 08-07-2005, 04:46 PM   #2
dennyqian
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Original Poster
Rep: Reputation: 0
Can someone help me ?

Can someone help me ? Is there any NFS log I can check ?
 
Old 08-08-2005, 05:52 AM   #3
Mark Taylor
Member
 
Registered: Apr 2004
Posts: 60

Rep: Reputation: 15
nfso -p -o nfs_use_reserved_ports=1

Rgds
Mark Taylor
 
Old 08-10-2005, 07:42 AM   #4
zorba4
Member
 
Registered: Feb 2004
Location: Paris
Posts: 398

Rep: Reputation: 31
by the way, look at your network installation.
"Permission denied" usually means "I don't know this guy".
1) go to the AIX system, and type "ping -c 3 my_linux_client".
2) On the AIX server system, "cat /etc/exports" in order to verify that your fileystem is correctly exported.
3) usually, on Linux systems, "mount aix_server:/shared_filesystem /mnt" works without problem.
 
Old 09-02-2005, 05:26 AM   #5
MaliCure
LQ Newbie
 
Registered: Sep 2005
Location: Rotterdam
Posts: 1

Rep: Reputation: 0
Is the nfso command mentioned above not only applicable to an AIX NFS client?

I have the same problems, by the way.

The exports on the AIX server are listed without any options, only -root=myclient
where myclient is an antry in the hosts file with the proper IP address.

I use RedHat ES3, trying to connect to an NFS server on an AIX 4.3 cluster.

This is the dump of nfso -a:

portcheck= 0
udpchecksum= 1
nfs_socketsize= 60000
nfs_tcp_socketsize= 60000
nfs_setattr_error= 0
nfs_gather_threshold= 4096
nfs_repeat_messages= 0
nfs_udp_duplicate_cache_size= 5000
nfs_tcp_duplicate_cache_size= 0
nfs_server_base_priority= 0
nfs_dynamic_retrans= 1
nfs_iopace_pages= 0
nfs_max_connections= 0
nfs_max_threads= 8
nfs_use_reserved_ports= 0
nfs_device_specific_bufs= 1
nfs_server_clread= 1
nfs_rfc1323= 0
nfs_max_write_size= 0
nfs_max_read_size= 0
nfs_allow_all_signals= 0
nfs_v2_pdts= 1
nfs_v3_pdts= 1
nfs_v2_vm_bufs= 1000
nfs_v3_vm_bufs= 1000


I tried mostly with the client defaults, and also with option "udp"

The problem is that I cannot use "trial and error" since it seems that in some occasions the portmapper dies on the AIX server.
 
Old 09-28-2005, 04:58 PM   #6
louis_m_c
LQ Newbie
 
Registered: Dec 2004
Location: Saint-Hubert, Canada
Posts: 26

Rep: Reputation: 15
I have the same problem here and I found out why I get this error:
on my server my uid is 500 and on my client 501 so they dont match which cause the access denied.
 
Old 10-18-2005, 06:20 PM   #7
baktor
LQ Newbie
 
Registered: Sep 2005
Location: Atlanta, GA USA
Posts: 17

Rep: Reputation: 0
well, I'm a bit confused what your exact issue is, but here is how I mount on my Redhat server an AIX mount:

10.28.1.61:/u37/somedir /mnt/somedir nfs rsize=8192,wsize=8192,intr,posix 0 0

and on AIX, that export looks like:
/u33/cold_backups -root=hqs6000aortal2,access=hqs6000aortal2

portal2 being the Redhat box. Key is making SURE hostname is in /etc/hosts on the AIX box and that your UID/GID matches up between the two boxes. I hope this makes sense.
 
Old 09-22-2006, 03:19 AM   #8
hshbo
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Hi,

I configured on NFS at Linux site (client of AIX) as follow:

Directory: /mnt/testdatalinuxclient
Host: <ip of aix server>
Permision is Read/Write and chmod -R 777 /mnt/testdatalinuxclient

At aix server, I use command:
mount -o proto=udp <ip of Linux client>:/mnt/testdatalinuxclient /mnt/testdataaixserver

Mount failed. Error message:

mount: 1831-008 giving up on:
<ip of linuxclient>:/mnt/testdatalinuxclient
vmount: Operation not permitted.

Please help me fix this. Thanks so much.
 
Old 09-22-2006, 03:34 AM   #9
hshbo
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
It works well. Thanks Mark Taylor.
 
Old 03-30-2016, 10:45 PM   #10
thuyentv
LQ Newbie
 
Registered: Mar 2016
Posts: 3

Rep: Reputation: Disabled
how to mount a nfs mount from linux client to AIX nfs server

Hi Support Team,
on AIX we use NFS Share. But which mount from linux client to AIX Server but see error:
"nfs.mount: remote I/O error".
we try use "mount -o -vers=3" and mount success. But I need use mount vers=4. because linux client use default version 4 get file.
how to resolve it ?
Many thanks support.
 
Old 03-31-2016, 05:06 AM   #11
Michael AM
Member
 
Registered: May 2006
Distribution: AIX 5.3, AIX 6.1, AIX 7.1
Posts: 109

Rep: Reputation: 29
The key here is the NFS domain.

From memory linux has a "default" nfs4domain - that comes from the FQDN. host.dom1.dom2 - so the NFS4 domain is: "dom1.dom2".

On AIX (server) you will need to run the commands:

# chnfsdom "dom1.dom2"
# nfs.clean # to stop all NFS activity, do not use stopsrc -g nfs
# rc.nfs # even more important, do not use startsrc -g nfs !!!

Use either chnfsexp or mknfsexp to add NFS4 "knowledge". I have a primer (that needs updating to work with Linux) at: http://www.rootvg.net/content/view/476/88/

Michael
 
Old 04-08-2016, 04:13 AM   #12
thuyentv
LQ Newbie
 
Registered: Mar 2016
Posts: 3

Rep: Reputation: Disabled
Hi Michael,
we go the follow as you posted. But we do not setup nfs domain on NFS Client (Redhat). How to setup NFS domain on Redhat.
also we sent for you command output on nfs client:
# chnfsdom nfsdomain
bash: chnfsdom: command not found

Could you please resolve it help me.
Many thanks support.
 
Old 04-08-2016, 05:18 AM   #13
Michael AM
Member
 
Registered: May 2006
Distribution: AIX 5.3, AIX 6.1, AIX 7.1
Posts: 109

Rep: Reputation: 29
chnfsdom is the AIX command to set the nfsv4 domain name.

I do not have a redhat to verify (atm), but think of redhat booting ASIF it was configured to run

Quote:
chnfsdom `hostname -d`
In otherwords, (and I shall test soon), on AIX run

Quote:
chnfsdom `ssh xyz@redhat hostname -d`
nfs.clean
rc.nfs
Hopefully that will have your AIX NFS (server/client) speaking the same domain as the redhat/suse, etc.

Note: I am working on LoP (Linux on Power), so I shall be looking into this!

If this does not work, on your linux client just add nfsvers=3 to your linux mount options.
 
Old 04-11-2016, 11:30 PM   #14
thuyentv
LQ Newbie
 
Registered: Mar 2016
Posts: 3

Rep: Reputation: Disabled
Hi Michael,
Case is to resolve.
Many thanks support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS server - client cannot mount remote file system mikemrh9 Linux - Networking 6 10-12-2006 11:05 PM
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 05:16 AM
NFS failed from linux client to AIX server dennyqian Linux - Networking 1 08-07-2005 04:44 PM
Getting NFS to work (AIX client/Linux server) Derefin Linux - Networking 2 11-17-2003 10:31 AM
How can I nfs mount an NTFS file system on my linux server jj4broder Linux - Networking 4 09-30-2003 02:03 PM


All times are GMT -5. The time now is 07:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration