LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   NFS server - client cannot mount remote file system (http://www.linuxquestions.org/questions/linux-networking-3/nfs-server-client-cannot-mount-remote-file-system-136327/)

mikemrh9 01-19-2004 08:34 AM

NFS server - client cannot mount remote file system
 
Hi. I'm pretty new to this linux stuff and am having problems sharing files between 2 systems. I have configured NFS Server on one PC and each time I try to mount the exported directory from the client, I get the message:

mount: RPC: Remote system error - No route to host

The 2 systems can ping each other quite happily, but that's about as far as I have got!

My configuration is as follows:

The server is running Red Hat Fedora and has the host name fedora and the IP address 192.168.1.1
The client is running Red Hat 9 and has the IP address 192.168.1.2

From the graphical NFS Server utility on the server, I have exported the following:

/root, to host 192.168.1.2/24, permissions Read/Write

The /etc/exports file has the following entry: /root 192.168.1.2/24(rw,sync,no_root_squash)
There is nothing concerning the new exported dir in /etc/fstab or /etc/mtab

On the client, I have created /mnt/fedora

The commands I have issued at the client to try to mount the remote filesystem are:

mount fedora:/root /mnt/fedora
mount 192.168.1.1:/root /mnt/fedora
mount -t nfs 192.168.1.1:/root /mnt/fedora

The error message is the same:
mount: RPC: Remote system error - No route to host

Accoding to the NFS server help file, the required services should start automatically,but I have tried stopping and re-starting them manually anyway, using the commands:

/etc/init.d/nfs start
/etc/init.d/nfslock start

ps ax gives processes for:

portmap
rpc.statd
rpc.rquotad
[nfsd] (8 of these)
lockd
rpciod
rpc.mountd

Please help!!!

Mike.

g-rod 01-19-2004 05:33 PM

Change the .2 to .0 in
192.168.1.2/24
and check that you are not filewalling
iptables -L -n;

mikemrh9 01-20-2004 01:17 PM

Yep! Disabled the firewalls and it worked straight away.

Thanks very much - I'd forgotten all about the firewall......

nukeu666 02-04-2006 10:31 AM

Quote:

Originally Posted by g-rod
Change the .2 to .0 in
192.168.1.2/24
and check that you are not filewalling
iptables -L -n;

im having the same problem
i dunno anyhtign about iptables...so what should i be trying to find or fix?

jcliburn 02-05-2006 10:06 AM

First, you need to configure mountd and rquotad to use static ports; they don't by default. I bind them to ports 922 and 923, but you can use any unused ports you wish. In Red Hat distros, the relevant file is /etc/sysconfig/nfs.

Code:

[root@petrel ~]# cat /etc/sysconfig/nfs
export MOUNTD_PORT=922
export RQUOTAD_PORT=923

Next, restart your nfs server. (Again, using Red Hat techniques.)
Code:

/sbin/service nfs restart
Finally, modify your software firewall to allow clients to connect to your nfs server. By using the "-s 192.168.1.0/24" option, I allow only internal clients to connect. Modify or leave it out altogether if you wish.
Code:

/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 922 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 922 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 923 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 923 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 111 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p udp --dport 111 -j ACCEPT
/sbin/iptables -A INPUT -s 192.168.1.0/24 -p tcp --dport 2049 -j ACCEPT


jola 10-12-2006 11:05 PM

SUSE 10.1 NFS problems
 
i use command "service nfs start " but if promote :
Net File System UNUSED
why ???

my development board can not mount NFS server .help !

jola 10-12-2006 11:05 PM

help to check how to use nfs service on suse10.1


All times are GMT -5. The time now is 03:58 AM.