LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-30-2006, 07:50 PM   #1
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
dhcp says "wrong interface name: "ath0"


Is this normal when you don't use "eth0" as your interface, or have I got something wrong? It works, but I'm not comfortable seeing an error from dhcp.

I have configured a Netgear WG311T wireless card on my Debian 2.6.8 system a bit differently from what I found in the documentation; mainly because I was having a lot of problems getting the thing to connect to my router. And since I wound up with a script that worked, I used it. I never got wpa_supplicant working, and removed it from my system. I'm using madwifi. Here's what I wound up with in my config files:

/etc/network/interfaces: (relevant lines)
auto ath0
iface ath0 inet dhcp
pre-up sh /etc/network/ath0/ath0.sh

/etc/network/ath0/ath0.sh:
#!/bin/sh
/sbin/iwconfig ath0 essid OurHouse channel 8 ap any key FFFFFFFFFF restricted
/sbin/iwconfig ath0 mode Managed txpower auto rate 11M auto sens -80 commit
/sbin/iwpriv ath0 authmode 2
/sbin/ifconfig ath0 up
echo "ath0 configured"
exit 0

/etc/dhcp/config: (relevant lines)
case ${INTERFACE} in
eth0 | ath0)


Thanks for any comments and help clearing this error/warning(?) message.
 
Old 12-01-2006, 09:04 AM   #2
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
After more digging, this was pretty easy to fix. I simply added one line to the script dhcpcd.exe as follows:

/etc/dhcpc/dhcpcd.exe:
case ${INTERFACE} in
eth*) ;;
wlan*) ;;
ath*) ;; <<<<<======= added this line
*) logger -s -p local0.err -t dhcpcd.exe "wrong interface name \"${INTERFACE}\""
exit 1
;;
esac
 
Old 12-07-2006, 01:05 PM   #3
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
Good job!

Thanks for posting your solution -- it's the way LQ is supposed to work.
 
Old 12-07-2006, 01:14 PM   #4
nuxrl
Member
 
Registered: Jun 2006
Location: NY, USA
Distribution: Slackware, Arch
Posts: 176

Rep: Reputation: 35
Talking

Quote:
Originally Posted by Quakeboy02
/etc/dhcpc/dhcpcd.exe:
dhcpcd.EXE?
 
Old 12-07-2006, 01:36 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
>>dhcpcd.EXE? <<<

You might try actually looking at the file, mate.
 
Old 12-07-2006, 01:43 PM   #6
nuxrl
Member
 
Registered: Jun 2006
Location: NY, USA
Distribution: Slackware, Arch
Posts: 176

Rep: Reputation: 35
I know that file. Just thought it's funny to see an .exe file in /etc directory.
 
Old 12-07-2006, 02:02 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
I thought it was strange, too. I didn't know it was a script file until I grepped for the error message and saw a script response. I had just assumed that a .exe was a compiled program of some sort.
 
Old 12-07-2006, 02:39 PM   #8
nuxrl
Member
 
Registered: Jun 2006
Location: NY, USA
Distribution: Slackware, Arch
Posts: 176

Rep: Reputation: 35
.exe usually is used in Windoze world.
 
Old 12-17-2006, 09:11 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
I finally revisited using wpa_supplicant on my system. It's a lot easier now that I've done this stuff a few times. I think my original problem was in getting a working wpa_supplicant.conf file created. This works better. Note, this will overwrite any existing wpa_supplicant.conf

Code:
/usr/bin/wpa_passphrase "MySSID"  "MyPassphrase" > /etc/wpa_supplicant.conf
After that, it's just a matter of changing the /etc/network/interfaces file by adding the following.

Code:
auto ath0
iface ath0 inet dhcp
        pre-up /sbin/wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -iath0
Hope this helps someone out there.
 
Old 12-19-2006, 07:03 PM   #10
>>BLACKHOLE<<
Member
 
Registered: Jun 2006
Location: In the bended light of the prism-
Distribution: Mandriva
Posts: 53

Rep: Reputation: 15
[B]Thanks for the suggestion Qboy-
---------------------------------

QUESTION: I've just installed the wpa_supplicant and the the file is /etc/wpa_supplicant.conf but it shows a change in the file as /etc/wpa_supplicant.conf.rpmnew which one should I use??
_______________________________________________________________

CHANGES:

-network={
psk=xxxxxxxxx
scan_ssid=1
ssid="my network"
}

-network={
psk=xxxxxxxxxx
scan_ssid=1
ssid="Cell2network"
}

-network={
psk=xxxxxxxxxx
scan_ssid=1
ssid="linksud"
}

-network={
psk=xxxxxxxxxxxxxxxxxxxxxxx
scan_ssid=1
ssid="My network"
}
____________________________________________________________
>>BLACKHOLE<<
 
Old 12-19-2006, 07:14 PM   #11
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
I'm not sure what rpmnew is all about, but the file is denoted by the command that you use to run wpa_supplicant. Note the "-c" option.

"/sbin/wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -iath0"

Do you really have 4 access points (routers) that you want to connect to? Use the "wpa_passphrase" command that I posted above. If you like, send it to a different file and run wpa_supplicant with the "-c" pointing to that other file. Here is a config I just generated for a pretend AP, along with the command I actually used to generate it.

Code:
bob@wendy:~$ /usr/bin/wpa_passphrase "fooessid"  "foo passphrase"
network={
        ssid="fooessid"
        #psk="foo passphrase"
        psk=114e5a1f013d25156013a1f52b3d23cec338e95a8bccfba12a6e58537a45bd36
}
 
  


Reply

Tags
debian, dhcpcd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
Any way to get "Alice"; "Call of Duty" series and "Descent 3" to work? JBailey742 Linux - Games 13 06-23-2006 01:34 PM
Error for wireless request "Set Encode" (8B2A) for ath0 Suse 9.0 debasisdan Linux - Wireless Networking 2 04-19-2006 01:28 AM
Wireless chip is displayed as "Ath0" instead of "wlan0" with Belkin F5D7000 ceramicsushi Linux - Wireless Networking 4 04-05-2006 11:26 PM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-06-2005 11:44 PM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration