LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 01-23-2013, 01:45 PM   #1
jaszczomp
LQ Newbie
 
Registered: Jan 2013
Distribution: Debian
Posts: 4

Rep: Reputation: Disabled
Nvidia (310.32) - GT635M - EDID and black screen


Hello all

My first post here, I've looked everywhere already and cannot solve my problem myself, so writing here. I have Asus R500VJ with Intel graphics and Nvidia GT635M and cannot get Nvidia drivers to work. I had EDID issue (driver couldn't get EDID info), solved it with custom EDID, everything seems OK in Xorg logs but there's still black screen. Maybe the problem is I have two graphic cards? In Xorg logs I see * before PCI:0:2:0, which is Intel card, and line below contains PCI:1:0:0 - Nvidia. If it is the source of the problem - how to disable Intel card? I've tried to disable autoadd devices and autoenable devices in X. I had many computers with very different configurations, few times had problem with Nvidia drivers (-.-), but always can solve it with X configuration, some file movements, etc.

Had anybody similar problems or know a solution already?
 
Old 01-24-2013, 08:02 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
For using the Optimus technology from Nvidia you have to use Bumblebee: http://bumblebee-project.org/
 
Old 01-25-2013, 02:21 AM   #3
jaszczomp
LQ Newbie
 
Registered: Jan 2013
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Bumblebee solved my problem, thanks, TobiSGD.
 
Old 01-25-2013, 04:37 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
It seems that your issue has been solved. If that's the case, please mark this thread as solved. This will make it easier for other members with the same problem to find this solution. You can do that with the thread tools above your initial post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen with NVIDIA drivers. iball8888 Linux Mint 10 12-03-2010 08:43 AM
get black screen after install nvidia driver!!! pzUH Fedora 3 06-01-2009 11:25 PM
nvidia drivers 8178 cause black screen (10.0) duncky Suse/Novell 35 03-24-2006 06:18 AM
nVidia in Xorg=black screen FXRS Slackware 13 07-01-2004 01:55 AM
Nvidia Black Screen (hsync out of range) JoshSmith41 Linux - Hardware 2 01-17-2004 03:38 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration