LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-27-2004, 08:40 PM   #1
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Rep: Reputation: 15
nVidia in Xorg=black screen


The drivers install fine. I put "nvidia" in place of "vesa" in the xorg.conf and start x I get a black screen.

Any ideas?

FX
 
Old 06-28-2004, 12:26 AM   #2
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
Did you try using "nv" instead of "nvidia". I believe "nv" is the stock nvidia driver and works better than "vesa". Otherwise you might check you screen section. Heres a snippet of mine.


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
Identifier "VESA Framebuffer"
Driver "nv"
#VideoRam 4096
# Insert Clocks lines here if appropriate
vendorname "NVidia"
boardname "GeForce3 (rev 1)"
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32
 
Old 06-28-2004, 07:34 AM   #3
EdwardA
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware 10 kernel 2.6.7 NVIDIA graphics
Posts: 15

Rep: Reputation: 0
What kernel are you running ? There are some NVIDIA driver issues with the 2.6.7 kernel.
 
Old 06-28-2004, 07:49 AM   #4
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Original Poster
Rep: Reputation: 15
The "vesa" drivers work fine. I thought that the "nv" drivers where just generic drivers and to actually get the 3D and frame rate capabilities of your card you had to install the nvidia drivers and then put in "nvidia" in place of either "vesa" or "nv".

Yea Im using the 2.6.7 kernel. Never seen anything about the nvidia issues and this kernel. Sorry.

FX
 
Old 06-28-2004, 07:54 AM   #5
EdwardA
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware 10 kernel 2.6.7 NVIDIA graphics
Posts: 15

Rep: Reputation: 0
The 2.6.7 kernel uses 4k stacks by default which break the nvidia drivers. In order to get the nvidia drivers to work with the new 2.6.7 kernel you have to uncheck use 4k stacks under the kernel hacking menu when compiling the kernel. I'm running slack 10 with the 2.6.7 kernel and nvidia drivers no problem. Try recompiling the kernel with the use 4k stacks under kernel hacking menu unchecked so the kernel wil use 8k stacks instead. That should fix your problem.

Let me know if that helps.
 
Old 06-28-2004, 09:42 AM   #6
wellmt
Member
 
Registered: Oct 2003
Location: Oxford, England
Distribution: Ubuntu
Posts: 70

Rep: Reputation: 15
This is exactly my problem too. I can get the NVIDIA drivers installed and running easily enough, but I get a total machine lockup when exiting KDE. I've got a custom 2.6.7 kernel,

Thanks for the pointer EdwardA, I'll try recompiling the kernel and post back with the results in a couple of days.
 
Old 06-28-2004, 09:56 AM   #7
EdwardA
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware 10 kernel 2.6.7 NVIDIA graphics
Posts: 15

Rep: Reputation: 0
No problem. Just hope that helps. Like i said it should b/c that was my problem now my system runs fine no lock ups or anything.
 
Old 06-28-2004, 10:22 AM   #8
c31c
Member
 
Registered: Mar 2004
Location: Planet Earth
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 15
thanks a lot!! that worked (at least for me)
I just disabled the 4k stacks thing, compiled, and all my problems were solved.
I had created this thread: http://www.linuxquestions.org/questi...hreadid=198384
Nobody answered...
but you guys solved both! cheers to EdwardA
 
Old 06-28-2004, 04:50 PM   #9
FXRS
Member
 
Registered: Jun 2003
Posts: 144

Original Poster
Rep: Reputation: 15
Unchecking 4 Stack and a recompile fixed it for me also. Thanks all those that replied.

FX
 
Old 06-29-2004, 07:09 PM   #10
wellmt
Member
 
Registered: Oct 2003
Location: Oxford, England
Distribution: Ubuntu
Posts: 70

Rep: Reputation: 15
Yes it worked for me also. Thanks a lot EdwardA
 
Old 06-30-2004, 09:47 PM   #11
rundarm
LQ Newbie
 
Registered: Jun 2004
Location: La Crosse, WI
Distribution: Red Hat Fedora Core 5 & 6
Posts: 22

Rep: Reputation: 15
Talking 4k Stacks now allowed

Get this Nvidia Update

http://www.nvidia.com/object/linux_d..._1.0-6106.html

It allows for 4k stacks.

Thanks for the great help guys...
Greg
 
Old 06-30-2004, 11:43 PM   #12
kmoffat
Member
 
Registered: Jul 2003
Location: near Seattle
Distribution: Debian/Ubuntu/Suse
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Anyone know if I can install over the older (5336?) driver? or do I need to uninstall it first?
 
Old 06-30-2004, 11:52 PM   #13
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
if you have a older driver installed try: nvidia-installer --update as root (of course, quit X first
That utility will connect to nvidia and install the latest drivers (that tool comes with the drivers so if you have old ones, you should have it)
 
Old 07-01-2004, 01:55 AM   #14
K1ll1nT1m3
LQ Newbie
 
Registered: Mar 2003
Location: Kansas City USA
Distribution: gentoo 2.6.7-r7
Posts: 18

Rep: Reputation: 0
rundarm: Thanks, that driver seems to load fine.

edit: I get the nvidia splash screen, but I have one problem. Its not letting me use "load glx" in XF86Config. Any Ideas why not?

edit2: I got it... I had to remove both the old nvidia-kernel and old the old nvidia-glx, then remove (nvidia-installer --unistall) the new one as well. After reinstalling the 6106, glx works fine now.

Last edited by K1ll1nT1m3; 07-01-2004 at 11:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia v...7676 on FC4 with black screen bakasaru Linux - Hardware 2 10-10-2005 12:28 AM
Black screen after installing nVidia driver GardarS Linux - Newbie 1 06-23-2005 05:28 PM
nvidia 7174 widescreen laptop 2.6.x xorg = "black screen" khermans Linux - Hardware 4 04-10-2005 08:28 AM
HP nx9105 With Latest Nvidia = Black Screen c3nturion Linux - Laptop and Netbook 6 02-03-2005 02:06 PM
Nvidia Black Screen (hsync out of range) JoshSmith41 Linux - Hardware 2 01-17-2004 03:38 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration