LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 04-04-2011, 08:25 PM   #1
bo01
LQ Newbie
 
Registered: Apr 2011
Posts: 16

Rep: Reputation: 0
Microphone noise


Ok, here I am again as I promised. the problem: when I try to make a recording in my laptop (integrated mic), I am able to hear myself (when I reproduce it afterwards) but with a lot of noise. I read a solution of going to alsamixer and disabling "L-R" in capture, but when I do that,I am not able to hear anything. Any suggestions? Thx!

Another thing (I don't know if that has to do with it) is that when I go to volume control->recording, every time I see a small red "x" in every mic (microphone, capture, internal mic) and if I enable them, close and reopen volume control the same "x"s appear.

Code:
lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
 
Old 04-04-2011, 08:39 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,917

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Try running alsactl store after changing your alsa settings.

I don't like using integrated microphones; I prefer a plugin headset for recording. Integrated mikes will pick all kinds of background noise and even feedback.
 
Old 04-05-2011, 07:24 AM   #3
bo01
LQ Newbie
 
Registered: Apr 2011
Posts: 16

Original Poster
Rep: Reputation: 0
The noise is not just a background, it is a very annoying one and it is not a hardware issue, because in windows it works perfect. I'll try the external mic as well, but I don't think that this is the cause of the problem.

Last edited by bo01; 04-05-2011 at 07:26 AM.
 
Old 04-05-2011, 10:00 AM   #4
bo01
LQ Newbie
 
Registered: Apr 2011
Posts: 16

Original Poster
Rep: Reputation: 0
I think I found a solution. This was to disable from alsamixer Dock Mic, Internal Mic and Mic and have enabled (but not 100%) Capture and Digital.

Thx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
virtual microphone: FILE ---> MICROPHONE ---> APPLICATION jamal_mohammadi Linux - Hardware 1 02-13-2011 03:10 PM
Virtualbox: weird noise from a webcam microphone Domine Slackware 0 11-17-2009 10:46 PM
too much noise spx2 Linux - Hardware 3 02-24-2008 11:21 AM
Speaker noise from X g00$e Linux - Hardware 2 10-07-2003 12:59 AM
Sound/Noise Ted8956 Linux - General 0 01-29-2002 08:04 PM


All times are GMT -5. The time now is 12:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration