LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 09-22-2008, 12:13 AM   #1
hans.zheng
LQ Newbie
 
Registered: Sep 2008
Posts: 2

Rep: Reputation: 0
Fedora 9 under IBM T400, No screens found


My laptop is IBM T400, which has two display adapters: ATI Mobility Radeon HD 3400 Series and Mobile Intel(R) 45 Express Chipset Family.

After installed Fedora 9, the system can just run under text mode. When i try to run startx, some error occurred.

The error messages are as follows:
Fatal server error
no screens found.

Please give me some help. Thank you.
 
Old 09-22-2008, 05:43 PM   #2
computer_freak_8
Member
 
Registered: Jul 2008
Location: Iowa
Distribution: Ubuntu 12.04 LTS 64-bit (Primary)
Posts: 80

Rep: Reputation: 15
Post Try this... (Note: I'm a newbie!)

Quote:
Originally Posted by hans.zheng View Post
The error messages are as follows:
Fatal server error
no screens found.
Ooh... I'm definitely no expert, but I'll try to help, at least until someone with more knowledge comes along.

I'm going to recommend that you first try running the following as root:
Code:
system-config-display
If your monitor is not listed, choose "Generic", or something along those lines. (I not sure if this is what it is called, but it should be similar.)

If your monitor is listed, choose it.

Post back to let us know what happened, good, bad, ugly, or evil.


Good luck,

computer_freak_8
 
Old 09-22-2008, 08:24 PM   #3
hans.zheng
LQ Newbie
 
Registered: Sep 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Hi~ computer_freak_8

Thank you for your help.

But the problem still remains. When i run system-config-display, it returns the following error messages:
Couldn't start X server on card 0
Couldn't start X server on card 1
Couldn't start X server with old config, trying with a fresh configuration
Couldn't start X server on card 0
Couldn't start X server on card 1
Error, failed to start X server
 
Old 09-22-2008, 09:24 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,664

Rep: Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682Reputation: 1682
for fedora 9 and your
Quote:
ATI Mobility Radeon HD
card you will need to downgrade the xorg/X11/X window to the xorg in fedora 8 .There ARE NO ATI drivers for this ( fedora9) xorg .
SEE:
http://forums.fedoraforum.org/forum/...d.php?t=155503
http://forums.fedoraforum.org/forum/...d.php?t=189227
 
Old 10-14-2008, 07:50 AM   #5
xbuffalo
LQ Newbie
 
Registered: Jun 2008
Posts: 6

Rep: Reputation: 0
try this...

your problem maybe caused by The X doesn't know which card should be used.

my T400 works by add BusID in the section of "Device" (xorg.conf)

BusID "PCI:1:0:0"

Quote:
Originally Posted by hans.zheng View Post
My laptop is IBM T400, which has two display adapters: ATI Mobility Radeon HD 3400 Series and Mobile Intel(R) 45 Express Chipset Family.

After installed Fedora 9, the system can just run under text mode. When i try to run startx, some error occurred.

The error messages are as follows:
Fatal server error
no screens found.

Please give me some help. Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No screens found :X 100sTressZeN Linux - Hardware 4 09-07-2007 11:34 AM
no screens found :( ApoIce Suse/Novell 4 03-06-2006 10:22 PM
No screens found spoody_goon Linux - Hardware 10 10-10-2004 04:36 PM
No Screens Found simsjr Slackware 1 05-29-2004 04:19 AM
no screens found junks Linux - Newbie 2 10-17-2003 03:05 PM


All times are GMT -5. The time now is 11:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration