LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
Search this Thread
Old 08-22-2004, 08:39 PM   #1
aewhite
LQ Newbie
 
Registered: Aug 2004
Location: AR USA
Distribution: Mandrake 10.0
Posts: 2

Rep: Reputation: 0
Angry Black Vertical Strip with NVIDIA on Toshiba 6100


In short, I did the update for the new 6111 NVIDIA driver. Install went great but now I have a vertical black strip on the right side of the screen, about 1/4 inch wide.

I have tried adding the options NVreg_SoftEDIDs=0 and NVreg_Mobile=2 in the modules.conf and modprobe.conf files. I have also treaked around with the XF86Config-4 file . I have even tried the xvidtune program, but it seems to ignore that dead zone.

I have worked, poked, and googled all I can for a day.
 
Old 08-24-2004, 02:29 AM   #2
atheist
Member
 
Registered: Sep 2003
Location: Iceland
Distribution: Debian Lenny - Kernel 2.6.22.8
Posts: 331

Rep: Reputation: 30
And this does not happen with older NVIDIA drivers? How about the vesa drivers?
 
Old 09-29-2004, 09:45 AM   #3
DragonKai
LQ Newbie
 
Registered: Nov 2003
Location: Indiana, United States
Distribution: Fedora Core, Red Hat, Mandrake, Linspire, Xandros
Posts: 8

Rep: Reputation: 0
NVIDIA Toshiba 6100

I am running Fedora Core 2 on my 6100 and am having the smae problem. I ahve noticed that if you change the driver back to "nv" in the X86 config file, it iwll display full screen, but will not be able to support GLX extensions. Once I changed it back to "nvidia" it would run the GLX extenstions, but got the vertical strip again.
 
Old 10-08-2004, 10:12 AM   #4
TiMiN8R
Member
 
Registered: Oct 2004
Location: Holland
Distribution: SuSE 9.1 Personal, SuSE 9.2, Mandrake 10 Off., Ubuntu 4.10 "Warty"
Posts: 34

Rep: Reputation: 15
same here. i have a toshiba 2100 with gf4 420. i've had the same problem with some custom nv drivers on windows. i set the res to 1024x768 but when i test i get 800x600 and that same black strip. haven't tried going back to the old drivers yet. i really want those gl extensions (doom3 and the bouncing cow screensaver ) is this just a toshiba issue or do all these mobile cards have the same problems?
 
Old 10-11-2004, 09:30 PM   #5
DragonKai
LQ Newbie
 
Registered: Nov 2003
Location: Indiana, United States
Distribution: Fedora Core, Red Hat, Mandrake, Linspire, Xandros
Posts: 8

Rep: Reputation: 0
Mine also is a GF4 420.
 
Old 10-20-2004, 02:30 AM   #6
TiMiN8R
Member
 
Registered: Oct 2004
Location: Holland
Distribution: SuSE 9.1 Personal, SuSE 9.2, Mandrake 10 Off., Ubuntu 4.10 "Warty"
Posts: 34

Rep: Reputation: 15
OK, I've found the answer in some other post. The problem is that the lcd panel is not reporting its dimensions correctly, saying it's not 1024 but 969. the solution is to add an option to the device section of the geforce in XF86Config: Option "IgnoreEDID". then everything will be back to normal.
 
Old 10-21-2004, 12:33 PM   #7
DragonKai
LQ Newbie
 
Registered: Nov 2003
Location: Indiana, United States
Distribution: Fedora Core, Red Hat, Mandrake, Linspire, Xandros
Posts: 8

Rep: Reputation: 0
Thumbs down

I tried that, and it didn't work. All I got was my screen streatched beyond the lower bounds of the diaplsy and still had the line on the right side. Almost like it set the vertical size to 1024 instead of the Horzontal size. Too bad I don't know how to manually edit the hardware so that I can define the deminsions for it in the driver.
 
Old 10-21-2004, 09:19 PM   #8
tobias_r33per
Member
 
Registered: Aug 2003
Location: Sydney
Distribution: Fedora Core 14, Gentoo 2011, Mandriva 2010 Powerpack, Ubuntu 10.10
Posts: 49

Rep: Reputation: 17
I might have the answer for you:

The same thing happened on my laptop as well, it is related to the frame buffer. Add this to you lilo.conf or menu.lst (grub) file:

kernel options line add this:

vga=791 or vga=792

One is 1024x768x16 and the other is 1024x768x32

This rectified the problem on my laptop anyways seee if that works

 
Old 10-25-2004, 02:13 PM   #9
DragonKai
LQ Newbie
 
Registered: Nov 2003
Location: Indiana, United States
Distribution: Fedora Core, Red Hat, Mandrake, Linspire, Xandros
Posts: 8

Rep: Reputation: 0
Thumbs down

Tried both 791 and 792 and neither of those worked with 16 or 24 bit color. I do not have the option for 32 bit.
It did alter the boot screen on grub to the smaller resolution, which was able to write out the the right edge of the display. But when I startx, I still get the black verticle strip.
 
Old 11-09-2004, 08:22 AM   #10
spawny75013
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Hi,

I'have the same crap on my toshiba SP6100, but this problem is due to nvidia driver because this problem is the same with new nvidia driver on WinXP.

I'm actually use a SuSE 9.1.

If someone has a answer to fix this, he's welcome :-)
 
Old 11-09-2004, 09:29 AM   #11
TiMiN8R
Member
 
Registered: Oct 2004
Location: Holland
Distribution: SuSE 9.1 Personal, SuSE 9.2, Mandrake 10 Off., Ubuntu 4.10 "Warty"
Posts: 34

Rep: Reputation: 15
yeah i still don't have a real fix either. the fix i posted earlier doesn't seem to work on all configurations and only in X. when i run an opengl game (doom 3, tuxracer) i still have the same problem. i had the same problem in xp when experimenting with modified .inf's to use the newer drivers that didn't support the gf4go, but after trying several driver versions i found one that worked. but that doesn't seem to be the only problem here because i've had this happen with many drivers and they all give the same s**t. these laptop gpus get crappy enough support in windblows as it is, in linux it's hell, but hey that's the fun of it

Last edited by TiMiN8R; 11-09-2004 at 09:35 AM.
 
Old 11-11-2004, 05:29 PM   #12
DragonKai
LQ Newbie
 
Registered: Nov 2003
Location: Indiana, United States
Distribution: Fedora Core, Red Hat, Mandrake, Linspire, Xandros
Posts: 8

Rep: Reputation: 0
Lightbulb Found a resolution

This is not a fix for a current install. However, I no longer have the vertical strip issue. I downloaded and installed a fresh install of Fedora Core 3 and I can now run my native 1600 resolution and with a full screen display and have the GLX support. I did not try a simple upgrade because I wanted a clean install, but the Fedora Core 3 ISO CDs did give me the option of an upgrade. Either way, my troubles with this problem are over. Good luck to everyone.

P.S not sure if it matters, but I did an "Everything" install of Core 3...a total of 6.7Gb install.
 
Old 11-12-2004, 03:43 AM   #13
juanrcuervo
LQ Newbie
 
Registered: Nov 2004
Location: Barranquilla
Distribution: fedora
Posts: 1

Rep: Reputation: 0
nvidia driver ignoring options

Hi fellas

I've been fighting with this issue for a very long time, without finding a definitive solution to it.
I had fedora core 1 and could solve the black line problem with the world-wide-recomended solution of adding "options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2" to the /etc/modules.conf or /etc/modprobe.conf files. But after that, I upgraded to fedora core 2 and the thing didnt work anymore.

So (after long nights of searching and testing ) I figured out that linux is not passing the mentioned options to the nvidia kernel driver.
If you put the line
Option "IgnoreEDID"
in your nvidiaś device section of your X11 configuration file, the driver recognize it, and you'll see it in your /var/log/Xorg.0.log. But the driver wont use this option if you just leave it in the /etc/modules.conf file...so it seems to be a lack of integration between the driver and linux.

Now, with the option in my X configuration file, the driver "finds" the correct screen size, but I have not been able to set the Hor and Vert screen frequency, nor find any appropiate "modeline" options for my 1600x1200 or 1600x1050 resolutions., so my scrren turns all white when i run startx

can anyone help me with this?

Last edited by juanrcuervo; 11-12-2004 at 03:47 AM.
 
Old 07-16-2011, 10:22 AM   #14
steeltoken420@yahoo.com
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by DragonKai View Post
This is not a fix for a current install. However, I no longer have the vertical strip issue. I downloaded and installed a fresh install of Fedora Core 3 and I can now run my native 1600 resolution and with a full screen display and have the GLX support. I did not try a simple upgrade because I wanted a clean install, but the Fedora Core 3 ISO CDs did give me the option of an upgrade. Either way, my troubles with this problem are over. Good luck to everyone.

P.S not sure if it matters, but I did an "Everything" install of Core 3...a total of 6.7Gb install.
enable the second display ! VOILA ! i worked !!! welcome..

---------- Post added 07-16-11 at 10:22 AM ----------

Quote:
Originally Posted by aewhite View Post
In short, I did the update for the new 6111 NVIDIA driver. Install went great but now I have a vertical black strip on the right side of the screen, about 1/4 inch wide.

I have tried adding the options NVreg_SoftEDIDs=0 and NVreg_Mobile=2 in the modules.conf and modprobe.conf files. I have also treaked around with the XF86Config-4 file . I have even tried the xvidtune program, but it seems to ignore that dead zone.

I have worked, poked, and googled all I can for a day.
enable the second display ! VOILA ! i worked !!! welcome.
 
Old 07-16-2011, 10:24 AM   #15
steeltoken420@yahoo.com
LQ Newbie
 
Registered: Jul 2011
Posts: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by TiMiN8R View Post
same here. i have a toshiba 2100 with gf4 420. i've had the same problem with some custom nv drivers on windows. i set the res to 1024x768 but when i test i get 800x600 and that same black strip. haven't tried going back to the old drivers yet. i really want those gl extensions (doom3 and the bouncing cow screensaver ) is this just a toshiba issue or do all these mobile cards have the same problems?
enable the second display ! VOILA ! i worked !!! welcome. I saw my mouse go UNDER the black strip so I thought..HUM, If I turn on the EXTENDED display...YEAH BABY !!! SOLVED!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X problems / Toshiba 6100/ FC4 Mjollnir Linux - Laptop and Netbook 7 07-22-2006 01:03 AM
Toshiba Satellite Pro 6100 and 10.2 slackb0t Slackware 3 12-02-2005 03:23 PM
Toshiba 5100 & Nvidia - black bar on right side of my screen? rnmartinez Linux - Laptop and Netbook 0 06-10-2004 08:26 PM
About NVIDIA GeForce4 420 Go installing on TOSHIBA 6100 laptop AnthraxCN Linux - Laptop and Netbook 1 05-16-2004 07:42 AM
Slack 9 and Toshiba Satellite Pro 6100 IndigoParadox Linux - Laptop and Netbook 3 08-25-2003 08:59 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration