LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices

Reply
 
Search this Thread
Old 01-12-2007, 01:02 AM   #1
outstream
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 11
Posts: 15

Rep: Reputation: 0
what am i doing wrong, in going from 2.4.33 to 2.6.17


Hi All,

I have compiled kernel 2.6.17 from sources, on a clean install of Slackware 11.0.

The problem is that my system does not boots up from new kernel. When i try to boot it, it just gives me a blank screen. Nothing else.

Here are the steps I followed for kernel recompile.

cp /boot/vmlinuz /boot/vmlinuzOLD
cp /boot/config /boot/configOLD


1. download kernel source and copy it to /usr/src

2 . cd /usr/src

3 . tar -xvzf linux-2.6.17.tar.gz

4. rm /usr/src/linux

5. ln -s linux-2.6.17 /usr/src/linux

6. cd /usr/src/linux

7. make menuconfig

8. make dep

9. make clean

10. make modules

11. make modules_install

12. make bzImage

13. make install

thats it, now when i reboot, the machine doesnt boots up from new kernel. Therefore, i started up the machine from installation cd1 and edited lilo.conf to make an entry for old kernel so that i can get in the system via old kernel.

Here is how my lilo.conf looks like :

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
 message = /boot/boot_message.txt
prompt
timeout = 1200
#Override dangerous defaults that rewrite the partition table:

change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends

# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda7
  label = Linux
  read-only
# Linux bootable partition config ends
# Linux old begins
 image = /boot/vmlinuzOLD
 root = /dev/hda7
 label = Old
 read-only
#Linux old ends
I searched onine about the problem, and I found out somebody saying that they fixed up this problem by setting vga = 0 in lilo.conf. I also tried doing that but it didnt solve my problem so i set it back to vga = 773.

Can somebody point out what I am doing wrong here?
 
Old 01-12-2007, 02:51 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Does the system not boot at all (in which case there should be some sort of error message) or does it boot, but you don't see anything on the screen?Did you compile the framebuffer stuff into the kernel? If you did not, then all you will have is a blank screen whilst everything else works fine. Also, there is no need to "make dep" on 2.6 kernels because this is automatically done for you.
 
Old 01-12-2007, 03:47 AM   #3
outstream
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 11
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by reddazz
Does the system not boot at all (in which case there should be some sort of error message) or does it boot, but you don't see anything on the screen?Did you compile the framebuffer stuff into the kernel? If you did not, then all you will have is a blank screen whilst everything else works fine. Also, there is no need to "make dep" on 2.6 kernels because this is automatically done for you.
1. I think it does boot, but I dont see anything on the screen.

2. I dont know about framebuffer stuff during kernel recompile. But I know I didnt change anything in it, i.e I accepted the default values in every area from 'code maturity level' to 'file systems'

3. Yes, you are right about no 'make dep' during 2.6 kernel compilation. I didnt know that, but it told me about it when I gave that command.
 
Old 01-12-2007, 04:05 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Well if the system boots but you don't see anything then it means you did not enable the framebuffer stuff. Framebuffer support is under Device Drivers -> Graphics Support. While you are there, you may want to enable the vesa stuff as well.
 
Old 01-12-2007, 04:39 AM   #5
outstream
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 11
Posts: 15

Original Poster
Rep: Reputation: 0
Hi again,

are you sure about enabling VESA stuff?. i`m sorry i`m not at doubt on your tallents, but I searched google after reading your post about enabling framebuffer and i came across this

http://easymamecab.mameworld.net/html/fbhowto.htm

The guy says to enable frame buffer but disable vga,vesa stuff.

I just recompiled it again, enabling frame buffer and disabling vga,vesa stuff. But the kernel didnt load the graphics again, it doesnt shows ANYTHING.

I guess i`ll recompile it once again right now, and enable framebuffer as well as vesa,vga stuff in it.

ahh..this will be my 3rd recompile in last 5 hours...lets see what happens
 
Old 01-12-2007, 04:53 AM   #6
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
On most distros, the vesa stuff is compiled into the kernel by default or enabled as a module. Its a good backup in case your graphics driver plays up for some reason and also it enables you to have fancy splash screens. Anyway, I have pointed you in the right direction as to where the problem is, so I hope everything works out for you.
 
Old 01-12-2007, 05:11 AM   #7
outstream
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 11
Posts: 15

Original Poster
Rep: Reputation: 0
Alright, reddazz, dude we nailed it down. you and me baby haha.

I just finished recompiling it, enabled framebuffer, vga,vesa and also enabled intel 810/45/865 (experimental).

Now, the kernel loads, I can see all those messages while its loading, but suddenly these lines appear

Code:
VFS: cannot open root device "307" or unknown-block93,7)

Please append a correct "root=" boot option

Kernel panic - not syncing: VFS :unable to mount root fs on unknown-block(3,7)
what do i do now? how do i make it not panic
 
Old 01-12-2007, 06:10 AM   #8
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Did you enter the correct details for your root partition in the bootloader entry you made for the new kernel? One other thing to do, is make sure you compiled drivers for the filesystem you are using as / into the kernel.
 
Old 01-12-2007, 06:44 AM   #9
outstream
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 11
Posts: 15

Original Poster
Rep: Reputation: 0
Hi,

Yes I did make sure there is a valid entry in my boot loader. I didnt edit lilo.conf after kernel recompile. Instead, i gave command of 'make install' after 'make bzImage'. It told me that it had added new entry in the boot loader. So new entry is there. To clear any doubt, here is what my lilo.conf looks like

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda7
  label = Linux
  read-only
# Linux bootable partition config ends
# Linux old begins
 image = /boot/vmlinuzOLD
 root = /dev/hda7
 label = Old
 read-only
#Linux old ends
clearly, the image is set to /boot/vmlinuz and drive is set to /dev/hda7.


Now, comming to the issue of compiling drivers of file system in kernel.

My all linux drives are ext2. During kernel recompile for 4th time, I made sure that all the things related to ext2 are compiled in the kernel. I am very sure that all settings for ext2, under filesystems option menu in kernel configuration, are set as "Y".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my time is wrong and calender is also wrong Paxmaster Linux - General 6 12-16-2004 12:46 AM
what's wrong ej25 Programming 15 11-24-2004 02:04 AM
What am I doing wrong? orly Linux - Software 7 08-20-2004 04:01 PM
what 's it wrong changlezhang Programming 3 09-01-2003 11:08 AM
What did I do wrong? yakko Linux - Newbie 7 05-02-2002 07:09 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration