LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 04-22-2007, 04:16 AM   #1
Zenx
LQ Newbie
 
Registered: Apr 2007
Location: Finland
Distribution: Gentoo Linux
Posts: 4

Rep: Reputation: 0
Kernel panic - not syncing:VFS: Unable to mount root fs on unknown-block (1,0)


Hello everyone!
I'm running Gentoo Linux, and tried to compile the kernel from r7 to r6. Now when I boot into the newer kernel it throws the kernel panic message.

No filesystem could mount root, tried:reiserfs ext3 ext2 msdos fuseblk jfs vfat iso9660 ntfs. Kernel panic - not syncing:VFS:Unable to mount root fs on unknown-block (1,0)

And here is my grub menu.lst:

default 0
timeout 30
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
title=Gentoo Linux r6
root (hd0,2)
kernel /boot/vmlinuz-2.6.20-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192$
title=Gentoo Linux r7
root (hd0,2)
kernel /boot/kernel-genkernel-x86-2.6.17-gentoo-r7 root=/dev/ram0 init=/linuxrc$
initrd /boot/initramfs-genkernel-x86-2.6.17-gentoo-r7

title=Win XP
rootnoverify (hd0,0)
makeactive
chainloader +1

I've been trying to get this to work for a day now and I'm all out of ideas. Thanks in advance!
 
Old 04-22-2007, 08:25 AM   #2
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
IS your /boot on a seperate partition ??
 
Old 04-22-2007, 08:47 AM   #3
Zenx
LQ Newbie
 
Registered: Apr 2007
Location: Finland
Distribution: Gentoo Linux
Posts: 4

Original Poster
Rep: Reputation: 0
No, I have currently one S-ATA disk, and it is partitioned like this: hd(0,0)=Win XP, hd (0,1) swap, hd (0,2) root, hd(0,3) /home. My root and /home are both in ext3.
 
Old 04-22-2007, 08:57 AM   #4
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
Try changing the root=/dev/ram0 to /dev/sda3

And also if that dont work get rid of all those options after the kernel make it will make it easier to debug
 
Old 04-22-2007, 09:41 AM   #5
Zenx
LQ Newbie
 
Registered: Apr 2007
Location: Finland
Distribution: Gentoo Linux
Posts: 4

Original Poster
Rep: Reputation: 0
After I changed the root=, it threw another, different error;
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.

Well, gotta try to remove the extra boot option thingies.

Edit: Removed them all, and no change happened. The error stayed as above ^

Last edited by Zenx; 04-22-2007 at 09:47 AM.
 
Old 04-22-2007, 10:53 AM   #6
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
ok sounds to me that you havent enabled the correct options for your file system in your kerenl conf. Hav a look.
 
Old 04-22-2007, 11:32 AM   #7
Zenx
LQ Newbie
 
Registered: Apr 2007
Location: Finland
Distribution: Gentoo Linux
Posts: 4

Original Poster
Rep: Reputation: 0
Allright, I tried enabling every SATA-controller in the kernel, but it still doesn't work! It still whines about that it can't mount root fs, although i've checked every ext2 and ext3 box in the filesystem screen.
 
Old 05-05-2007, 10:45 AM   #8
Adaptive
LQ Newbie
 
Registered: Nov 2003
Distribution: RedHat 9
Posts: 4

Rep: Reputation: 0
Hi all. I am getting the same error when updating from 2.6.18-r6 to 2.6.20-r7 (gentoo sources). I checked my .config for the new sources and my file systems are already compiled into the kermel. help please.
 
Old 05-05-2007, 02:50 PM   #9
kernel_geek
Member
 
Registered: Jan 2007
Location: UK
Distribution: Ubuntu/Arch
Posts: 161

Rep: Reputation: 30
it must be grub issues then. Are you specifying root=/dev/sda7 or similar in kernel opts line in grub.conf ??
 
Old 05-06-2007, 12:50 PM   #10
Adaptive
LQ Newbie
 
Registered: Nov 2003
Distribution: RedHat 9
Posts: 4

Rep: Reputation: 0
I think I found the problem. The new kernel sources have support for SATA in a new location from the old sources. I went and checked NVIDIA SATA (for my Motherboard) and recompiled. Everything works great now.
 
Old 05-29-2009, 04:57 PM   #11
ehsanmx
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
Talking Tnx It works fine

Quote:
Originally Posted by Adaptive View Post
I think I found the problem. The new kernel sources have support for SATA in a new location from the old sources. I went and checked NVIDIA SATA (for my Motherboard) and recompiled. Everything works great now.

Yes exactly NVIDIA SATA SUPPORT .
 
Old 06-03-2009, 03:45 PM   #12
drew2x
LQ Newbie
 
Registered: Apr 2005
Location: Columbus
Distribution: Gentoo, LFS, Ubuntu
Posts: 2

Rep: Reputation: 0
Thank you! I was having the same issue and about to put my head through the wall :]
 
Old 08-04-2010, 06:33 AM   #13
kharlamov
LQ Newbie
 
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
Talking hardware malfunction

Hi. I had the same problem and finally figured out that it was a bad RAM item. After replacing it everything went good.
You need to run Memtest86 at start up and find if it is the issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic - not syncing : VFS: unable to mount root FS on unknown-block Dankles Slackware 23 01-28-2011 04:01 AM
kernel panic - not syncing : VFS: unable to mount root FS on unknown-block kaplis Linux - Software 1 09-19-2006 02:44 AM
kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(3,2) o2bfishn Slackware 5 04-28-2006 04:51 PM
Kernel Panic!!! -Not Syncing VFS:Unable to mount root FS on unknown - block (0,0) scarabs Linux - Software 4 04-16-2006 05:16 PM
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2) Volgin Linux - Software 1 12-11-2005 08:46 PM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration