LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Kernel (http://www.linuxquestions.org/questions/linux-kernel-70/)
-   -   Kernel panic - not syncing:VFS: Unable to mount root fs on unknown-block (1,0) (http://www.linuxquestions.org/questions/linux-kernel-70/kernel-panic-not-syncing-vfs-unable-to-mount-root-fs-on-unknown-block-1-0-a-547998/)

Zenx 04-22-2007 03:16 AM

Kernel panic - not syncing:VFS: Unable to mount root fs on unknown-block (1,0)
 
Hello everyone!
I'm running Gentoo Linux, and tried to compile the kernel from r7 to r6. Now when I boot into the newer kernel it throws the kernel panic message.

No filesystem could mount root, tried:reiserfs ext3 ext2 msdos fuseblk jfs vfat iso9660 ntfs. Kernel panic - not syncing:VFS:Unable to mount root fs on unknown-block (1,0)

And here is my grub menu.lst:

default 0
timeout 30
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
title=Gentoo Linux r6
root (hd0,2)
kernel /boot/vmlinuz-2.6.20-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192$
title=Gentoo Linux r7
root (hd0,2)
kernel /boot/kernel-genkernel-x86-2.6.17-gentoo-r7 root=/dev/ram0 init=/linuxrc$
initrd /boot/initramfs-genkernel-x86-2.6.17-gentoo-r7

title=Win XP
rootnoverify (hd0,0)
makeactive
chainloader +1

I've been trying to get this to work for a day now and I'm all out of ideas. Thanks in advance! :)

kernel_geek 04-22-2007 07:25 AM

IS your /boot on a seperate partition ??

Zenx 04-22-2007 07:47 AM

No, I have currently one S-ATA disk, and it is partitioned like this: hd(0,0)=Win XP, hd (0,1) swap, hd (0,2) root, hd(0,3) /home. My root and /home are both in ext3.

kernel_geek 04-22-2007 07:57 AM

Try changing the root=/dev/ram0 to /dev/sda3

And also if that dont work get rid of all those options after the kernel make it will make it easier to debug

Zenx 04-22-2007 08:41 AM

After I changed the root=, it threw another, different error;
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.

Well, gotta try to remove the extra boot option thingies.

Edit: Removed them all, and no change happened. The error stayed as above ^

kernel_geek 04-22-2007 09:53 AM

ok sounds to me that you havent enabled the correct options for your file system in your kerenl conf. Hav a look.

Zenx 04-22-2007 10:32 AM

Allright, I tried enabling every SATA-controller in the kernel, but it still doesn't work! It still whines about that it can't mount root fs, although i've checked every ext2 and ext3 box in the filesystem screen.

Adaptive 05-05-2007 09:45 AM

Hi all. I am getting the same error when updating from 2.6.18-r6 to 2.6.20-r7 (gentoo sources). I checked my .config for the new sources and my file systems are already compiled into the kermel. help please.

kernel_geek 05-05-2007 01:50 PM

it must be grub issues then. Are you specifying root=/dev/sda7 or similar in kernel opts line in grub.conf ??

Adaptive 05-06-2007 11:50 AM

I think I found the problem. The new kernel sources have support for SATA in a new location from the old sources. I went and checked NVIDIA SATA (for my Motherboard) and recompiled. Everything works great now.

ehsanmx 05-29-2009 03:57 PM

Tnx It works fine
 
Quote:

Originally Posted by Adaptive (Post 2738437)
I think I found the problem. The new kernel sources have support for SATA in a new location from the old sources. I went and checked NVIDIA SATA (for my Motherboard) and recompiled. Everything works great now.


Yes exactly NVIDIA SATA SUPPORT .

drew2x 06-03-2009 02:45 PM

Thank you! I was having the same issue and about to put my head through the wall :]

kharlamov 08-04-2010 05:33 AM

hardware malfunction
 
Hi. I had the same problem and finally figured out that it was a bad RAM item. After replacing it everything went good.
You need to run Memtest86 at start up and find if it is the issue.


All times are GMT -5. The time now is 11:17 AM.