LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-25-2006, 02:20 PM   #1
jojolx
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
suse 10.1 DHCP client via cable modem does not give a IP address..


Hi,

I have suse 10.1 x86-64 installed on my ADM 3000+ PC, I'd like to use Internet via cable modem, I configured onboard network card on my MB using YaST this way (IP+DNS via DHCP):

configuration NIC via YaST:
root: YaST/Network Devices/Network card:
Network Setup Method: User Controlled with NetworkManager ->Next
Micro-Star International MCP51 Ethernet Controller/Edit
General: Firewall zone=Firewall Disabled
Device Activation=On cable Connection
Address: Automatic Address Setup (via DHCP)
Hostaname and Domain Name (Global)
Hostname=js Domain Name=home
x Change Hostname via DHCP
x Update Name Servers and Search List via DHCP ->Next

but it does not work properly... a part of log following:

Aug 25 19:28:50 js ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
Aug 25 19:28:50 js ifplugd(eth0)[19233]: client: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
Aug 25 19:28:50 js ifup: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 is controlled by ifplugd
Aug 25 19:28:50 js ifup-dhcp: Starting DHCP Client Daemon on eth0...
Aug 25 19:28:50 js ifup-dhcp: .
Aug 25 19:28:51 js ifup-dhcp: .
Aug 25 19:28:52 js ifup-dhcp: .
Aug 25 19:28:53 js ifup-dhcp: .
Aug 25 19:28:54 js ifup-dhcp: .
Aug 25 19:28:55 js ifup-dhcp: no IP address yet... backgrounding.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: client: Starting DHCP Client Daemon on eth0... . . . . . no IP address yet... backgrounding.
Aug 25 19:28:55 js kernel: eth0: link down.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: Program execution failed, return value is 12.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: Link beat lost.
Aug 25 19:28:56 js kernel: eth0: link up.
Aug 25 19:28:57 js kernel: eth0: link down.
Aug 25 19:28:58 js kernel: eth0: link up.


Can anybody advice me how to solve this problem?

Thanks in advance

J.
 
Old 08-26-2006, 08:17 AM   #2
noranthon
Member
 
Registered: Apr 2006
Location: Australia
Distribution: PCLinuxOS with Xfce
Posts: 301

Rep: Reputation: 30
I don't know what is causing your problem. I used DHCP quite happily on Mandriva but the system seems to work even better with static protocol. I gather DHCP is used because less information is required.

In a related context, I was advised by another forum member to use the following commands:
Quote:
[3] Bring down your eth0 like this (as root):
ifdown eth0
[4] Bring up your eth0 using DHCP like this (as root):
dhclient eth0
 
Old 08-26-2006, 08:57 AM   #3
jojolx
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Thank for your advice, I tried it:

oco@js:~> su -
Password:
js:~ # ifdown eth0
eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
eth0 configuration: eth-id-00:13:d3:cc:6a:8c
js:~ # dhclient eth0
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:13:d3:cc:6a:8c
Sending on LPF/eth0/00:13:d3:cc:6a:8c
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
js:~ #
js:~ #

...but no success...
 
Old 08-27-2006, 04:01 AM   #4
noranthon
Member
 
Registered: Apr 2006
Location: Australia
Distribution: PCLinuxOS with Xfce
Posts: 301

Rep: Reputation: 30
I've had that response too. And Google got 460 hits for the phrase "No working leases in persistent database - sleeping" with "dhcp" including several threads in this forum.

At that time I was able to get an internet connection using static protocol. This post mentions something similar.

On the last occasion I had to reset my modem to the factory defaults before I could use dhcp again. Incidentally, I have the same network controller as you have. Did you install the nvnet driver?

Last edited by noranthon; 08-27-2006 at 04:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no ipv4 address for dhcp client alz3k3 Linux - Networking 0 12-16-2005 10:12 AM
dhcp client requests a new address every time EdoardoC Linux - Networking 6 02-02-2005 06:02 PM
ADSL modem & SUSE 9.0 DHCP client Embedded Linux - Networking 1 01-24-2004 06:48 AM
cannot get dhcp address from cable modem, using mandrake 9.0 nanosyche021 Linux - Networking 2 12-06-2003 01:27 AM
dhcp3-client won't negotiate with windows dhcp server through cable modem frankster2000 Linux - Networking 0 06-25-2002 10:04 AM


All times are GMT -5. The time now is 12:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration