LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-28-2003, 08:50 AM   #1
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
Scratching sound with snd-via82xx


I am using an onboard soundcard on a K7VM2 motherboard from ASrock. I get sound allright but it is mixed with a periodic scratching sound which is quite frankly most annoying!

Default driver is snd-via82xx. I have tried the alternative driver via82cxxx or something but that just made it worse. I am sure this is a driver problem since the sound is fine in windows.

On the cd from ASrock (www.asrock.com) there are actually a bunch of linux drivers but these are for older linux distros -- and are compiled with gcc v.2.xx which shouldn't work with newer kernels compiled with gcc 3.xx . The drivers are called 74audio.distro eg. for Mandrake 8.2 it is 74audio.mdk82, unfortuneatly they havn't attached a driver source...

Does any one know anything about this??? Please help -- it is a brand new computer.

greetings, kamstrup
 
Old 08-29-2003, 03:20 AM   #2
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Original Poster
Rep: Reputation: 15
ASrock mailed me this link: www.viaarena.com/?PageID=2
There's a bunch of linux drivers here but many of them are outdated, I'll dig a bit into this... I'll be back!

kamstrup (talking to himself while starring bewildered into the screen)
 
Old 10-20-2003, 10:54 AM   #3
Kear_Amon
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Hi,
I had the same problem and solved it by adding the following line in my /etc/modules.conf:

options snd-via82xx dxs_support=2



kear_amon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
snd-via82xx no sound but works in other distros WireLine Fedora 8 09-10-2005 03:36 AM
Help with snd-via82xx in ubuntu Da_Robber Linux - Newbie 7 08-18-2005 07:49 AM
Sound Conflict: snd-via82xx & snd-emu10k1 Electronkz Linux - Hardware 6 03-29-2004 11:58 AM
No sound on MDK9.1 with snd-via82xx chip tryynanen Linux - Hardware 5 01-13-2004 02:03 AM
Need Help with snd-via82xx jswmcse Linux - Hardware 2 11-11-2003 12:13 PM


All times are GMT -5. The time now is 03:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration