LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 03-04-2005, 10:29 AM   #1
WireLine
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Rep: Reputation: 0
snd-via82xx no sound but works in other distros


Details first:
Motherboard: DFI K8M800-MLVF (mini-atx with on board sound, video, lan)
Hauppauge WinTV Go PCI card
Fedora Core 3

I am trying to get the sound card to work. It works fine in debian, knoppix, suse 9.1 but I don't like those distros as much as I like Fedoa

I have tried the most obvious things like making sure that the volume was not muted and that it was turned up. Also I have ran the sound card detection tool it comes up the the snd-via82xx module. I have updated my alsa drivers to the latest from atrpms.net (I am using apt). I don't see any error messages from dmesg or anything like that.

What now? How do I continue to troubleshoot this? Or better yet has somebody gotten this to work?
 
Old 03-05-2005, 07:19 PM   #2
Sakur
LQ Newbie
 
Registered: Mar 2005
Location: China
Distribution: FC3
Posts: 25

Rep: Reputation: 15
"alsamixer" to open channels , it is defaully closed in FC3
 
Old 03-05-2005, 08:17 PM   #3
WireLine
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
I should have been more specific, I did use alsamixer to check for muted channels something is wrong with the driver in general.

I also used Fedora volume control panel and it did not help either.

Any ideas whats next? If I had an open PCI slot I would slip in a different sound card but they are all full at the moment.
 
Old 03-05-2005, 08:23 PM   #4
purwant
LQ Newbie
 
Registered: Mar 2005
Location: india
Distribution: redhat / fedora and mandrake
Posts: 2

Rep: Reputation: 0
hi go to the termminal and type kmix then increase te levels of pcm and headphone that's it
alternatively try alsamix if you have installed it

also if this work tell me how to post a question.

-nikhil
 
Old 03-05-2005, 08:29 PM   #5
Sakur
LQ Newbie
 
Registered: Mar 2005
Location: China
Distribution: FC3
Posts: 25

Rep: Reputation: 15
seems really strange, i also use snd-via82xxx,which works fine in my FC3,could u give me the some useful info to let me what condition u r in , like the result of " dmesg " 'lspci" " lsmod",
 
Old 03-05-2005, 08:32 PM   #6
WireLine
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
no kmix, using gnome.

To post a quest go to the correct forum and click new topic at the top.

Every single option in alsamix is unmuted and maxed out. I have also tried many diffrent combos to get it to work.
 
Old 03-06-2005, 10:37 AM   #7
WireLine
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Well I got it working kind of now.

Here is what I did. I grabbed the Alsa Kernel module and the Alsa-driver rpm. Installed those. I turned of my sound card in the bios somewhere in there let Fedora boot up and removed the sound card config. This part was not nessarry but I was furstrated. Then I rebooted and re-enabled it let kudzu dectect and install it. Used alsa mixer which now had about a hundred diffrent volume levels and tweaked them tell I head sound.

Now I just have to figure out why my line in is all distorted and why it does not save my volume levels. Thanks for all your help.
 
Old 09-08-2005, 09:49 PM   #8
wfcloherty
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
reply: snd-via82xx no sound but works in other distros

I had the same problem with the Ubuntu 5.04 distro on the same hardware.

The fix for Ubuntu was to go into ALSAMIXER and turn off (mute) the IEC958 Capture Monitor [off] channel. I also had to restore the sound system back to the original setup as installed, I had really messed it up while trying to get it to work.


William
 
Old 09-10-2005, 03:36 AM   #9
whencat
Member
 
Registered: Aug 2003
Location: Pondicherry,India
Distribution: Fedora Core 3, RedHat 9.0, SUSE 8.1 Personal,
Posts: 49

Rep: Reputation: 15
To save the mixer settings........
1. Set the desired volume in the desired channels in alsamixer

2. type
#alsactl store
[or give the full path to alsactl]

This will store the current settings in /etc/asound.state.
You can also edit the above file directly if you are comfortable with it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with snd-via82xx in ubuntu Da_Robber Linux - Newbie 7 08-18-2005 07:49 AM
Sound Conflict: snd-via82xx & snd-emu10k1 Electronkz Linux - Hardware 6 03-29-2004 11:58 AM
No sound on MDK9.1 with snd-via82xx chip tryynanen Linux - Hardware 5 01-13-2004 02:03 AM
Need Help with snd-via82xx jswmcse Linux - Hardware 2 11-11-2003 12:13 PM
Scratching sound with snd-via82xx kamstrup Linux - Hardware 2 10-20-2003 10:54 AM


All times are GMT -5. The time now is 03:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration