LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-25-2005, 11:31 AM   #1
whysyn
Member
 
Registered: Jun 2003
Location: Cleveburg, OH
Distribution: mostly Fedora
Posts: 154

Rep: Reputation: 30
keyboard issue - have to double press some keys


Hello,

I just reinstalled FC4 on my laptop, and obviously something is different this time.

For certain keys - double quote, single quote and tilde ( ¨ ´ ~ ) at least I have to double press the key to make it appear on screen. If I don double press it, it puts the keyboard into some mode for typing special characters.

I don even know where to begin to look to change this option. In KDE Control Center, under ¨Regional & Accessability¨ -> ¨Keyboard Layout¨ I have selected ¨Laptop/Notebook Dell Inspiron 8xxx¨ and activated the (us) keymap.

Let me know what other information I might need to post, or if I should try changing anything.

Thank you!
 
Old 10-25-2005, 05:27 PM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
You could try running 'xev' in a terminal window to see what X is doing with the keystrokes. Put the focus in the xev window and type. Here is what I get for double-quote (along with the shift-key). Standard US keyboard.

KeyPress event, serial 28, synthetic NO, window 0x3200001,
root 0x3b, subw 0x0, time 88060397, (148,6), root150,32),
state 0x0, keycode 62 (keysym 0xffe2, Shift_R), same_screen YES,
XLookupString gives 0 bytes: ""

KeyPress event, serial 28, synthetic NO, window 0x3200001,
root 0x3b, subw 0x0, time 88063646, (148,6), root150,32),
state 0x1, keycode 48 (keysym 0x22, quotedbl), same_screen YES,
XLookupString gives 1 bytes: """

You can change the mapping from keycodes to keysyms using 'xmodmap'. Check the man page. Strange problem tho'.
 
Old 10-26-2005, 12:28 AM   #3
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
What keyboard driver and options is X using on your box? Could you post your "InputDevice" section from xorg.conf or XFree86.conf ?
 
Old 10-26-2005, 12:32 AM   #4
whysyn
Member
 
Registered: Jun 2003
Location: Cleveburg, OH
Distribution: mostly Fedora
Posts: 154

Original Poster
Rep: Reputation: 30
Here is xev output from holding shift, tapping the quote key, and releasing shift. I don't particularly understand what it all means, but I also found something else interesting.

If I go into control center and uncheck the "Enable keyboard layouts" box, special keys start to work fine, but then my media buttons do nothing (Mute, Play, Stop, etc...)

Anyway, here is the output. I think it is odd that three actions (hold, tap, release) actually generated four events... but again, I am clueless as to what this actually means.
Code:
KeyPress event, serial 31, synthetic NO, window 0x3400001,
    root 0x46, subw 0x0, time 16853741, (173,-9), root:(850,12),
    state 0x10, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x3400001,
    root 0x46, subw 0x0, time 16855749, (173,-9), root:(850,12),
    state 0x11, keycode 48 (keysym 0xfe57, dead_diaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c2 a8) "�"
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: True

KeyRelease event, serial 31, synthetic NO, window 0x3400001,
    root 0x46, subw 0x0, time 16855809, (173,-9), root:(850,12),
    state 0x11, keycode 48 (keysym 0xfe57, dead_diaeresis), same_screen YES,
    XLookupString gives 2 bytes: (c2 a8) "�"

KeyRelease event, serial 31, synthetic NO, window 0x3400001,
    root 0x46, subw 0x0, time 16857133, (173,-9), root:(850,12),
    state 0x11, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes:

Last edited by whysyn; 10-26-2005 at 12:35 AM.
 
Old 10-26-2005, 12:44 AM   #5
whysyn
Member
 
Registered: Jun 2003
Location: Cleveburg, OH
Distribution: mostly Fedora
Posts: 154

Original Poster
Rep: Reputation: 30
hereś the keyboard section from my xorg.conf:

Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
I can put up a link to the whole thing and any other conf files if needed...

Thanks guys!
 
Old 10-26-2005, 01:19 AM   #6
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
Do you have the same problem when logging in to the console, or is it exclusive to X? Does it matter which terminal program you use? Is "deadkeys" enabled?
 
Old 10-26-2005, 02:50 AM   #7
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
X-windows inserts an extra mapping keycodes (physical keys) to keysyms (symbolic keys) which is easily modified. Executing the command

xmodmap -e 'keycode 48 = apostrophe quotedbl'

should make the quote/doublequote key work correctly.

You can see current settings using 'xmodmap -pke'. The whole set-up is quite complex. Have a look in /etc/X11/xkb for all the config files for different languages etc. You can use xev to find out the keycodes. Xmodmap can be run in a startup script.

Better if you find what went wrong in your keyboard configuration, but you can always do this as a last resort.
 
Old 10-27-2005, 03:43 PM   #8
whysyn
Member
 
Registered: Jun 2003
Location: Cleveburg, OH
Distribution: mostly Fedora
Posts: 154

Original Poster
Rep: Reputation: 30
OK, back to square one.

The keymapping issue was only in X, not on traditional terminal.

I disabled Keyboard Layout in the KDE Control Center, and everything works properly...

except for the "media" buttons. This is a new Dell Inspiron 6000, and it has the following buttons along the edge: Mute, Vulume Up, Volume Down, Play/Pause, Next, Previous, Stop. Any hints on setting these up to be recognized by X so I can make them shortcuts in mplayer, KMix, etc...?
 
Old 10-27-2005, 05:14 PM   #9
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
http://www.cweiske.de/howto/xmodmap/allinone.html

http://gentoo-wiki.com/HOWTO_Use_Multimedia_Keys
 
Old 10-31-2005, 08:25 AM   #10
fiomba
Member
 
Registered: Sep 2004
Posts: 63

Rep: Reputation: 15
Hello whysyn,
I can only try a kind of diagnosis of your problem:
IMHO, it seems that, during the installation, you have enabled
the "dead key" technique and the keys you must type twice are
indeed the enabled "dead" keys.
For more details you can google a little or have a look at
Monk15 post and at my reply:
Bye.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard Press and hold broken Atrocity Slackware 6 09-29-2005 08:23 AM
Double key press on Keyboard Zettai Linux - Newbie 2 03-09-2005 10:59 PM
Keyboard Problem - I have to press a key twice for certain keys daedius Linux - Hardware 4 01-13-2005 06:32 AM
Can Only Press 3 or 4 Keys At Once While Gaming soroh Linux - Hardware 3 07-14-2004 02:33 AM
Beep when I press keyborad keys.. ! xconspirisist Fedora 1 01-30-2004 06:37 PM


All times are GMT -5. The time now is 03:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration