LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-01-2004, 06:15 AM   #1
digital vortex
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Rep: Reputation: 0
Unhappy IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always


Hello All,

I've searched for quite a bit about my particular problem before posting, so sorry to bother you all with yet another imwheel configuration question.

What do I have to do to make the thumb buttons on my 5 button IntelliMouse Explorer mouse function correctly when logged in as a non-root user.

I've been running Linux (Slack 9.1) for about two days now and I've configured imwheel as per the directions listed many times in various forums.


Here's the relevant snippet from my /etc/X11/XF86Config file:
Code:
Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Device"      "/dev/mouse"
    Option "Protocol"    "ExplorerPS/2"
    Option "Buttons" "7"
    Option "ZAxisMapping" "6 7"

EndSection
And here's what I have inserted into my /etc/X11/xinit/xinitrc.kde file:
Code:
# Start the window manager:
xmodmap -e "pointer = 1 2 3 6 7 4 5"
imwheel -k -b "67"
startkde
Finally, the .imwheelrc file in my home directory contains:
Code:
".*"
None, Up, Alt_L|Left
None, Down, Alt_L|Right
This configuration works perfect when I'm logged in as root. The wheel scrolls in Mozilla, and the Thumb Buttons allow me to move simulate "back" and "forward" page history functions.

However, when I log in as a normal user (which I created using "adduser" and all default values) the thumb buttons stop working as desired. If I click the thumb buttons over application windows, the new window will gain focus (I use KDE with MSWindows-like window behavior), but Mozilla no longer responds to these buttons by moving back and forth in page history. However, the scroll wheel continues to function.

I tried calling imwheel by using the "-p" flag, but that didn't fix anything. I also suid-rooted the imwheel binary by executing "chmod +s" on /usr/local/bin/imwheel, but that also did not help. In desperation, I used the KDE KUser utility to add my non-root user to the same groups that root belonged to. That also didn't do much to improve the situation.

Can you guys spot my mistake? Sorry to bore you, and thanks in advance.

Last edited by digital vortex; 03-01-2004 at 06:25 AM.
 
Old 03-01-2004, 08:16 AM   #2
mathwizard
LQ Newbie
 
Registered: Mar 2004
Distribution: Slack
Posts: 1

Rep: Reputation: 0
The problem is in your .imwheelrc if you are logged in as another user and the file is in /root/ folder you don't have access to it. create the file in your home folder where you are as normal user e.g. /home/mysuer
 
Old 03-01-2004, 08:36 AM   #3
digital vortex
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Mathwizard, sorry for the confusion. In my original post, when I said I created the ".imwheelrc file in my home directory," I meant that I already created this file in the home folder of the normal user.

So... I'm still having this problem. Thanks for the reply though.
 
Old 03-01-2004, 10:14 AM   #4
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
But do you have the same .imwheelrc in the home directories of root and non-root users? If you don't have a .imwheelrc in root's home directory, and the wheel works for root, try removing .imwheelrc from non-root home directories. Another thing is to check permissions for /dev/mouse or /dev/input/mice. Did you try the mouse without using imwheel? I don't have a wheel, but I thought recent versions of X could handle it without imwheel.
 
Old 03-01-2004, 03:46 PM   #5
digital vortex
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Actually, now I've stopped using .imwheelrc files in user's home directories, and am simply referencing the global imwheelrc definitions file in /etc/X11/imwheel/imwheel.

So, same file for all users now.

Except the funky behavior still continues. Wheel + Thumb Buttons only work when logged in with root.

Only wheel works when logged in as normal user.

Greg, after removing the .imwheel file, thumb buttons became equivalent to page up and page down keypresses, and the wheel stopped working entirely. This idea did not fix the problem.

Last edited by digital vortex; 03-01-2004 at 03:51 PM.
 
Old 03-02-2004, 05:17 AM   #6
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Try changing your ~/.imwheelrc file to:

".*"
None, Up, Alt_L|Left
None, Down, Alt_L|Right

"(null)"
None, Up, Alt_L|Left
None, Down, Alt_L|Right

It might not work, as you say you have things working as root, but it sorted out the thumb buttons in Mozilla for me.

Dave
 
Old 03-02-2004, 09:49 AM   #7
digital vortex
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Sigh,

Dave, that did not help either.

Other attempts I have tried include:

1. Running imwheel through sudo.

2. Chmodding +s the /dev/mouse and /dev/psaux devices.

3. Adding the xmodmap and imwheel startup commands to ~/.xinitrc instead of in /etc/X11/xinit/xinitrc.kde

4. Praying.

5. Using variations on the imwheel startup, such as "0067" instead of "67." And the -f flag.

6. Referencing the ~/.imwheelrc file again, instead of /etc/X11/imwheel/imwheelrc.

7. Manually adding "pointer = 1 2 3 6 7 4 5" to the vestigal /etc/X11/xinit/.Xmodmap file.

8. Forgot to mention that I disabled gpm from starting up as a service during the Slackware install. I read somwhere once that Slack's copy of gpm and imwheel are not best of friends.

Gah, I'm stuck. Thank you all for your help.

Continued suggestions are welcome. I'm pretty sure nothing is wrong with my imwheel setup, and it's accompanying files. Instead, I think I did something wrong when I originally employed "adduser" to create the non-root user. But that's just my inexperienced, humble opinion.

I'm considering just using the root user for everything.... blah.

Last edited by digital vortex; 03-02-2004 at 09:55 AM.
 
Old 03-02-2004, 04:14 PM   #8
digital vortex
LQ Newbie
 
Registered: Mar 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Update: got it to work.

It was a combination of Dave's last tip and correct syntax of using sudo.

It's odd that I didn't have to use the "(null)" section for the thumb buttons to work right for root.

I also didn't realize that one had to issue the sudo command with the full file path, not just the name of the binary.

Thank you all.

Last edited by digital vortex; 03-02-2004 at 04:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken X - Only works for root BigBadPenguin Slackware 11 02-25-2008 08:08 PM
Intellimouse Explorer side buttons and scroll wheel broken after kernel 2.6.10 Ricochet Linux - Hardware 3 07-28-2005 05:21 PM
Microsoft Intellimouse wheel/Optical USB (5 Buttons) barabus Linux - Hardware 2 06-14-2005 10:29 PM
root files: create as root:root or root:wheel? pcass Linux - Security 1 02-07-2004 04:14 PM
How to get scroll wheel and thumb buttons to work. DrD Linux - Newbie 2 02-07-2004 02:00 AM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration