LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-02-2002, 03:00 PM   #1
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Rep: Reputation: 30
Hauppage WinTV Card


HI. I'm having trouble with the card mentioned above. Here is the problem :

I'm getting only a black screen on overlay when I run xawtv. This is the output of v4l-conf :

map: vt01 => fb0
v4l-conf: using framebuffer device /dev/fb0
can handle only packed pixel frame buffers

This is the output of xawtv :

sh-2.05a$ xawtv
This is xawtv-3.76, running on Linux/i686 (2.4.18)
WARNING: Your X-Server has no DGA support.
WARNING: couldn't find framebuffer base address, try manual
configuration ("v4l-conf -a <addr>")
Warning: Cannot convert string "-*-ledfixed-medium-r-semicondensed--39-*" to type FontStruct
ioctl: VIDIOCCAPTURE(on): Invalid argument

Has anyone seen this kind of behaviour before? HOw can I get this card to work? I'm not actually sure there's a signal coming into the card, but I hear the screen should be blue if that is the case. Thanks in advance.
 
Old 09-02-2002, 03:08 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
well what did v4l-conf say?

dga should be enabled by default, you'd have to specifically turn it off normally. is it listed in XF86config (look for 'option "omit xfree86-dga"') and as for the framebuffer... are you booting to a framebuffer (i.e. logo in top corener of screen on boot) ? try running fbtv outside of X aswell, see if that gets any further
 
Old 09-02-2002, 03:55 PM   #3
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Original Poster
Rep: Reputation: 30
sh-2.05a$ xawtv
This is xawtv-3.76, running on Linux/i686 (2.4.18)
Warning: Cannot convert string "-*-ledfixed-medium-r-semicondensed--39-*" to type FontStruct
Xlib: extension "GLX" missing on display ":0.0".


Is the output of xawtv after I ommited that line, thanks acid. I now get some static at the top of the box, the rest is black. THe ouput of v4l-conf is the same though (see first post). I haven't tried to run fbtv in X, I"ve been running it on a (real) console. As for booting into a framebuffer (the logo at the top-left) I can't remember ( it used to, but then I changed some monitor settings and now I can't remember - would it help if I rebooted to give a definite answer on that?). Thanks for the help thus far.
 
Old 09-02-2002, 04:28 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
right, so fbtv DOES work outside of X? now you'er getting GL errors, have you got the GLX extension loading in your XF86Config?
 
Old 09-02-2002, 05:31 PM   #5
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Original Poster
Rep: Reputation: 30
no, fbtv gives me the same messages as v4l-conf, except it tells me that it's using a linux console font.

GLX was commented in XF86Config. I uncommented the line and restarted X. Here is xawtv's output :

sh-2.05a$ xawtv
This is xawtv-3.76, running on Linux/i686 (2.4.18)
Warning: Cannot convert string "-*-ledfixed-medium-r-semicondensed--39-*" to type FontStruct


still static at the top, the rest is black. v4l-conf still says the same stuff.
 
Old 09-02-2002, 05:39 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
well, not a clue about the ont problems, thoguht waxtv brought all it's fonts with it... anyway, surely you just need to tune the bugger in now no? make sure its selecting the right input source and you should be able to tun it in. you have got the card set up in modules.conf i presume. my wintvgo entry says:

alias char-major-81 bttv

and nothing else. you can add various options to explicitly state the card type, but it's such a generic card it shoudln't really need it.
 
Old 09-02-2002, 05:53 PM   #7
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Original Poster
Rep: Reputation: 30
This is what I found somewhere for my modules.conf :

## TV Card
alias char-major-89 i2c
options i2c i2c_debug=0 verbose=1 scan=1
alias char-major-81 videodev
alias char-major-81-0 bttv
options bttv card=6 radio=0
options tuner debug=0 type=6
options msp3400

It's still giving static, but I feel alot better about it now that there are less errors. I think if I get the v4l-conf thing figured out it'll be okay.
 
Old 09-02-2002, 05:58 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
well i'd try knocking out ALL of tha and just using that line i have in mine, i don't even have any i2c lines.., and it worked first time.
 
Old 09-02-2002, 06:24 PM   #9
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Original Poster
Rep: Reputation: 30
well, I removed all the extra crap, put that line in, rmmod'ed all the related modules then ran depmod -a and finnally modprobe bttv. Everything was re-loaded and so I went back to try xawtv. It didn't really change things . Though I am glad my modules.conf isn't so huge.
 
Old 09-03-2002, 05:04 PM   #10
lackluster
Member
 
Registered: Apr 2002
Location: D.C - USA
Distribution: slackware-current
Posts: 488

Original Poster
Rep: Reputation: 30
acid_kewpie,

thanks for your help. After struggling for a while I finnaly got a (staticy) channel 5. A BIG improvement. I don't know why the stations won't come in clear though. Would having digital cable have anything to do with it (I have it hooked up AFTER the cable box)?

Last edited by lackluster; 09-03-2002 at 05:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hauppage WinTV Card in Ubuntu ubuntu-addict Linux - Software 19 02-09-2010 10:53 PM
Hauppage WinTV PVR 350 RobertSensei Linux - Hardware 2 10-24-2005 10:42 PM
Hauppage WinTV does not work... dimgr Linux - Hardware 11 01-09-2005 05:41 PM
Hauppage WinTV Card in YOPER??? KDETV???? rm6990 Yoper 2 10-11-2004 11:04 PM
hauppage wintv card subh Linux - Hardware 3 11-09-2003 11:53 PM


All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration