LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-28-2005, 09:57 PM   #1
saiket
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1,


hi all,
my LINUX version is redhat 9.0 and the name of my usb_flash drive is
"Kingstone Data Traveller" . problem is when i run following code to mount
Code:
 mount -t vfat /dev/sda1 /mnt/usb
the i got the following error
Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
 or too many mounted file systems
 
Old 10-28-2005, 11:11 PM   #2
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Unplug the pen drive, wait a few secs, then plug it again. Wait a few secs again and open a console. Issue 'dmesg' and see the last lines regarding the info from kernel, about the pen drive. They can give you some clues on whats going on.
Also, plug the device, then log in as root in a console and do:
dosfsck /dev/sda1
This will check if the fat fs in the drive is ok.
 
Old 04-11-2008, 12:48 PM   #3
juanarce
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Solucion

For mount the usb drive:

Log in as root in a console and:

go to /etc/fstad

Edit this file whith vim /etc/fstab and
write in the end of the file:

/dev/sda1 /media/usb vfat rw,user,noauto 0 0

After create the folder /media/usb/ whith mkdir /media/usb

Excuse me for my bad english, bud the solutiont is appropriate for this problem.


Greetings for all.
 
Old 04-12-2008, 12:07 AM   #4
Kahless
Member
 
Registered: Jul 2003
Location: Pennsylvainia
Distribution: Slackware / Debian / *Ubuntu / Opensuse / Solaris uname: Brian Cooney
Posts: 503

Rep: Reputation: 30
Upgrade your distro before you become a rootkit zombie.

If you want to stay redhat, use the latest fedora, or the latest centos

If not, give Ubuntu a try
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 11:37 AM
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM
USB 2.0 memory stick mount: wrong fs type, bad option, bad superblock on /dev/sda1, o olivier.riff Linux - Hardware 2 11-12-2003 08:11 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration