LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-17-2002, 05:00 PM   #1
Oooska
LQ Newbie
 
Registered: Jan 2002
Location: Bangor, ME
Distribution: Slackware 8
Posts: 20

Rep: Reputation: 0
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom


I tried to mount my cdrom drive as either root and a regular user, but when I do I get this error:
Code:
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
The line pertaining to the drive in fstab is:
Code:
/dev/cdrom      /mnt/cdrom       iso9660 noauto,ro,users 0 0
Also when I login as root and try to use either the GNOME or KDE CD players music plays just fine, but if I try it as a regular user I get an error saying permission is denied. So it seems as if the CD players can mount the cdrom drive just fine as root.

Any suggestions would be appreciated. Thanks : )
 
Old 03-17-2002, 05:11 PM   #2
isajera
Senior Member
 
Registered: Jun 2001
Location: San Antonio, TX
Distribution: distro? what's a distro?
Posts: 1,635

Rep: Reputation: 45
well... if you're using audio cd's, then you don't mount them. audio cd's don't really use typical filesystem formats - they have a table of contents, and a couple of tracks... not a real filesystem. data cd's are written differently... they have a filesystem, so they need to be mounted.
 
Old 03-17-2002, 05:16 PM   #3
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
look in /dev and see if you even have a device called cdrom.

If you dont then create one
ln -s /dev/hdc /dev/cdrom

/dev/hdc is what my cdrom drive is on, yours may be different.
 
Old 03-17-2002, 07:18 PM   #4
LinuzRulz
Member
 
Registered: Jan 2002
Location: Confederate States of America
Distribution: Mandrake 9.0
Posts: 197

Rep: Reputation: 31
try this

I got mine to mount like this....go into terminal as SU, then type....

chmod a+rwx /mnt/cdrom
then I had to reboot ..............after that it worked
 
Old 03-17-2002, 11:43 PM   #5
Oooska
LQ Newbie
 
Registered: Jan 2002
Location: Bangor, ME
Distribution: Slackware 8
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks guys, my CDROM drive mounts now. However, I still can't the CD Player to play any CDs yet. I get this error when I load it. I've tried everything I can think of, my regular account has ownership and auth rights to access the CD drive, but I still get that error.

*Edit: Silly vB code.

Last edited by Oooska; 03-17-2002 at 11:44 PM.
 
Old 03-18-2002, 12:21 PM   #6
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
make sure you have permmision to access the actual dev ie; hdc.

do a ls -al /dev/cdrom and see what device the simlink is pointing to. And give your normal users read, and maybe exec access to it
 
Old 03-19-2002, 05:51 AM   #7
panjas51
LQ Newbie
 
Registered: Mar 2002
Posts: 10

Rep: Reputation: 0
me too

actually I am having the same problem.

fook forward to get your answers
 
Old 07-10-2013, 12:37 PM   #8
andrewcassidy
LQ Newbie
 
Registered: Jul 2013
Posts: 1

Rep: Reputation: Disabled
specific the type

Try: mount -t iso9660 /dev/cdrom mnt/cdrom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 09:55 AM
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 01:07 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 11:31 AM
wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file sy TheCyberDude Linux - Software 1 02-11-2002 01:44 PM


All times are GMT -5. The time now is 04:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration