LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, (http://www.linuxquestions.org/questions/linux-hardware-18/error-at-mounting-usb-mount-wrong-fs-type-bad-option-bad-superblock-on-dev-sda1-377918/)

saiket 10-28-2005 09:57 PM

ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1,
 
hi all,
my LINUX version is redhat 9.0 and the name of my usb_flash drive is
"Kingstone Data Traveller" . problem is when i run following code to mount
Code:

mount -t vfat /dev/sda1 /mnt/usb
the i got the following error
Code:

mount: wrong fs type, bad option, bad superblock on /dev/sda1,
 or too many mounted file systems


bruno buys 10-28-2005 11:11 PM

Unplug the pen drive, wait a few secs, then plug it again. Wait a few secs again and open a console. Issue 'dmesg' and see the last lines regarding the info from kernel, about the pen drive. They can give you some clues on whats going on.
Also, plug the device, then log in as root in a console and do:
dosfsck /dev/sda1
This will check if the fat fs in the drive is ok.

juanarce 04-11-2008 12:48 PM

Solucion
 
For mount the usb drive:

Log in as root in a console and:

go to /etc/fstad

Edit this file whith vim /etc/fstab and
write in the end of the file:

/dev/sda1 /media/usb vfat rw,user,noauto 0 0

After create the folder /media/usb/ whith mkdir /media/usb

Excuse me for my bad english, bud the solutiont is appropriate for this problem.


Greetings for all.

Kahless 04-12-2008 12:07 AM

Upgrade your distro before you become a rootkit zombie.

If you want to stay redhat, use the latest fedora, or the latest centos

If not, give Ubuntu a try :)


All times are GMT -5. The time now is 02:59 PM.