LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-19-2004, 11:37 AM   #1
Jemsquash
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Rep: Reputation: 0
After adding ide to SATA(via) machine, boot fails - Fedora core 2


I have Fedora Core 2 (64 bit) installed on my SATA disk. I also have the 32 bit version installed on an ide drive.

When I put both drives in at the same time then it no longer boots up. I am trying to boot with the SATA drive.
It gets as far as displaying the message:
Red Hat nash Version 3.5.22 starting
And then stops.

If I disconnect the ide drive again then it boots no problem. I cannot see anything in the logs. I have looked in the boot.log and messages and cannot see anything there. I can also boot up on the ide drive if the SATA drive is disconnected.

Both installs were done without the other drive connected.

I have a biostar K8NHA pro motherboard which uses the via SATA chipset.

Any hints/guesses appreciated.

Thanks.
 
Old 09-19-2004, 12:10 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Where is your grub/lilo or other bootloader? Either your problem
is quite simply that you have a bootloader on each drive, and they're
not properly setup - or there's information amiss in your post.
 
Old 09-20-2004, 08:52 AM   #3
Jemsquash
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I have grub on the SATA drive.

This is the config file for it:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/hde1
# initrd /boot/initrd-version.img
#boot=/dev/hde
default=0
timeout=10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title Fedora Core (2.6.8-1.521)
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1.521 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.8-1.521.img
title Fedora Core (2.6.7-1.494.2.2)
root (hd0,0)
kernel /boot/vmlinuz-2.6.7-1.494.2.2 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.7-1.494.2.2.img
title Fedora Core (2.6.6-1.435.2.3)
root (hd0,0)
kernel /boot/vmlinuz-2.6.6-1.435.2.3 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.6-1.435.2.3.img

As far as I can tell the SATA drive is hd0,0 but I am not 100% sure.

This is the bootup message :
Booting 'Fedora Core (2.6.8-1.521)'
kernel direct mapping tables upto 10100000000 @ 8000-c000
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.8-1.521 ro root=LABEL=/ rhgb quiet
[Linux-bzImage, setup=0x1400, size=0x1a266d]
initrd /boot/initrd-2.6.8-1.521.img
[Linux-initrd @ 0x37f3b000, 0xb4567 bytes]



Decompressing Linux...done.
Booting the kernel.
audit(1095706744.237:0): initialized
Red Hat nash version 3.5.22 starting

Which is where it stops. If I boot up without the IDE drive attached it looks identical except for the line:
audit(1095706875.237:0): initialized

I am not sure how the drives are assigned by the bios but is seems to be correct.

mount reports the SATA drive as follows:
/dev/sda1 on / type ext3 (rw)

Thanks.
 
Old 09-20-2004, 09:41 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
I'm sorry, but I never could figure out GRUB so I use LILO.
I do see this:
Quote:
root (hd0,0)
Filesystem type is ext2fs
but mount reports /dev/sda1 (is that / on the sata drive?) is ext3,
so that must be the IDE drive it's attempting to boot. I think
that hd0,0 is the master drive on the primary controller, and
hd0,1 is the slave, etc. If so, then I don't know what will be
the designation for sata0 and sata1.

When I've installed the 2.4.26 kernel with my sata drive, it is
recognized at /dev/sda but when I installed 2.6.7 it was then
changed to /dev/hde so I couldn't get it to boot. Check out
this thread http://kerneltrap.org/node/view/3795 and see if
it helps.
 
Old 09-20-2004, 10:40 AM   #5
Jemsquash
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for that post.

It has got me a lot further.

I changed the root entry in grub.conf to:
kernel /boot/vmlinuz-2.6.8-1.521 ro root=/dev/sda1 rhgb quiet

Which enabled me to boot correctly (with the correct kernel so I know it is off the correct drive). I guess grub is not passing the correct value through to the kernel.

Now, however, mount seems to be confused.

mount reports :
/dev/hdd2 on / type ext3 (rw)

which is my sata drive! Which used to be sda1.

If use the hardware browser it reports:
/dev/sda1 as the sata drive - but when I type mount it reports otherwise (/dev/hdd2)
/dev/hdd1 as a small extended partition.
/dev/hdd2 as ext3 - which is my other linux partition.

I can now mount /dev/hdd2 and browse my other partition.

Which is what I want.

Thanks.

P.S. I am still confused why mount is reporting the SATA drive as hdd2!?!
 
Old 09-20-2004, 10:48 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Try the LQ search function and enter "sata on Slackware 9.1"
which is where I first read about sata in Slackware. You will
get many threads about sata. Try reading some of that and
see where it leads you. And read and search at KernelTrap
where I gave you the previous link.

I'm trying 2.6.7 on this comp again right now, reading those
links I just "searched up" first....
 
Old 09-21-2004, 09:41 AM   #7
Jemsquash
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I've now changed /etc/fstab to read
/dev/sda1 / ext3 defaults 1 1

Now eveything seems as it should be when I boot up.

mount now reports:
/dev/sda1 on / type ext3 (rw)


Thanks again for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to install Fedora Core 3 on a machine that cannot boot to CD caps_phisto Fedora - Installation 1 02-11-2005 10:42 PM
SATA HD does not boot Fedora Core in second HDD vida Fedora - Installation 1 01-06-2005 10:18 AM
Dual boot on Fedora/Windows || 1st hd=sata 2nd hd=IDE Mustard010 Linux - General 4 11-28-2004 03:54 PM
advice sought: need linux as dual boot. machine has SATA raid 0, fedora? abunn Linux - Newbie 1 09-16-2004 08:38 AM
advice sought: need linux as dual boot. machine has SATA raid 0, fedora? abunn Linux - Hardware 3 09-15-2004 03:33 AM


All times are GMT -5. The time now is 02:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration