LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-24-2008, 01:34 PM   #1
karnaf
Member
 
Registered: Dec 2005
Distribution: Linux Mint 14 (Cinnamon), Xubuntu 12.04, Ubuntu 10.04
Posts: 49

Rep: Reputation: 15
Switching languages, but keeping the hot keys?


Hi,

I've recently re-installed Kubuntu 8.04 on my machine which I am using mostly for typing, both in Hebrew and in English. I use both languages in a few applications, and am looking for an easy way to switch between the two without any change to the behavior of the application's hot-keys and the global hot-keys.

For example, I want to switch to typing in Hebrew in oowriter, but keep CTRL+B for bold, CTRL+I for italics, CTRL+S for save, CTRL+SHIFT+D for 'show desktop', etc.

My default system's language is English (by choice) and /etc/environment also has LANG=en_US.utf8 to be on the safe side. Got Hebrew and English layouts, got Hebrew and English languages installed (visible in kcontrol, English first on both cases)

I think I have managed to do what I want in KDE4 but I'm back to KDE3 and want to stay here.

So, can I have the language switching change only the typed text but keep the rest as it was?


Thanks, Happy Hanukkah, Merry Christmas, Happy Id El Adha,
karnaf
 
Old 12-28-2008, 02:09 PM   #2
karnaf
Member
 
Registered: Dec 2005
Distribution: Linux Mint 14 (Cinnamon), Xubuntu 12.04, Ubuntu 10.04
Posts: 49

Original Poster
Rep: Reputation: 15
Well, thanks for nothing :-)
With the help of some friends, lots of tries and lots of reading, I've finally found the solution -

1. Open kcontrol
2. Go to 'Regional & Accessibility' > 'Keyboard Layout'
3. Check the 'Enable keyboard layouts' checkbox
4. Remove the current layout you have (you may not have to do this, but I did)
5. Add the 'Israel il' layout
6. Select it in the 'Active layouts' list and then check the 'Include latin layout' checkbox down at the bottom
7. Click 'Apply' and voila, you're done

Enjoy!
 
Old 01-22-2009, 06:40 AM   #3
karnaf
Member
 
Registered: Dec 2005
Distribution: Linux Mint 14 (Cinnamon), Xubuntu 12.04, Ubuntu 10.04
Posts: 49

Original Poster
Rep: Reputation: 15
Next step - how do I make the Latin layout the default one? i.e. keep the above behavior, only have it start with Latin and not Hebrew.

Thanks
 
  


Reply

Tags
keyboard, language, layout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keeping the other languages out. bezeek Linux - Software 2 08-30-2007 01:46 PM
How to setup Hot keys language layout switching? loom Linux - Newbie 7 05-22-2007 07:08 AM
switching languages? Four Linux - Newbie 4 01-31-2006 05:02 PM
with keys is the keys that change languages? AKAKAK Fedora 2 01-25-2005 11:11 AM
switching between languages monohouse Linux - Software 8 12-10-2004 02:08 PM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration