LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-16-2007, 08:18 AM   #1
loom
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
How to setup Hot keys language layout switching?


Hi,

Is there any way to setup hot key language switching? I'm using Kubuntu. In the configure KDE Control module I have added two active layouts, then on Xkb Options tab, I enabled "Enable xkb options" check box, and checked "Group Shift/Lock behavior ->Alt+Shift changes group". But this didn't help. I still need to click on the task bar in order to switch the layout How did you setup to change current keyboard layout with hot keys?

Thanks,
loom
 
Old 05-16-2007, 08:27 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
You should edit your xorg.conf and use something like:
Code:
Option "XkbLayout"  "lang1,lang2"
Option "XkbOptions" "grp:alt_shift_toggle"
Take a look here for details.

Regards
 
Old 05-20-2007, 04:27 PM   #3
loom
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the help, but it didn't help

I have followed the steps provided on the referenced site, however, the result was the same: hot keys didn't work. Probably, you might recommend other solution if any?

Last edited by loom; 05-21-2007 at 02:02 AM.
 
Old 05-20-2007, 06:12 PM   #4
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
Have you tried it with each alt key? Some keyboard layouts have the right alt set as a third level shift--so only the left alt is an actual alt key.

Do other combinations work? Like will grp:shifts_toggle allow you to switch by pressing both shift keys?
 
Old 05-21-2007, 02:15 AM   #5
loom
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Original Poster
Rep: Reputation: 0
That is what is written in my xorg.conf file.
Code:
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us,ru(winkeys)"
	Option		"XkbOptions"	"grp:shifts_toggle"
EndSection
I have two applications installed Kxkb and KeyboardSwitch. The first one I used to get "grp" string as adviced in the Ubuntu forum. But the result is still the same. By the way, if I remove both these application, who will be responsible for switching and whether it is possible to setup layout switching with standard Kubuntu hotkeys?
 
Old 05-21-2007, 03:12 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,526

Rep: Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503Reputation: 1503
Check your Xorg.0.log to see if you find any errors when you try to switch languages.
Quote:
By the way, if I remove both these application, who will be responsible for switching
If you remove those apps, then xserver will handle the language switching using the settings in xorg.conf. If you want to use the kxkb (to view the flag of the currently selected language), then you have to edit ~/.kde/share/config/kdeglobals:
Search for "Switch to Next Keyboard Layout" and change it to "ALT+SHIFT_L", or whatever you want.

Regards

Last edited by bathory; 05-21-2007 at 03:42 AM.
 
Old 05-21-2007, 01:08 PM   #7
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
In your xorg.conf, I think you need to put the variant in a different line. Try
Code:
Option     "XkbLayout"     "us,ru"
Option     "XkbVariant"    ",winkeys"
 
Old 05-22-2007, 07:08 AM   #8
loom
LQ Newbie
 
Registered: Jan 2007
Posts: 4

Original Poster
Rep: Reputation: 0
No progress yet

Before continue this conversation I want to thank you guy for your assistance!

So, I have replaced the "winkeys" as Sonneteer recommended. No effect.

After that I checked Xorg.0.log. But unfortunately I couldn't understand the log messages. What kind of errors should I see there?

And the last thing. The file ~/.kde/share/config/kdeglobals doesn't contain a string like "Switch to Next Keyboard Layout". If I need to add it then where?

Thanks people!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 07:43 PM
How To Disable Hot-Keys of Console? davialbuquerque Linux - Software 2 04-16-2006 04:39 PM
Hot Keys in GNOME sipsipi Linux - Software 1 03-11-2006 07:08 AM
Using hot keys in linux hollering Linux - Hardware 1 01-14-2004 06:32 PM
Hot Keys on Gnome anyone ?.... amit_181 Linux - General 1 07-20-2001 09:02 AM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration