LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 01-04-2005, 01:07 AM   #1
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Rep: Reputation: 15
No sound in Firefox - but sound in KDE


Alright, this is kind of an odd problem -
I have sound setup in KDE. When I go to the Sound System Module and click the Test Sound button, I hear sound. If I open tvtime, or xmms, or xine or anything else for that matter, I get sound.

When I open firefox and check out some flash animations - no sound.

What do I need to (re?)configure to get sound?

I''m on Slackware 10, KDE 3.2.x
PC has a TvTuner card based on bttv and a SoundBlaster Audigy

Any ideas?
 
Old 01-04-2005, 01:13 AM   #2
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 199

Rep: Reputation: 30
Do sounds work on Flash in Konqueror?
 
Old 01-04-2005, 01:15 AM   #3
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Poprocks
Do sounds work on Flash in Konqueror?
you know - it doesn't

-Jason
 
Old 01-04-2005, 01:17 AM   #4
student04
Member
 
Registered: Jan 2004
Location: Georgia
Distribution: OS X, CentOS
Posts: 669

Rep: Reputation: 34
do you have two sources of sound open at the same time? When i have XMMS open and a flash document on a webpage loads, it never has sound. I have to close XMMS and restart firefox for it to work. But this is a driver problem, and the one i'm using right now is basic - haven't gotten around to modifying it.
 
Old 01-04-2005, 01:21 AM   #5
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by student04
do you have two sources of sound open at the same time? When i have XMMS open and a flash document on a webpage loads, it never has sound. I have to close XMMS and restart firefox for it to work. But this is a driver problem, and the one i'm using right now is basic - haven't gotten around to modifying it.
No, I've tried just running firefox alone w/ no xmms. I can play the flash movies, get no sound, then start xmms and voila, there's sound.

Same with the Sound Test Panel.

-JAson
 
Old 01-04-2005, 01:25 AM   #6
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 199

Rep: Reputation: 30
Quote:
Originally posted by student04
do you have two sources of sound open at the same time? When i have XMMS open and a flash document on a webpage loads, it never has sound. I have to close XMMS and restart firefox for it to work. But this is a driver problem, and the one i'm using right now is basic - haven't gotten around to modifying it.
Yes you bring up a good point -- are you (original poster) using OSS or ALSA? If you're using OSS, upgrade to ALSA now (it's about time anyway). OSS only allows one source of output to be piped to your card at once, so if a sound server---such as aRts---is running, it is probably occupying the one source of output that can be piped to.

A good way to tell is by running
Code:
lsmod | grep snd
and see if there are any snd-whatever modules. Mine, for example, lists snd-via82xx among others. If you do not see that, you are probably not running ALSA but OSS.

A short-term solution if you don't want to switch to ALSA, would be to enable the option in Konqueror (forget where it is, I don't have KDE installed) that allows you to pipe any plugin sounds through aRts. That would only work for Konqueror, of course.
 
Old 01-04-2005, 01:40 AM   #7
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
The system is running alsa 1.7.

Curious note, when I attempt to turn on full-duplex in the KDE Sound System module, I get an error saying :

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for capture (Permission denied)
The sound server will continue, using the null output device.

And then no sounds plays. If I uncheck the option I can hear the test music.

What permissions do I have to change to enable full duplex?
 
Old 01-04-2005, 01:43 AM   #8
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
OOOhhhh, even more confusing stuff ...

I was looking at the options for xine, and tried the -A option which allows you to choose what audio system to use.

When I use "-A oss" the sound works, when I use "-A alsa" it doesn/t. When I don't use the "-A" it works.

So does that mean part of my system is using the OSS and par tof it is in ALSA?

I'm thoroughly lost now.
 
Old 01-04-2005, 01:46 AM   #9
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 199

Rep: Reputation: 30
how sure are you that you are running ALSA and that you have ALSA drivers, and not OSS drivers, loaded?

It is of course possible to have ALSA installed but be completely unused.

Last edited by Poprocks; 01-04-2005 at 01:48 AM.
 
Old 01-04-2005, 02:04 AM   #10
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Poprocks
how sure are you that you are running ALSA and that you have ALSA drivers, and not OSS drivers, loaded?

It is of course possible to have ALSA installed but be completely unused.

well
when I use alsactl to restore settings it works
I use alsamixer to adjust the volumes

The KDE sound system declares it's using ALSA
XMMS also claims to be using ALSA as it's output. And when I adjust the volume in that, it changes the same volume in alsamixer

So I'm fairly confident I'm using ALSA

-Jason
 
Old 01-04-2005, 05:58 AM   #11
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Try running firefox from the command line but put artsdsp in front of it. In other words, if your firefox binary is called firefox then you would type artsdsp firefox. Then see if you get sound in flash.
 
Old 01-04-2005, 11:57 AM   #12
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
Thumbs up

Yeah..
Code:
artsdsp firefox
does the trick
But is there any other way of automating this...?
 
Old 01-04-2005, 10:05 PM   #13
shawv
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
As for the "permission denied" error, make sure you have read and write access to /dev/dsp. On my gentoo system, this is a link to /dev/sound/dsp, which is owned by root and group 'audio.'. I just added myself to the audio group to get the permissions I needed. Good luck.
 
Old 01-05-2005, 04:17 AM   #14
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Quote:
But is there any other way of automating this...?
How do you normally launch firefox? The Debian menu? If so, then copy /usr/lib/menu/mozilla-firefox to /etc/menu/mozilla-firefox. Then (as root) edit this new file (/etc/menu/mozilla-firefox) and change the command to read artsdsp firefox. Then run update-menus as the user (not root).

You can do similar things for any debian package.
 
Old 01-09-2005, 04:25 AM   #15
icpsvt
LQ Newbie
 
Registered: Oct 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Amazingly that still doesn't do the trick.
I'm forever stuck.

I have sound virtually everywhere else. In konsole I have the little annoying beeps if you back up too much.
I can play music through xmms and amp.
I've setup xine to play music through the arts server

But stupid friggin flash stuff ain't working. Maybe I should try reinstalling flash?

I'll give that a shot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Player, Firefox: sound in blackbox but not KDE DaneM Slackware 11 11-21-2006 02:41 PM
KDE blocks sound? cant play sound from other programs. Smurfen Linux - Hardware 1 04-02-2005 08:14 PM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 02:05 AM
kde sound options gone except for root, login sound gone memphisSuseUser Linux - Distributions 2 12-10-2004 06:55 PM
Gnome has sound/switch to KDE no sound Lar Fedora 6 11-05-2004 04:33 AM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration