LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-03-2003, 12:14 PM   #1
svyshna
LQ Newbie
 
Registered: Aug 2003
Location: Bangalore
Posts: 10

Rep: Reputation: 0
Mounting problems in local file system


Hi Guys


Today Our vob server O.S was corrupted(LINUX-2.4.18-3) I have installed again and mount the file system " /vobfs" (From data disk---/dev/sdb1)

Our /etc/fstab entry is like this

"/dev/sdb1 /vobfs ext3 defaults 1 2 "



If I give like this the vobs(contents of the file system ) are not mounted while booting .After booting if I run " mount /vobfs " then they are mounted.(strange?).But we are unable to check out any file .We are getting permission denied error to write some thing If I run 'mount" command the filesystem is listed as 'rw"

For this problem we are following the following procedur to make it work tempararly

1.commented the /etc/fstab entry for /vobfs

2.Booted the system

3.mount with the command " mount /dev/sdb1 /vobfs "

4.cd /etc/init.d

5 ./nfs restart

6.ct mount -all

Then only we are able to do checkins.But the problem is system is hanging sometimes while doing checkins

7.Our vob and view storage file systems type is "ext3"

8.I Run the fsck and mounted it again .Still we are getting the same trouble


What could be the reasons for the file system not getting mounted eventhough we have given entryes in /etc/fstab file?

Regards, Satya
 
Old 08-03-2003, 04:24 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,530

Rep: Reputation: 178Reputation: 178
I would try changing the permissions of /vobfs to:
drwxr-xr-x

mount may be looking for the x in the directory permissions.
 
Old 08-06-2003, 09:51 AM   #3
svyshna
LQ Newbie
 
Registered: Aug 2003
Location: Bangalore
Posts: 10

Original Poster
Rep: Reputation: 0
mounting file system

Hi,
Thanks for your reply
The permisssions are similar as you mentioned.pls give alternative
Regards,
Svyshna
 
Old 08-06-2003, 10:58 AM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Hi svyshna

You could always try putting in your User ID (uid ) as one of the options - to get it -

su to root - then

id username (substitute your usename in )

It will then look something like this

/dev/sdb1 /vobfs ext3 uid=501,defaults 1 2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel 2.6.10 - error mounting local file systems sirrus_linux Linux - Software 6 02-12-2005 01:07 PM
cannot mount the local file system egypt Red Hat 2 10-06-2004 11:02 AM
One of my local file systems /dev/sda9 is not mounting Fairlie Linux - Newbie 8 05-10-2004 11:27 PM
System hangs when Mounting local filesystems, help please!! slopez Linux - General 3 03-05-2004 03:37 PM
mounting problem in local file system svyshna Linux - Newbie 0 08-03-2003 01:00 PM


All times are GMT -5. The time now is 05:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration