LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-06-2005, 02:58 PM   #1
sirrus_linux
LQ Newbie
 
Registered: Sep 2004
Location: India
Distribution: Fedora Core 2
Posts: 11

Rep: Reputation: 0
kernel 2.6.10 - error mounting local file systems


I have this strange error coming up everytime i boot up the system :
( I have recently moved onto a custom built 2.6.10 kernel from the stable 2.6.9 kernel )

Mounting local filesystems: mount: wrong fs type, bad option, bad superblock on none,
or too many mounted file systems [FAILED]

I have been able to boot perfectly inspite of this error and the system appears to be stable.

I can also access my vfat windows partitions flawlessly.

My specs are : Athlon Xp 1800+, ASUS A7N266-VM

Help will be appreciated. Thanks in advance.

================================================== ========

attached : DMESG report is as follows :-

Linux version 2.6.10-ck5Thunderbird (root@Thunderbird) (gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #3 Sun Feb 6 01:37:47 IST 2005
BIOS-provided physical RAM map:

223MB LOWMEM available.
On node 0 totalpages: 57324
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 53228 pages, LIFO batch:12
HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 ASUS ) @ 0x000f7fd0
ACPI: RSDT (v001 ASUS A7N266VM 0x42302e31 MSFT 0x31313031) @ 0x0dfec000
ACPI: FADT (v001 ASUS A7N266VM 0x42302e31 MSFT 0x31313031) @ 0x0dfec100
ACPI: BOOT (v001 ASUS A7N266VM 0x42302e31 MSFT 0x31313031) @ 0x0dfec040
ACPI: MADT (v001 ASUS A7N266VM 0x42302e31 MSFT 0x31313031) @ 0x0dfec080
ACPI: DSDT (v001 ASUS A7N266VM 0x00001000 MSFT 0x0100000b) @ 0x00000000
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:6 APIC version 16
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl edge)
ACPI: BIOS IRQ0 pin2 override ignored.
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ9 used by override.
Enabling APIC mode: Flat. Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Built 1 zonelists
Kernel command line: ro root=/dev/hda11 rhgb quiet vga=5
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
CPU 0 irqstacks, hard=c03ca000 soft=c03c9000
PID hash table entries: 1024 (order: 10, 16384 bytes)
Detected 1529.734 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x34
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 223376k/229296k available (1894k kernel code, 5292k reserved, 762k data, 168k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 3014.65 BogoMIPS (lpj=1507328)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1c3fbff 00000000 00000000 00000000 00000000
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383fbff c1c3fbff 00000000 00000020 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: AMD Athlon(TM) XP 1800+ stepping 02
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=0 pin2=-1
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 109k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf1ab0, last bus=2
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20041105
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI2._PRT]
Linux Plug and Play Support v0.97 (c) Adam Belay
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically. If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device(). As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior. If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.
Simple Boot Flag at 0x3f set to 0x1
audit: initializing netlink socket (disabled)
audit(1107695295.420:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected NVIDIA nForce chipset
agpgart: Maximum main memory to use for agp memory: 176M
agpgart: AGP aperture is 64M @ 0xf8000000
Hangcheck: starting hangcheck timer 0.5.0 (tick is 180 seconds, margin is 60 seconds).
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
elevator: using cfq as default io scheduler
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 2 RAM disks of 16384K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE: IDE controller at PCI slot 0000:00:09.0
NFORCE: chipset revision 195
NFORCE: not 100% native mode: will probe irqs later
NFORCE: BIOS didn't set cable bits correctly. Enabling workaround.
NFORCE: 0000:00:09.0 (rev c3) UDMA100 controller
Probing IDE interface ide0...
hda: SAMSUNG SV4012H, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: GCR-8521B, ATAPI CD/DVD-ROM drive
hdd: LG CD-RW CED-8081B, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
hda: max request size: 128KiB
hda: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hda: cache flushes supported
hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >
hdc: ATAPI 52X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 168k freed
ACPI: Power Button (FF) [PWRF]
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [LNKU] enabled at IRQ 22
ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 22 (level, high) -> IRQ 22
ohci_hcd 0000:00:02.0: nVidia Corporation nForce USB Controller
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: irq 22, pci mem 0xef000000
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 22 (level, high) -> IRQ 22
ohci_hcd 0000:00:03.0: nVidia Corporation nForce USB Controller (#2)
PCI: Setting latency timer of device 0000:00:03.0 to 64
ohci_hcd 0000:00:03.0: irq 22, pci mem 0xee800000
ohci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
EXT3 FS on hda11, internal journal
Adding 240932k swap on /dev/hda10. Priority:-1 extents:1
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda9, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Mounting local filesystems: mount: wrong fs type, bad option, bad superblock on none, Mounting local filesystems: mount: wrong fs type, bad option, bad superblock on none,
 
Old 02-06-2005, 03:14 PM   #2
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Rep: Reputation: 15
I think there is a bug in /etc/fstab
You should check it.
 
Old 02-06-2005, 03:55 PM   #3
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by mmmm
I think there is a bug in /etc/fstab
You should check it.
Yes, list your /etc/fstab file please....
 
Old 02-06-2005, 09:49 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
List both /etc/fstab and /proc/mounts. This way we can see WHICH file system(s) caused the problem.
 
Old 02-09-2005, 04:53 PM   #5
sirrus_linux
LQ Newbie
 
Registered: Sep 2004
Location: India
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
hey ! sorry you all -- for the delayed reply........

I have the fstab file content for you as follows
==========================================
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hda10 swap swap defaults 0 0
/dev/hda7 /mnt/F_drive vfat defaults,gid=users,umask=002 0 0
/dev/hda8 /mnt/G_drive vfat defaults,gid=users,umask=002 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
==========================================

but i really dont find anything wrong in these entries ---- cause i have my backup kernel 2.6.5-1.386 whick is the standard kernel in fedora 2 and it works flawlessly without flashing any error messages ..... why is that the new 2.6.10 kernel keeps flashing this message ????

anyway - i really appreciate your help -- keep gaining my appreciation

thank you.

Last edited by sirrus_linux; 02-09-2005 at 04:57 PM.
 
Old 02-10-2005, 12:41 PM   #6
mmmm
Member
 
Registered: Oct 2004
Location: Poland
Distribution: Slack 10.1, Mandrake 10.1
Posts: 118

Rep: Reputation: 15
I think error is when mounting one of :

none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0

Most possible problematic is /dev/pts.
Your kernel can support udev instead of /dev/pts file system.
You can hash-out this line, or recompile the kernel
 
Old 02-12-2005, 02:07 PM   #7
sirrus_linux
LQ Newbie
 
Registered: Sep 2004
Location: India
Distribution: Fedora Core 2
Posts: 11

Original Poster
Rep: Reputation: 0
Ok .... After lots of curses and kernel configurations and recompiling about 6 to 8 times all i could figure out was that i had missed out to include support for /dev/pts in my kernel .config file and as if that was not enough i had also forgotten to include support for the ¨tmpfs¨ -- which is support for virtual temopary file systems in the .config file ........... just these two corrections and the boot procedure hummed along smoothly.

A heartfelt thanks to you all who took time out to help me with this silly mistake of mine -- especially mmmm ( what kinda name is that ).

and the lesson to be learnt for others who come across this type of problems -- make sure your kernel has support for ¨ temporary virtual filesystems ¨ included in the .config file also one addtion with out this support in the kernel you will not be able to use konsole to run a terminal session. konsole just starts and loads a blank screen and does nothing. Make sure you take note of this

Thank you once again to all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Mounting Virtual Kernel File Systems satimis Linux From Scratch 4 07-21-2005 10:04 PM
Problem in "Mounting Virtual Kernel File Systems" satimis Linux From Scratch 7 07-05-2005 07:57 AM
Mounting Virtual Kernel File Systems - Help Pls chakkaradeepcc Linux From Scratch 2 05-13-2005 07:53 AM
mounting FAT (not FAT32) file systems w/ 2.4 kernel timsch75 Linux - General 6 11-16-2004 06:17 PM
One of my local file systems /dev/sda9 is not mounting Fairlie Linux - Newbie 8 05-11-2004 12:27 AM


All times are GMT -5. The time now is 05:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration